Bug 15028 - kernel segfaults during system halt
Summary: kernel segfaults during system halt
Status: CLOSED DUPLICATE of bug 15005
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Off (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: Zhang Rui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-10 17:31 UTC by Elvio Basello
Modified: 2010-01-30 17:47 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32.5
Tree: Mainline
Regression: No


Attachments
system information (85.87 KB, text/plain)
2010-01-10 17:31 UTC, Elvio Basello
Details
segmentation fault trace (43 bytes, text/plain)
2010-01-10 17:31 UTC, Elvio Basello
Details

Description Elvio Basello 2010-01-10 17:31:05 UTC
Created attachment 24497 [details]
system information

Hi all,
my linux 2.6.32.3 hangs during system halt with a segmentation
fault on /sbin/poweroff.
The same configuration works fine on linux 2.6.32.2.

As attachment there are system info and a photo I took to report the problem
Comment 1 Elvio Basello 2010-01-10 17:31:42 UTC
Created attachment 24498 [details]
segmentation fault trace
Comment 2 Zhang Rui 2010-01-13 08:43:43 UTC

*** This bug has been marked as a duplicate of bug 15005 ***
Comment 3 Elvio Basello 2010-01-25 15:26:31 UTC
Same segfault on 2.6.32.5
Comment 4 Zhang Rui 2010-01-26 05:38:36 UTC
this is a duplicate of bug 15005 and we don't want to have two bug reports for the same issue.
so please left this bug closed and let's look at the issue in bug report 15005. :)

please re-open it if you don't think it's a duplicate of bug 15005.

*** This bug has been marked as a duplicate of bug 15005 ***
Comment 5 Elvio Basello 2010-01-26 14:42:09 UTC
Yep, that's true, but I don't find how to reopen bug 15005
Comment 6 Zhang Rui 2010-01-27 01:06:14 UTC
we already have a fix for this issue.
could you please try the patch at:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=ea9d8e3f45404d411c00ae67b45cc35c58265bb7
and see if it fixes the problem for you?
If yes, we don't need to re-open that bug.
Comment 7 Elvio Basello 2010-01-27 09:54:06 UTC
I tried the patch, but it does not compile.

kernel/time/clockevents.c: In function 'clockevents_notify':
kernel/time/clockevents.c:262: error: implicit declaration of function 'tick_is_broadcast_device'
make[2]: *** [kernel/time/clockevents.o] Error 1
Comment 8 Zhang Rui 2010-01-28 01:09:06 UTC
hmm, what's the kernel version you're using?
why not get the latest kernel source on Linus' git tree and see if the problem has been fixed?
Comment 9 Elvio Basello 2010-01-30 17:03:43 UTC
I tried the patch on 2.6.32.5.
Latest kernel not segfaulting is 2.6.32.2
Comment 10 Elvio Basello 2010-01-30 17:47:47 UTC
Ok, just compiled 2.6.32.7 and the problem is fixed
Thanks :)

Note You need to log in before you can comment on or make changes to this bug.