Bug 15019 - kbuild changes render kernel image unbootable
Summary: kbuild changes render kernel image unbootable
Status: RESOLVED DUPLICATE of bug 14907
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_i386
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-09 19:34 UTC by Daniel Vetter
Modified: 2010-01-09 20:58 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments
kernel config (62.73 KB, text/x-mpsub)
2010-01-09 19:34 UTC, Daniel Vetter
Details

Description Daniel Vetter 2010-01-09 19:34:41 UTC
Created attachment 24494 [details]
kernel config

HW: IBM Thinkpad X40, 1.2GHz Pentium M, 1.5GB RAM
SW: Debian unstable x86_32, Grub2 boot-loader

Symptoms: Affected kernels refuse to boot. Grub2 seems to be able to load the kernel image (and initrd), but to kernel halts with the following output

Destination address too large

   -- System halted

Via bisecting I've drilled down the problem to the following changesets:
Last-knonw-good: 053fe57ac249a9531c396175778160d9e9509399
First-known-bad: 91d161857ce9672bd2a8cd99ff712a67186e2e76

I haven't bisected further because compiling kernels takes ages on this box and the buildsystem changes in this area force a full recompile every time I've tested a new kernel. Furthermore quite a few kernels I've tested in-between refused to properly compile, so I've given up.

I've reverted the complete kbuild merge for .33 like this:

    Revert "Merge branch 'for-33' of git://repo.or.cz/linux-kbuild"
    
    This reverts commit 5a865c0606eb44d5d12cabb429751c83712183de, reversing
    changes made to 331d9d5958277de27e6ce42247e1cbec54fd1c7e.

... on top of a recent -linus. This works around the problem.
Comment 1 H. Peter Anvin 2010-01-09 20:58:28 UTC
It's a known problem, and a fix is on the way.  In the meantime, change the kernel compression to GZIP.

*** This bug has been marked as a duplicate of bug 14907 ***

Note You need to log in before you can comment on or make changes to this bug.