Bug 15012 - Slow resume from RAM on Panasonic Y7c laptop (30s)
Slow resume from RAM on Panasonic Y7c laptop (30s)
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 blocking
Assigned To: Harald Welte
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2010-01-09 07:57 UTC by John Fremlin
Modified: 2013-12-10 17:21 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.31-11 Ubuntu
Tree: Mainline
Regression: No


Attachments
Full dmesg (76.82 KB, text/plain)
2010-01-09 07:57 UTC, John Fremlin
Details
sudo acpidump --output (196.83 KB, application/octet-stream)
2010-01-26 09:50 UTC, John Fremlin
Details

Description John Fremlin 2010-01-09 07:57:22 UTC
Created attachment 24487 [details]
Full dmesg

Resume from RAM takes 30s or more.
[19433.160502] PM: resume devices took 34.120 seconds

Maybe related to

[19432.480489] PM: Device MAT0019:00 failed to resume: error -22

This device is provided by the panasonic-laptop module.
Comment 1 Zhang Rui 2010-01-26 07:38:29 UTC
please attach the acpidump output of your laptop.
Comment 2 Zhang Rui 2010-01-26 07:40:26 UTC
It seems that we failed to evaluate SSET method in acpi_pcc_hotkey_resume.
cc Harald.
Comment 3 John Fremlin 2010-01-26 09:50:20 UTC
Created attachment 24715 [details]
sudo acpidump --output

The ACPI dump (after a fresh reboot without any s2ram)
Comment 4 Zhang Rui 2010-02-24 03:31:37 UTC
bug is blocked because it seems that Harald is not active anymore...
Comment 5 Zhang Rui 2010-03-10 03:20:28 UTC
cc Matthew, who will be the maintainer of all platform drivers. :p
Maybe we need someone to volunteer to maintain the panasonic-laptop driver.
Comment 6 Matthew Garrett 2010-03-10 21:03:32 UTC
The only place I can see this stalling is in the call to EC83 (via ECBF, EC0B). Some kind of conflict with the EC driver at resume time? ECST gets set when the _REG method is called, so we shouldn't be following the =0 path.

Note You need to log in before you can comment on or make changes to this bug.