Bug 15006 - Network testing packet generator (NET_PKTGEN) module breaks suspend to ram
Network testing packet generator (NET_PKTGEN) module breaks suspend to ram
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216 56331
  Show dependency treegraph
 
Reported: 2010-01-08 07:49 UTC by Ciprian Dorin Craciun
Modified: 2013-04-09 06:23 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32.3
Tree: Mainline
Regression: No


Attachments
`dmesg` output (142.32 KB, text/plain)
2010-01-08 07:53 UTC, Ciprian Dorin Craciun
Details
kernel config (69.36 KB, text/plain)
2010-01-08 07:55 UTC, Ciprian Dorin Craciun
Details
`dmesg` for a working build (66.10 KB, text/plain)
2010-01-18 07:30 UTC, Ciprian Dorin Craciun
Details
Net / pktgen: Fix freezing (432 bytes, patch)
2010-01-29 20:50 UTC, Rafael J. Wysocki
Details | Diff

Description Ciprian Dorin Craciun 2010-01-08 07:49:39 UTC
(Note: I'm not sure if I should submit this bug to the "Power management" or "Networking" component, so please correct me.)

So, the problem is simple (at least to diagnostic):
* when enabling `CONFIG_NET_PKTGEN=y`,
* and I try to suspend to ram (by either `s2ram -f`, or manually with `echo mem >/proc/...`,
* the system fails to suspend with the following error in `dmesg`:
~~~~~~~~
[   36.576132] Freezing user space processes ... (elapsed 0.00 seconds) done.
[   36.576215] Freezing remaining freezable tasks ... 
[   49.493737] psmouse.c: TouchPad at isa0060/serio1/input0 lost sync at byte 1
[   56.577262] 
[   56.577265] Freezing of tasks failed after 20.00 seconds (2 tasks refusing to freeze):
[...snip...]
[   56.582777]  kpktgend_0
[   56.582779]  kpktgend_1
[   56.582783] 
[   56.582785] Restarting tasks ... done.
~~~~~~~~

How I've solved it: I've disabled the module with `CONFIG_NET_PKTGEN=n`.

Attached is my config file and dmesg output. (One note about the config file: every module I think I'll ever use is built inside the kernel (`=y`), so the resulting kernel is large (7MB), and thus the problem may arise only in corroboration with one of the modules I've enabled.)
Comment 1 Ciprian Dorin Craciun 2010-01-08 07:53:44 UTC
Created attachment 24481 [details]
`dmesg` output
Comment 2 Ciprian Dorin Craciun 2010-01-08 07:55:15 UTC
Created attachment 24482 [details]
kernel config
Comment 3 Zhang Rui 2010-01-18 02:48:59 UTC
please also attach the dmesg output when CONFIG_NET_PKTGEN=n.
Comment 4 Ciprian Dorin Craciun 2010-01-18 07:30:28 UTC
Created attachment 24613 [details]
`dmesg` for a working build
Comment 5 Rafael J. Wysocki 2010-01-29 20:50:10 UTC
Created attachment 24782 [details]
Net / pktgen: Fix freezing

Sorry for the delay.

Can you please test with this patch applied?
Comment 6 Rafael J. Wysocki 2010-01-29 23:15:41 UTC
And with CONFIG_NET_PKTGEN=y, of course.
Comment 7 Ciprian Dorin Craciun 2010-02-02 11:26:57 UTC
Thanks! I confirm that your patch works when applied on top of the latest 2.6.32.7. (Of course with CONFIG_NET_PKTGEN=y, and checked to see if I have kpktgend kernel threads.)
Comment 8 Rafael J. Wysocki 2010-02-02 20:05:14 UTC
Handled-By : Rafael J. Wysocki <rjw@sisk.pl>
Comment 9 Rafael J. Wysocki 2010-02-02 20:05:44 UTC
Thanks for testing, I'll push the patch upstream soon.

Note You need to log in before you can comment on or make changes to this bug.