Bug 14980 - (aj2r) ath9k/AR9285 - WEP cannot connect, WPA unstable connection
(aj2r)
ath9k/AR9285 - WEP cannot connect, WPA unstable connection
Status: CLOSED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: network-wireless
i386 Linux
: P1 blocking
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-03 12:21 UTC by aj2r
Modified: 2010-10-12 13:52 UTC (History)
10 users (show)

See Also:
Kernel Version: Ubuntu 2.6.31-16-generic
Tree: Mainline
Regression: No


Attachments

Description aj2r 2010-01-03 12:21:25 UTC
Distribution: Ubuntu 9.10
Kernel version: 2.6.31-16
Device: 04:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Problem Description:
    - Low signal strength
    - Cannot connect to wireless networks
Using linux-backports-modules-karmic or the latest linux-wireless snapshot (20091211):
    - Low signal strength persists
    - Can connect to WPA networks but signal strengh is low and unstable, also when using at the same time a Bluetooth USB dongle (scan or transmission) the wireless connection is lost.
    - Cannot connect to WEP networks, although the WEP key is set correctly and the device is associated to the AP
Comment 1 hall900 2010-01-05 22:20:40 UTC
Distribution: Ubuntu 9.10
Kernel version: 2.6.31-16
Device: Atheros Communications Inc. AR9285 Wireless
Network Adapter (PCI-Express) (rev 01)

Description:
Connection Problems with WEP doesn't work and WAP has low signal stregnh and doesn't work if using a bluetooth USB dongle at the same time.
Comment 2 dpp 2010-01-06 09:02:20 UTC
Distribution: Ubuntu 9.10
Kernel version: 2.6.31-16
Device: Atheros Communications Inc. AR9285 Wireless
Network Adapter (PCI-Express) (rev 01)

Description:
Low signal strength.
The device is associated to the AP but cannot connect to WEP networks.
Comment 3 aj2r 2010-01-10 11:33:09 UTC
With the new latest linux-wireless snapshot (20100106) seems to work well. Thanks
Comment 4 aj2r 2010-01-12 16:18:45 UTC
Problems with WPA networks when using at the same time a Bluetooth USB dongle (scan or transmission) persists. With WEP encryption I can use BlueTooth without problems.
Comment 5 aj2r 2010-01-14 17:32:22 UTC
With snapshot 2010-01-13 the problem persists
Comment 6 John W. Linville 2010-03-03 16:49:12 UTC
Sounds like a bluetooth coexistence problem?  Can the Atheros guys chime-in?
Comment 7 Luis R. Rodriguez 2010-03-04 00:44:34 UTC
A few notes:

1) 2.6.31 is deprecated. It is no longer supported upstream on kernel.org, use at least 2.6.32.

2) If you want to use bleeding edge snapshots of compat-wireless based on linux-next I encourage you to report issues on the linux-wireless mailing list:

http://bugzilla.kernel.org/show_bug.cgi?id=14980

3) Bluetooth hogs up the 2.4 GHz spectrum and its usage requires coordination of different sorts to not create interference with 802.11 devices on the same 2.4 GHz band. Because of this bug report I've created this set of documention:

http://wireless.kernel.org/en/users/Documentation/Bluetooth-coexistence
http://wireless.kernel.org/en/users/Drivers/ath9k/btcoex

Hope it helps.
Comment 8 Matteo Rossi 2010-03-21 13:23:55 UTC
With kernel 2.6.32 (Ubuntu 10.04 Alpha 3 - package 2.6.32-16) chip AR9285 has very poor and unstable performance compared to Windows 7. Browsers are very slow in loading pages, and file transfers from another computer on the LAN are slow (max 300 kbps) and are often canceled.
From dmesg I can see that the chip does not re-associate.
Bluetooth is switched off.

I'm connected to a 802.11g connection encrypted with WPA2 in a room next to the router.

Using latest compat-wireless daily build does not seem to solve the problem.

Sorry if I'm not quantitative but I don't know which information would be usefull, so please let me know if any tests are necessary.

$ iwlist wlan0 scan

wlan0     Scan completed :
          Cell 01 - Address: 00:14:6C:6A:79:64
                    Channel:5
                    Frequency:2.432 GHz (Channel 5)
                    Quality=47/70  Signal level=-63 dBm  
                    Encryption key:on
                    ESSID:"WIFI_ROSSI"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000000084c93b10
                    Extra: Last beacon: 8440ms ago
                    IE: Unknown: 000A574946495F524F535349
                    IE: Unknown: 010482848B96
                    IE: Unknown: 030105
                    IE: Unknown: 2A0104
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32088C129824B048606C
Comment 9 Slig 2010-04-03 00:19:07 UTC
Exactly same issues with my Sony Vaio VPCEB1S1E which is also based on AR9285 wifi chip. On Ubuntu 2.6.31, when downloading large files connection stops frequently for some time and resumes on its own. Web pages loading is slow and frequently "locks". At first I've installed backports driver - no effect. Next I've compiled latest ath9k driver from sources (compat-wireless-2.6.tar.bz2 tarball) - no effect. Also tried to uninstall network-mananager and replace it with wicd - no effect. On Ubuntu 10.04 beta1 kernel 2.6.32 - all the same issues.

On Windows 7 - no such issues, everything works flawlessly.

My AP is configured as WPA2-PSK AES (also tried TKIP).

If there are any test that can help debug this issue plase let me know and I'll perform them.
Comment 10 Slig 2010-04-03 16:56:40 UTC
I've managed to disable ath9k module and configure ndiswrapper with WinXP driver version 7.7.0 - exactly same issues as with ath9k, network slowdowns and "lockups" especially with large files, but no link dropdowns. On Windows 7 I have installed driver version 8.0.0, but I can't find this driver in zip package 32 bit version to test it on Ubuntu. I suppose it is somewhat improbable that ath9k and windows driver 7.7.0 share the same bug. I don't know what could be the reason of such behaviour and how to test it further. Also noticed that wifi network speed under Win7 sometimes reaches even 2.9 MB/s (downloading large file from LAN), while on Ubuntu my top speed is about 1.8 MB/s - downloading the same file.
Comment 11 Slig 2010-04-20 14:19:31 UTC
I've installed madwifi driver + patch with ar9285 support on Ubuntu 10.04 (2.6.32-21-generic). With this driver wifi works much more stable than with ath9k. No download cut-offs and transfer speed is far better.
Comment 12 John W. Linville 2010-08-13 15:53:36 UTC
Does this problem persist with 2.6.35 (or later) kernels?
Comment 13 John W. Linville 2010-10-04 19:28:05 UTC
Closing due to lack of response -- please reopen if/when the requested information becomes available...
Comment 14 newbeewan 2010-10-12 13:45:40 UTC
Hi,

I think I encountered that issue I post some informations here : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=577555

Regards
Comment 15 Matteo Rossi 2010-10-12 13:52:12 UTC
I have updated ubuntu to 10.10 based on kernel 2.6.35 and I haven't noticed any improvement. Performance is still unacceptable. Using madwifi driver (properly patched to work with ar9285), performance is enormously better

http://madwifi-project.org/

Note You need to log in before you can comment on or make changes to this bug.