Bug 14961 - Very old and buggy ARCMSR drivers are included
Summary: Very old and buggy ARCMSR drivers are included
Status: CLOSED OBSOLETE
Alias: None
Product: SCSI Drivers
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 high
Assignee: scsi_drivers-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-30 12:38 UTC by mikki
Modified: 2012-06-18 14:20 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.18 etc
Tree: Mainline
Regression: No


Attachments
Latest arcmsr (95 bytes, text/plain)
2009-12-30 12:38 UTC, mikki
Details

Description mikki 2009-12-30 12:38:04 UTC
Created attachment 24377 [details]
Latest arcmsr

Hello,

Some very buggy ARCMSR drivers are included in the kernels dating from early 2008.

The new drivers with the same version number, but a later date exists and should be included instead.

This is the latest ftp://ftp.areca.com.tw/RaidCards/AP_Drivers/Linux/DRIVER/SourceCode/arcmsr.1.20.0X.15-90605.zip

With the older .15 driver i had several system lockups under heavy load.
Comment 1 Andrew Morton 2010-01-06 23:21:38 UTC
On Wed, 30 Dec 2009 12:38:06 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=14961
> 
>            Summary: Very old and buggy ARCMSR drivers are included
>            Product: SCSI Drivers
>            Version: 2.5
>     Kernel Version: 2.6.18 etc
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Other
>         AssignedTo: scsi_drivers-other@kernel-bugs.osdl.org
>         ReportedBy: mikki@hugo.dk
>         Regression: No
> 
> 
> Created an attachment (id=24377)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=24377)
> Latest arcmsr
> 
> Hello,
> 
> Some very buggy ARCMSR drivers are included in the kernels dating from early
> 2008.
> 
> The new drivers with the same version number, but a later date exists and
> should be included instead.
> 
> This is the latest
>
> ftp://ftp.areca.com.tw/RaidCards/AP_Drivers/Linux/DRIVER/SourceCode/arcmsr.1.20.0X.15-90605.zip
> 
> With the older .15 driver i had several system lockups under heavy load.
> 

Well that's bad.  I'm not seeing any commits against that driver from
Areca staff since February 2008.

So it may be that the manufacturer has abandoned this driver.  If so,
then it would be useful if someone who has the hardware could pick
apart the differences between the above driver and the in-kernel
version, and send the updates into the mainline kernel.
Comment 2 nick cheng 2010-01-07 01:50:06 UTC
Hi Andrew,
Areca does not abandon this driver.
We will still keep maintaining it.
Originally I plan to update the driver in the middle of last year.
But there is a lot of emergency to postpone the plan again and again.
I will make time to do it ASAP.
Sorry for you inconvenience.
Comment 3 mikki 2010-09-04 03:38:16 UTC
This has still not been done from what I can see.

Continuing to let a _very_ buggy driver stay in the dist when you know it causes trouble and not keeping promises is something I dont expect for someone providing missioncritical equipment.
Comment 4 Marc Bejarano 2011-04-19 10:56:41 UTC
nick: any ETA on your update?
Comment 5 nick cheng 2011-04-20 02:26:41 UTC
Marc,
I have updated driver to bugzilla several times.
I have no idea why you still ask this.
Do you lost something?
Comment 6 mikki 2011-04-20 18:58:13 UTC
If you have updated the driver please close the ticket Nick.
Comment 7 nick cheng 2011-04-21 01:50:34 UTC
This bug is not opened by me.
Comment 8 mikki 2011-04-21 05:28:39 UTC
No but if you resolved it mark it as resolved. Its hard for me to know if you as a vendor solved the issue.

Note You need to log in before you can comment on or make changes to this bug.