Bug 14947 - Blank screen for Intel KMS
Blank screen for Intel KMS
Status: CLOSED DUPLICATE of bug 14860
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2009-12-29 13:58 UTC by Rafael J. Wysocki
Modified: 2009-12-30 22:27 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-29 13:58:51 UTC
Subject    : Re: Linux 2.6.33-rc2 - Blank screen for Intel KMS
Submitter  : Miguel Calleja <mcalleja1@telecable.es>
Date       : 2009-12-25 13:10
References : http://marc.info/?l=linux-kernel&m=126174693019098&w=4

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit fc816655236cd9da162356e96e74c7cfb0834d92
Author: Zhao Yakui <yakui.zhao@intel.com>
Date:   Tue Nov 24 09:48:45 2009 +0800

    drm/i915: Don't set up HDMI ports that aren't in the BIOS device table.

    Use the child device array to decide whether the given HDMI output should be
    initialized. If the given HDMI port can't be found in child device array,
    it is not present and won't be initialized.

    Signed-off-by: Zhao Yakui <yakui.zhao@intel.com>
    Signed-off-by: Eric Anholt <eric@anholt.net>

First-Bad-Commit : fc816655236cd9da162356e96e74c7cfb0834d92

[rjw: I can reproduce this one.]
Comment 1 Rafael J. Wysocki 2009-12-30 22:27:10 UTC

*** This bug has been marked as a duplicate of bug 14860 ***

Note You need to log in before you can comment on or make changes to this bug.