Bug 14944 - 2.6.32.2 SATA link detect failed, 2.6.32.1 works fine
2.6.32.2 SATA link detect failed, 2.6.32.1 works fine
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Tejun Heo
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2009-12-29 13:44 UTC by Rafael J. Wysocki
Modified: 2010-01-24 21:50 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32.2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-29 13:44:14 UTC
Subject    : 2.6.32.2 SATA link detect failed, 2.6.32.1 works fine
Submitter  : fengxiangjun <fengxiangjun@neusoft.com>
Date       : 2009-12-21 11:12
References : http://marc.info/?l=linux-kernel&m=126139442328314&w=4
Handled-By : Tejun Heo <tj@kernel.org>

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-12-29 13:48:00 UTC
Patch : http://patchwork.kernel.org/patch/69746/
Comment 2 Jim Faulkner 2010-01-09 15:15:35 UTC
I too saw SATA link detection failures on my ata_piix controller under 2.6.32.2.  I see that this patch wasn't part of 2.6.32.3, can we expect it in the next bugfix release?
Comment 3 Rafael J. Wysocki 2010-01-24 21:50:32 UTC
Fixed by commit 5040ab67a2c6d5710ba497dc52a8f7035729d7b0.

Note You need to log in before you can comment on or make changes to this bug.