Bug 14940 - cfq-iosched: tiobench regression
cfq-iosched: tiobench regression
Status: CLOSED DOCUMENTED
Product: IO/Storage
Classification: Unclassified
Component: Block Layer
All Linux
: P1 normal
Assigned To: Jens Axboe
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2009-12-29 13:20 UTC by Rafael J. Wysocki
Modified: 2009-12-30 21:52 UTC (History)
0 users

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-29 13:20:04 UTC
Subject    : cfq-iosched: tiobench regression
Submitter  : Shaohua Li <shaohua.li@intel.com>
Date       : 2009-12-24 0:55
References : http://marc.info/?l=linux-kernel&m=126161612401994&w=4
Notify-Also : Gui Jianfeng <guijianfeng@cn.fujitsu.com>
Notify-Also : Corrado Zoccolo <czoccolo@gmail.com>
Notify-Also : Jens Axboe <jens.axboe@oracle.com>

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-12-30 21:52:14 UTC
On Wednesday 30 December 2009, Jens Axboe wrote:
> On Tue, Dec 29 2009, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.32.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14940
> > Subject		: cfq-iosched: tiobench regression
> > Submitter	: Shaohua Li <shaohua.li@intel.com>
> > Date		: 2009-12-24 0:55 (6 days old)
> > References	: http://marc.info/?l=linux-kernel&m=126161612401994&w=4
> 
> I don't think this should be labelled as a regression. It was already
> known that we'd have less throughput for the many clients cases, it was
> a trade off that was made to improve latencies.

Note You need to log in before you can comment on or make changes to this bug.