Bug 14921 - Successful resume from suspend but freezes after I/O
Successful resume from suspend but freezes after I/O
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-12-28 23:37 UTC by Rafael J. Wysocki
Modified: 2011-01-16 22:11 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.30
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-28 23:37:28 UTC
Subject    : [BISECTED, REGRESSION] Successful resume from suspend but freezes after I/O
Submitter  : Volker Lanz <vl@fidra.de>
Date       : 2009-12-07 17:56
References : http://marc.info/?l=linux-kernel&m=126021054931813&w=4
Handled-By : Yinghai Lu <yinghai@kernel.org>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 78a8b35bc7abf8b8333d6f625e08c0f7cc1c3742
Author: Yinghai Lu <yinghai@kernel.org>
Date:   Thu Mar 12 22:36:01 2009 -0700

    x86: make e820_update_range() handle small range update

    Impact: enhance e820 code to handle more cases

    Try to handle new range which could be covered by one entry.

    Signed-off-by: Yinghai Lu <yinghai@kernel.org>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 78a8b35bc7abf8b8333d6f625e08c0f7cc1c3742
Comment 1 Rafael J. Wysocki 2011-01-16 22:11:11 UTC
This looks like it should have been fixed, closing.

Note You need to log in before you can comment on or make changes to this bug.