Bug 14915 - Reiser4 doesn't sync
Reiser4 doesn't sync
Status: CLOSED OBSOLETE
Product: File System
Classification: Unclassified
Component: Reiser4
All Linux
: P1 normal
Assigned To: ReiseFS developers team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-28 14:33 UTC by Johannes Buchner
Modified: 2012-05-14 15:36 UTC (History)
1 user (show)

See Also:
Kernel Version: 2009-12-10-17-19
Tree: -mm
Regression: No


Attachments

Description Johannes Buchner 2009-12-28 14:33:28 UTC
The current mm patches don't respect 'sync()'.
In particular, reiser4_sync_inodes in fs/reiser4/super_ops.c skips it, due to NULL being handed over.

The skip was introduced by http://userweb.kernel.org/~akpm/mmotm/broken-out/reiser4-fixed-null-pointer-dereference.patch to mitigate a NULL dereference introduced by http://userweb.kernel.org/~akpm/mmotm/broken-out/reiser4-vfs-add-super_operationssync_inodes-2.patch

Note You need to log in before you can comment on or make changes to this bug.