Bug 14909 - pata_cmd64x broken in 2.6.33-rc1
pata_cmd64x broken in 2.6.33-rc1
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2009-12-27 23:59 UTC by Rafael J. Wysocki
Modified: 2009-12-29 22:43 UTC (History)
0 users

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-27 23:59:20 UTC
Subject    : pata_cmd64x broken in 2.6.33-rc1 on sparc64
Submitter  : Meelis Roos <mroos@linux.ee>
Date       : 2009-12-19 22:23
References : http://marc.info/?l=linux-kernel&m=126126142501594&w=4
Notify-Also : linux-ide@vger.kernel.org

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit d43744390e460dce6626fb8de2c02a24ff650005
Author: Alan Cox <alan@linux.intel.com>
Date:   Mon Nov 30 13:22:54 2009 +0000

    pata_cmd64x: implement serialization as per notes

    Signed-off-by: Alan Cox <alan@linux.intel.com>
    Signed-off-by: Jeff Garzik <jgarzik@redhat.com>

First-Bad-Commit : d43744390e460dce6626fb8de2c02a24ff650005
Comment 1 Jeff Garzik 2009-12-28 00:00:42 UTC
Fix is in mainline:

commit 06393afde321b0fd7626b2d0966ebcaf6077de93
Author: Jeff Garzik <jeff@garzik.org>
Date:   Sun Dec 20 15:39:55 2009 -0500

    Revert "pata_cmd64x: implement serialization as per notes"
Comment 2 Rafael J. Wysocki 2009-12-29 22:43:19 UTC
On Tuesday 29 December 2009, Meelis Roos wrote:
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14909
> > Subject		: pata_cmd64x broken in 2.6.33-rc1
> > Submitter	: Meelis Roos <mroos@linux.ee>
> > Date		: 2009-12-19 22:23 (11 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=d43744390e460dce6626fb8de2c02a24ff650005
> > References	: http://marc.info/?l=linux-kernel&m=126126142501594&w=4
> 
> Fixed as of 2.6.33-rc2 - just retested the upstream fix.

Note You need to log in before you can comment on or make changes to this bug.