Bug 14907 - Commit "kbuild: fix bzImage build for x86" breaks build
Commit "kbuild: fix bzImage build for x86" breaks build
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Configuration
All Linux
: P1 normal
Assigned To: other_configuration@kernel-bugs.osdl.org
:
: 14848 14952 15019 (view as bug list)
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2009-12-27 23:51 UTC by Rafael J. Wysocki
Modified: 2010-01-14 20:35 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-27 23:51:58 UTC
Subject    : Also on x86 - was: 2.6.33-rc1: hrtimers and tickless broken on m68knommu.
Submitter  : Oliver Hartkopp <oliver@hartkopp.net>
Date       : 2009-12-19 19:21
References : http://marc.info/?l=linux-kernel&m=126125050622195&w=4

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 4a2ff67c88211026afcbdbc190c13f705dae1b59
Author: Michael Tokarev <mjt@tls.msk.ru>
Date:   Tue Oct 13 22:22:46 2009 +0200

    kbuild: fix bzImage build for x86

    Signed-Off-By: Michael Tokarev <mjt@tls.msk.ru>
    Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
    Signed-off-by: Michal Marek <mmarek@suse.cz>

First-Bad-Commit : 4a2ff67c88211026afcbdbc190c13f705dae1b59
Comment 1 Rafael J. Wysocki 2009-12-28 23:49:10 UTC
References : http://marc.info/?l=linux-kernel&m=126114565103300&w=4
Comment 2 Rafael J. Wysocki 2009-12-29 14:56:40 UTC
*** Bug 14848 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan Nieder 2010-01-02 16:29:45 UTC
References : http://marc.info/?l=linux-kbuild&m=126202819526623&w=2
Comment 4 Rafael J. Wysocki 2010-01-05 22:56:22 UTC
*** Bug 14952 has been marked as a duplicate of this bug. ***
Comment 5 H. Peter Anvin 2010-01-09 20:58:28 UTC
*** Bug 15019 has been marked as a duplicate of this bug. ***
Comment 6 Rafael J. Wysocki 2010-01-10 18:53:23 UTC
Handled-By : Jonathan Nieder <jrnieder@gmail.com>
Patch : http://thread.gmane.org/gmane.linux.kbuild.devel/4313/focus=4319
Patch : http://patchwork.kernel.org/patch/71957/
Comment 7 Rafael J. Wysocki 2010-01-12 22:04:06 UTC
On Tuesday 12 January 2010, Oliver Hartkopp wrote:
> Rafael J. Wysocki wrote:
> > On Monday 11 January 2010, Jonathan Nieder wrote:
> >> Rafael J. Wysocki wrote:
> >>
> >>> The following bug entry is on the current list of known regressions
> >>> from 2.6.32.  Please verify if it still should be listed and let me know
> >>> (either way).
> >>>
> >>>
> >>> Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14907
> >>> Subject		: Commit "kbuild: fix bzImage build for x86" breaks build
> >>> Submitter	: Oliver Hartkopp <oliver@hartkopp.net>
> >>> Date		: 2009-12-19 19:21 (23 days old)
> >>> Handled-By	: Jonathan Nieder <jrnieder@gmail.com>
> >>> Patch		: http://thread.gmane.org/gmane.linux.kbuild.devel/4313/focus=4319
> >>> 		  http://patchwork.kernel.org/patch/71957/
> >> I am using the patch without problems, but it is not in the mainline
> >> as of v2.6.33-rc3-git3.  So please do keep the bug listed.
> > 
> > I will, thanks for the update.
> 
> I just tested the patch again - and it fixes the problem.
> 
> You can add my
> 
> Tested-by: Oliver Hartkopp <oliver@hartkopp.net>
>
Comment 8 Rafael J. Wysocki 2010-01-14 20:35:15 UTC
On Thursday 14 January 2010, Michal Marek wrote:
> On 13.1.2010 13:33, Michal Marek wrote:
> > On 11.1.2010 02:36, Jonathan Nieder wrote:
> >> Rafael J. Wysocki wrote:
> >>
> >>> The following bug entry is on the current list of known regressions
> >>> from 2.6.32.  Please verify if it still should be listed and let me know
> >>> (either way).
> >>>
> >>>
> >>> Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14907
> >>> Subject		: Commit "kbuild: fix bzImage build for x86" breaks build
> >>> Submitter	: Oliver Hartkopp <oliver@hartkopp.net>
> >>> Date		: 2009-12-19 19:21 (23 days old)
> >>> First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=4a2ff67c88211026afcbdbc190c13f705dae1b59
> >>> References	: http://marc.info/?l=linux-kernel&m=126125050622195&w=4
> >>> 		  http://marc.info/?l=linux-kernel&m=126114565103300&w=4
> >>> 		  http://marc.info/?l=linux-kbuild&m=126202819526623&w=2
> >>> Handled-By	: Jonathan Nieder <jrnieder@gmail.com>
> >>> Patch		: http://thread.gmane.org/gmane.linux.kbuild.devel/4313/focus=4319
> >>> 		  http://patchwork.kernel.org/patch/71957/
> >>
> >> I am using the patch without problems, but it is not in the mainline
> >> as of v2.6.33-rc3-git3.  So please do keep the bug listed.
> > 
> > I resent the pull request (http://lkml.org/lkml/2010/1/13/194), let's see.
> 
> FYI:
> commit 04e9e5c7659ee07f0387ddb663913fadcca88d5f
> Merge: cedabed 0710520
> Author: Linus Torvalds <torvalds@linux-foundation.org>
> Date:   Wed Jan 13 16:09:59 2010 -0800
> 
>     Merge branch 'for-33' of git://repo.or.cz/linux-kbuild
> 
>     * 'for-33' of git://repo.or.cz/linux-kbuild:
>       Makefile: do not override LC_CTYPE
>       kbuild: really fix bzImage build with non-bash sh
>

Note You need to log in before you can comment on or make changes to this bug.