Bug 14897 - i915: Commit 0e442c60 causes flickering
i915: Commit 0e442c60 causes flickering
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-12-27 23:09 UTC by Rafael J. Wysocki
Modified: 2010-02-07 13:19 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: Yes


Attachments
remove lvds downclock (719 bytes, patch)
2010-01-12 18:14 UTC, Jesse Barnes
Details | Diff
2.6.33-rc3 config (90.67 KB, application/octet-stream)
2010-01-13 04:44 UTC, David
Details
Kernel Log (47.50 KB, application/octet-stream)
2010-01-13 04:45 UTC, David
Details
DMI Info (11.94 KB, application/octet-stream)
2010-01-13 04:45 UTC, David
Details
PCI Info (11.67 KB, application/octet-stream)
2010-01-13 04:46 UTC, David
Details
X Log (56.71 KB, application/octet-stream)
2010-01-13 04:47 UTC, David
Details
try the patch that fixes the incorrect cursor A bit definition (935 bytes, patch)
2010-01-14 07:01 UTC, ykzhao
Details | Diff

Description Rafael J. Wysocki 2009-12-27 23:09:43 UTC
Subject    : [Regression] i915: Commit 0e442c60 causes flickering in 2.6.32
Submitter  : David John <davidjon@xenontk.org>
Date       : 2009-12-09 17:26
References : http://marc.info/?l=linux-kernel&m=126037889600769&w=4

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.

Reportedly caused by:

commit 0e442c60dd39ac6924b11a20497734bd2303744c
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Mon Oct 19 10:09:33 2009 +0900

    drm/i915: add FIFO watermark support for G4x

    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
    Signed-off-by: Eric Anholt <eric@anholt.net>

First-Bad-Commit : 0e442c60dd39ac6924b11a20497734bd2303744c
Comment 1 Rafael J. Wysocki 2009-12-30 21:34:22 UTC
On Wednesday 30 December 2009, David John wrote:
> On 12/29/2009 08:58 PM, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.31 and 2.6.32.
<> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.31 and 2.6.32.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14897
> > Subject		: i915: Commit 0e442c60 causes flickering
> > Submitter	: David John <davidjon@xenontk.org>
> > Date		: 2009-12-09 17:26 (21 days old)
...
> This regression along with the associated one:
> http://marc.info/?l=linux-kernel&m=126044443222694&w=2 is still present
> in 2.6.33-rc2.
Comment 2 ykzhao 2010-01-02 13:45:37 UTC
Hi, John
    Will you please confirm whether the issue still exists if you always use the internal LVDS? This means that the external VGA is not used.

    Will you please provide more hardware info about your laptop? For example:
hardware model, dmidecode, lspci -vxxx

Thanks.
Comment 3 Rafael J. Wysocki 2010-01-11 19:52:06 UTC
On Monday 11 January 2010, David John wrote:
> On 01/11/2010 04:26 AM, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.31 and 2.6.32.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.31 and 2.6.32.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14897
> > Subject		: i915: Commit 0e442c60 causes flickering
> > Submitter	: David John <davidjon@xenontk.org>
> > Date		: 2009-12-09 17:26 (33 days old)
> 
> Still present in 2.6.33-rc3.
Comment 4 Jesse Barnes 2010-01-12 18:13:47 UTC
David, please see above.  Also please check out the attached patch and see if it resolves the flicker.
Comment 5 Jesse Barnes 2010-01-12 18:14:20 UTC
Created attachment 24522 [details]
remove lvds downclock

Turn off LVDS downclock for testing.
Comment 6 David 2010-01-13 04:37:08 UTC
(In reply to comment #2)
> Hi, John
>     Will you please confirm whether the issue still exists if you always use
> the internal LVDS? This means that the external VGA is not used.
> 
>     Will you please provide more hardware info about your laptop? For example:
> hardware model, dmidecode, lspci -vxxx
> 
> Thanks.

Hi Yakui Zhao,

Sorry for the late reply.

No, the issue does not occur if only LVDS is used. My original post wasn't very detailed and seemed to imply that only LVDS was at fault, so I'll try and explain the behaviour I see:

My machine is a Dell Inspiron 1545 (DMI, dmesg, config, X and PCI info attached) with an Acer H233 connected to external VGA. I use only the external
display so the internal LVDS is switched off on X start.

Case 1:

The problem can be triggered with the following sequence of steps:

1) X starts: Both LVDS and VGA powered on.
2) LVDS switched off with: xrandr --output LVDS1 --off

(No problems here)

3) Switch to any console: Ctrl+Alt+Fx

(Heavy console flicker, unusable).

4) Switch back to X: Ctrl+Alt+F1

(Heavy X flicker, almost unusable. The flicker stops on key press and starts up again with screen refresh on mouse move).

To stop the flicker, the LVDS has to be turned back on with: xrandr --output LVDS1 --auto. It is easily reproducible by starting from step 2 again. 

Case 2: With 2.6.32, the same sequence of steps resulted in heavy flicker on LVDS if the VGA output was switched off instead. Basically, it triggers if one output is off and one on.

Reverting commits 0e442c60 and 0d9c778978 fixes the problem, which is what I currently use with 2.6.32.

NEW:

Case 3:

With 2.6.33-rc3 however, Case 2 no longer occurs, but if LVDS is kept on and VGA is powered off, on switching to console, VGA automatically powers back on. However, switching back to X freezes the VGA output (with the console screen contents). You have to turn VGA on manually with --auto. Flicker does not occur in this case. I think this might be a separate bug, so I'm looking into it.

I hope this is not too confusing :)
Comment 7 David 2010-01-13 04:38:34 UTC
(In reply to comment #5)
> Created an attachment (id=24522) [details]
> remove lvds downclock
> 
> Turn off LVDS downclock for testing.

Hi Jesse,

This patch does not fix the problem. I have a given a more detailed description in the reply to Yakui. Hope that helps.
Comment 8 David 2010-01-13 04:44:41 UTC
Created attachment 24531 [details]
2.6.33-rc3 config
Comment 9 David 2010-01-13 04:45:21 UTC
Created attachment 24532 [details]
Kernel Log
Comment 10 David 2010-01-13 04:45:49 UTC
Created attachment 24533 [details]
DMI Info
Comment 11 David 2010-01-13 04:46:26 UTC
Created attachment 24534 [details]
PCI Info
Comment 12 David 2010-01-13 04:47:00 UTC
Created attachment 24535 [details]
X Log
Comment 13 David 2010-01-13 04:51:28 UTC
One more note: The "[drm] DAC-6: set mode 1920x1080 c" at the end of the kernel log is the VGA output automatically powering back on with 2.6.33-rc3 when switching to a console.
Comment 14 ykzhao 2010-01-14 07:01:52 UTC
Created attachment 24546 [details]
try the patch that fixes the incorrect cursor A bit definition

Hi, 
   Will you please try the attached debug patch and see whether the flicker issue can be fixed?
   Thanks.
Comment 15 David 2010-01-14 09:18:46 UTC
(In reply to comment #14)
> Created an attachment (id=24546) [details]
> try the patch that fixes the incorrect cursor A bit definition
> 
> Hi, 
>    Will you please try the attached debug patch and see whether the flicker
> issue can be fixed?
>    Thanks.

Hi Yakui,

This does not fix the issue. I will try and do some debugging over the weekend, but will not be available till Tuesday.

Thx,
David.
Comment 16 ykzhao 2010-01-15 05:54:09 UTC
Will you please attach the output of intel_reg_dumper when the issue happens?

thanks.
Comment 17 Rafael J. Wysocki 2010-01-27 20:57:04 UTC
On Wednesday 27 January 2010, David John wrote:
> On 01/27/2010 06:14 PM, Pekka Enberg wrote:
> > On Mon, Jan 25, 2010 at 12:23 AM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> >> This message has been generated automatically as a part of a report
> >> of regressions introduced between 2.6.31 and 2.6.32.
... 
> > David, bunch of i915 flickering fixes have gone into 2.6.33-rc5. Is
> > this still a problem?
> > 
> 
> Yes, this is a separate issue the cause of which I've informed Jesse
> about today. I've sent a patch but it needs reviewing. So the entry
> should still be open.
Comment 18 Rafael J. Wysocki 2010-01-27 21:08:56 UTC
Handled-By : David John <davidjon@xenontk.org>
Patch : http://patchwork.kernel.org/patch/75423/
Comment 19 Rafael J. Wysocki 2010-02-07 13:14:14 UTC
On Sunday 07 February 2010, David John wrote:
> On 02/03/2010 02:25 AM, Rafael J. Wysocki wrote:
> > On Monday 01 February 2010, David John wrote:
> >> On 02/01/2010 06:13 AM, Rafael J. Wysocki wrote:
> >>> This message has been generated automatically as a part of a report
> >>> of regressions introduced between 2.6.31 and 2.6.32.
> >>>
> >>> The following bug entry is on the current list of known regressions
> >>> introduced between 2.6.31 and 2.6.32.  Please verify if it still should
> >>> be listed and let me know (either way).
> >>>
> >>>
> >>> Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14897
> >>> Subject		: i915: Commit 0e442c60 causes flickering
> >>> Submitter	: David John <davidjon@xenontk.org>
> >>> Date		: 2009-12-09 17:26 (54 days old)
> 
> This regression entry can now be closed, it's fixed by the upstream
> commit 33c5fd12 (drm/i915: Disable SR when more than one pipe is enabled).

Note You need to log in before you can comment on or make changes to this bug.