Bug 14892 - intel, KMS, suspend2ram resume, screen black
intel, KMS, suspend2ram resume, screen black
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2009-12-27 22:41 UTC by Rafael J. Wysocki
Modified: 2010-01-13 21:52 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-27 22:41:57 UTC
Subject    : intel, KMS, suspend2ram resume, screen black
Submitter  : Norbert Preining <preining@logic.at>
Date       : 2009-11-24 4:35
References : http://marc.info/?l=linux-kernel&m=125903731125558&w=4

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Norbert Preining 2009-12-30 04:31:01 UTC
Yes it is an regression. There is already a bug report here: 14722 where a patch is posted.

Please merge these two bugs.

Yes, it is still present in 2.6.32.2

Best

Norbert
Comment 2 Haggy 2009-12-30 10:39:18 UTC
Confirmed on 2.6.32.2 for me as well. Note i can reactivate the display by Hitting Fn + Output (which toggles between external VGA connector and the display of my notebook).
Comment 3 Rafael J. Wysocki 2010-01-13 21:51:52 UTC
Fixed by commit a2565377a5c31e25c77c7cabaf6752abe9a2d83a .

Note You need to log in before you can comment on or make changes to this bug.