Bug 14891 - Deadlock regression related to NFS root
Deadlock regression related to NFS root
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Arnaldo Carvalho de Melo
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-12-27 22:39 UTC by Rafael J. Wysocki
Modified: 2011-02-02 10:40 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31.5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-27 22:39:42 UTC
Subject    : Deadlock regression in v2.6.31.6
Submitter  : "Stephen R. van den Berg" <srb@cuci.nl>
Date       : 2009-11-24 0:24
References : http://marc.info/?l=linux-kernel&m=125902279909452&w=4
Handled-By : Trond Myklebust <Trond.Myklebust@netapp.com>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-02-02 10:40:34 UTC
No one in the cc, 

this got probably fixed in 2.6.35 with 
commit 301e99ce4a2f42a317129230fd42e6cd874c64b0
Author: Neil Brown <neilb@suse.de>
Date:   Sun Feb 28 22:01:05 2010 -0500

    nfsd: ensure sockets are closed on error

Note You need to log in before you can comment on or make changes to this bug.