Bug 14890 - [WMI?] boot hang
[WMI?] boot hang
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Anisse Astier
:
Depends on:
Blocks: 14885 56331
  Show dependency treegraph
 
Reported: 2009-12-27 22:11 UTC by Rafael J. Wysocki
Modified: 2013-04-09 06:23 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.33-rc2
Tree: Mainline
Regression: Yes


Attachments
Patch to fix hp-wmi regression. (853 bytes, patch)
2009-12-28 11:17 UTC, Anisse Astier
Details | Diff

Description Rafael J. Wysocki 2009-12-27 22:11:08 UTC
Subject    : [2.6.33-rc2] [ACPI] [WMI?] boot hang
Submitter  : Maciej Rutecki <maciej.rutecki@gmail.com>
Date       : 2009-12-25 10:10
References : http://marc.info/?l=linux-kernel&m=126173586309724&w=4

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-12-27 22:14:19 UTC
References : http://marc.info/?l=linux-kernel&m=126170348921630&w=4
Notify-Also : Sedat Dilek <sedat.dilek@googlemail.com>

Caused by:

commit 3e9b988e4edf065d39c1343937f717319b1c1065
Author:     Anisse Astier <anisse@astier.eu>
Commiter:   Len Brown <len.brown@intel.com>
CommitDate: Thu Dec 24 00:42:00 2009 -0500

    wmi: Free the allocated acpi objects through wmi_get_event_data

    These function allocate an acpi object by calling wmi_get_event_data, which
    then calls acpi_evaluate_object, and it is not freed afterwards.

    And kernel doc is fixed for parameters of wmi_get_event_data.

    Signed-off-by: Anisse Astier <anisse@astier.eu>
    Acked-by: Randy Dunlap <randy.dunlap@oracle.com>
    Acked-by: Carlos Corbacho <carlos@strangeworlds.co.uk>
    Signed-off-by: Len Brown <len.brown@intel.com>

First-Bad-Commit : 3e9b988e4edf065d39c1343937f717319b1c1065
Comment 2 Zhang Rui 2009-12-28 01:24:05 UTC
re-assign to Anisse
Comment 3 Anisse Astier 2009-12-28 11:17:51 UTC
Created attachment 24326 [details]
Patch to fix hp-wmi regression.

Please tell me if this patch fixes the problem. The reverted commit is already in acpi-test, but this should be a cleaner fix.
Comment 4 Zhang Rui 2009-12-29 01:15:29 UTC
please re-open it if the patch doesn't work for you.
Comment 5 Rafael J. Wysocki 2010-01-10 22:16:39 UTC
Fixed by commit c9c041fcb1a4d69ed4791f00b57554eeb341d148 .

Note You need to log in before you can comment on or make changes to this bug.