Bug 14889 - System wakeup by time not working anymore
System wakeup by time not working anymore
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PNP
All Linux
: P1 normal
Assigned To: Adam Belay
:
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2009-12-27 22:07 UTC by Rafael J. Wysocki
Modified: 2010-01-11 22:29 UTC (History)
0 users

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: Yes


Attachments
rtc_cmos-fix (1.47 KB, patch)
2009-12-29 22:12 UTC, OGAWA Hirofumi
Details | Diff

Description Rafael J. Wysocki 2009-12-27 22:07:41 UTC
Subject    : [REGRESSION] System wakeup by time not working anymore on 2.6.32
Submitter  : Malte Schröder <maltesch@gmx.de>
Date       : 2009-12-03 18:06
References : http://marc.info/?l=linux-kernel&m=125986362631900&w=4
Notify-Also : Len Brown <lenb@kernel.org>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.

Reportedly caused by:

commit abd6633c67925f90775bb74755f9c547e30f1f20
Author: David Härdeman <david@hardeman.nu>
Date:   Mon Sep 21 17:04:52 2009 -0700

    pnp: add a shutdown method to pnp drivers
    
    The shutdown method is used by the winbond cir driver to setup the
    hardware for wake-from-S5.
    
    Signed-off-by: Bjorn Helgaas <bjorn.helgaas@hp.com>
    Signed-off-by: David Härdeman <david@hardeman.nu>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>

First-Bad-Commit : abd6633c67925f90775bb74755f9c547e30f1f20
Comment 1 Rafael J. Wysocki 2009-12-29 14:59:14 UTC
*** Bug 14927 has been marked as a duplicate of this bug. ***
Comment 2 OGAWA Hirofumi 2009-12-29 22:12:52 UTC
Created attachment 24365 [details]
rtc_cmos-fix

Specified commit would break the pnp driver which is using
driver->shutdown.
Comment 3 Rafael J. Wysocki 2009-12-30 21:31:35 UTC
Handled-By : OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>
Patch : http://patchwork.kernel.org/patch/70212/

Note You need to log in before you can comment on or make changes to this bug.