Bug 14887 - suspend doesn't work on X200s
suspend doesn't work on X200s
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 14885
  Show dependency treegraph
 
Reported: 2009-12-27 21:00 UTC by Rafael J. Wysocki
Modified: 2010-01-04 20:15 UTC (History)
0 users

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-12-27 21:00:52 UTC
Subject    : [2.6.33-rc1 regression] suspend doesn't work on X200s
Submitter  : Andrew Lutomirski <luto@mit.edu>
Date       : 2009-12-22 0:45
References : http://marc.info/?l=linux-kernel&m=126144274102396&w=4

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-12-30 21:37:11 UTC
On Wednesday 30 December 2009, Jens Axboe wrote:
> On Tue, Dec 29 2009, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.32.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14887
> > Subject		: suspend doesn't work on X200s
> > Submitter	: Andrew Lutomirski <luto@mit.edu>
> > Date		: 2009-12-22 0:45 (8 days old)
> > References	: http://marc.info/?l=linux-kernel&m=126144274102396&w=4
> 
> Works fine for me on an x200s. The only issue I seem to have is that
> sometimes it suspends immediately upon resume again, presumably the lid
> close event is re-triggered (or something to that extent). Apart from
> that, 2.6.32 and current -git works fine for me.
Comment 2 Rafael J. Wysocki 2010-01-04 20:15:18 UTC
Fixed by 0c69774e6ce94364cfaa8bdeb18061edc414bc5a .

Note You need to log in before you can comment on or make changes to this bug.