Bug 14865 - eeepc-laptop: touchpad led is inverted on Eee1001HAG
eeepc-laptop: touchpad led is inverted on Eee1001HAG
Status: RESOLVED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Corentin Chary
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-12-23 17:39 UTC by Simeon Maryasin
Modified: 2013-04-09 06:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: No


Attachments
simple patch which fixed problem for me (442 bytes, patch)
2009-12-23 17:39 UTC, Simeon Maryasin
Details | Diff
/proc/acpi/dsdt (I hope it is what you told about...) (32.11 KB, application/octet-stream)
2009-12-29 17:12 UTC, Simeon Maryasin
Details
acpidump for 1005ha (157.52 KB, application/octet-stream)
2009-12-30 18:54 UTC, Andrej Gelenberg
Details

Description Simeon Maryasin 2009-12-23 17:39:43 UTC
Created attachment 24264 [details]
simple patch which fixed problem for me

There is support for eeepc 1005 etc touchpad led. But on my EeePC 1001 HAG it behaves as:
after boot /sys/devices/platform/eeepc/leds/eeepc::touchpad/brightness == 0 and led is off;
when I do 'echo 1 > /sys/devices/platform/eeepc/leds/eeepc::touchpad/brightness', it becomes ==1, but led is still off;
when I do 'echo 0 > /sys/devices/platform/eeepc/leds/eeepc::touchpad/brightness', it becomes ==0, and led is now on.
Unfortunately I hadn't chance to test on EeePC 1005, maybe it is 1001's issue.
Comment 1 Zhang Rui 2009-12-28 01:23:09 UTC
re-assign to Henrique.
Comment 2 Henrique de Moraes Holschuh 2009-12-28 12:53:12 UTC
Sorry Zhang, but I don't take care of Eee-PC ;-)

Maybe you wanted someone else?
Comment 3 Zhang Rui 2009-12-29 01:17:34 UTC
oops.
re-assign to Corentin. :p
Comment 4 Corentin Chary 2009-12-29 08:12:11 UTC
Could you send me your dsdt ?
Thanks
Comment 5 Simeon Maryasin 2009-12-29 17:12:44 UTC
Created attachment 24352 [details]
/proc/acpi/dsdt (I hope it is what you told about...)
Comment 6 Andrej Gelenberg 2009-12-30 18:54:20 UTC
Created attachment 24379 [details]
acpidump for 1005ha
Comment 7 Corentin Chary 2009-12-31 08:10:22 UTC
Hum,(In reply to comment #6)
> Created an attachment (id=24379) [details]
> acpidump for 1005ha

Thanks, the code for touchpad seems to be the same. Andrej, can you reproduce this bug on your 1005ha ?
Comment 8 Zhang Rui 2010-02-21 07:07:11 UTC
ping...
Comment 9 Zhang Rui 2010-03-10 03:16:39 UTC
close this bug as there is no response for more than 3 months.
Comment 10 Simeon Maryasin 2010-03-10 05:26:06 UTC
Which data is needed? Can I help? (I have not 1005ha...)
Comment 11 Zhang Rui 2010-03-10 05:32:42 UTC
Corentin,
does the patch in comment #0 make sense?
the dsdt of semen's laptop is attached in comment #5.
Comment 12 Corentin Chary 2010-03-11 15:29:48 UTC
(In reply to comment #11)
> Corentin,
> does the patch in comment #0 make sense?
> the dsdt of semen's laptop is attached in comment #5.

The patch make sense for this model, but I don't know if it won't break on over models with touchpad led, and I didn't get any answer about that (here, and on the mailing list).

Maybe we should apply the patch and wait for a regression report, but I'm not sure that this is a really good practice ...
Comment 13 Michael Perlov 2011-06-07 12:45:46 UTC
Reproducable on 1005HA as well, patch from https://bugzilla.kernel.org/show_bug.cgi?id=14865#c0 fixed the problem (kernel-2.6.34.9).
Comment 14 Corentin Chary 2011-06-07 13:05:46 UTC
1xxx models should not use eeepc-laptop, they should use eeepc-wmi instead. Please reopen this bug if a model below 1000 is affected or if eeepc-wmi is also affected.
Comment 15 Simeon Maryasin 2011-06-07 20:16:55 UTC
(In reply to comment #14)
> 1xxx models should not use eeepc-laptop, they should use eeepc-wmi instead.

I just tried to use eeepc-wmi, but couldn't load module:

# modprobe eeepc-wmi
FATAL: Error inserting eeepc_wmi (/lib/modules/3.6.38-gentoo/kernel/drivers/platform/x86/eeepc_wmi.ko): No such device
# dmesg | tail
<...>
[ 5486.078107] wmi: Mapper loaded
[ 6586.102116] eeepc_wmi: No known WMI GUID found

My device is EeePC 1001 HAG. eeepc-laptop works fine (but with this led bug). Maybe WMI works only for newer models such as 1001PX?..
Comment 16 Corentin Chary 2011-06-08 05:21:20 UTC
I guess 1001HA and 1001HAG are the same. if yes you probably need to update your bios. The latest bios update is BIOS 1401 - 2010.03.15.

Note You need to log in before you can comment on or make changes to this bug.