Bug 14863 - Resume from suspend fails on intel 4965 AGN
Resume from suspend fails on intel 4965 AGN
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 high
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2009-12-23 02:50 UTC by Javier Jardón
Modified: 2010-01-04 19:35 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.32.1
Tree: Mainline
Regression: Yes


Attachments

Description Javier Jardón 2009-12-23 02:50:38 UTC
Distribution: Ubuntu Lucid
Kernel version: 2.6.32.9.9
Environment used for testing: Dell XPS 1330 (All Intel)

All the info (lspci, dmesg....) are attached in the downstream bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/499221

I mark this as a regression because I have karmic installed too (2.6.31.16.29 kernel) and suspend/resume works.
Comment 1 Javier Jardón 2009-12-23 03:03:07 UTC
I think the problem is the suspend/resume of the wireless card (intel 4965 AGN) because after disabling wireless network through the networmanager-applet suspend/resume works again without problems.
Comment 2 Zhu Yi 2009-12-31 02:03:10 UTC
Do you mean suspend is successful but during resume there is nothing show up in the screen (even kernel is not started)? Looks like a BIOS related issue.
Comment 3 Javier Jardón 2010-01-04 04:49:10 UTC
The problem is gone after installing the 2.6.33rc2 kernel from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33-rc2/
Comment 4 Rafael J. Wysocki 2010-01-04 19:35:01 UTC
Good, closing.

Note You need to log in before you can comment on or make changes to this bug.