Bug 14862 - intel-agp breaks X, regression from 2.6.31
intel-agp breaks X, regression from 2.6.31
Status: CLOSED DUPLICATE of bug 14627
Product: Drivers
Classification: Unclassified
Component: Video(AGP)
All Linux
: P1 normal
Assigned To: Dave Airlie
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-12-22 22:59 UTC by Zephaniah E. Hull.
Modified: 2009-12-29 21:31 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: Yes


Attachments

Description Zephaniah E. Hull. 2009-12-22 22:59:47 UTC
This has been bisected down to commit 1755168, which reworked the PCI DMI API stuff for the Intel IOMMU support.

On 2.6.32 if I disable USE_PCI_DMA_API everything works again, with it enabled I get a mouse cursor but corrupted frame buffer.

This is an HP/Compaq 6710b with GM965 integrated video, on Ubuntu 9.10.

Without this fix 2.6.32 is unusable on this hardware.
(Console works, but.)

Zephaniah E. Hull.
Comment 1 Rafael J. Wysocki 2009-12-29 21:31:28 UTC

*** This bug has been marked as a duplicate of bug 14627 ***

Note You need to log in before you can comment on or make changes to this bug.