Bug 14861 - brightness on Samsung Q1
brightness on Samsung Q1
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-12-22 03:35 UTC by a3990208
Modified: 2013-04-09 06:23 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments
acpidump (82.88 KB, application/octet-stream)
2009-12-22 19:52 UTC, a3990208
Details
lspci (2.02 KB, application/octet-stream)
2009-12-23 16:29 UTC, a3990208
Details

Description a3990208 2009-12-22 03:35:25 UTC
the brightness is not available on this UMPC
Comment 1 ykzhao 2009-12-22 05:38:05 UTC
Please attach the output of acpidump on this box.

thanks.
Comment 2 a3990208 2009-12-22 19:52:11 UTC
Created attachment 24258 [details]
acpidump

This is my output of acpidump
Comment 3 Zhang Rui 2009-12-23 06:00:15 UTC
There is no ACPI backlight control methods available on this UMPC.
so this is not an ACPI bug.
what graphics are you using?
please attach the lspci output.
Comment 4 a3990208 2009-12-23 16:29:23 UTC
Created attachment 24263 [details]
lspci

It has a 915GM intel graphic. Is it possible to have in the future release of Kernel Linux same method for backlight? 
This is lspci.
Comment 5 Zhang Rui 2009-12-24 01:01:25 UTC
No. this is done is the BIOS...
Comment 6 a3990208 2009-12-24 03:17:55 UTC
But in Windows i can change it
Comment 7 zhenyuw 2009-12-28 06:45:07 UTC
Please test with new 'samsung-laptop' kernel driver, with recent xf86-video-intel release, to see if backlight can work on your samsung.
Comment 8 a3990208 2009-12-28 20:37:16 UTC
Where can i find samsung-laptop kernel driver? i use xf86-video-intel v 2.9.1 on gentoo
Comment 9 zhenyuw 2009-12-29 01:06:11 UTC
It's not relate to xf86-video-intel. Check if gentoo kernel already has 'samsung-laptop' module (e.g modprobe samsung-laptop), if not you have to build kernel with staging driver and make sure CONFIG_SAMSUNG_LAPTOP is on.
Comment 10 a3990208 2009-12-29 04:19:44 UTC
I checked in my .config of kernel 2.6.32, but there isn't CONFIG_SAMSUNG_LAPTOP. samsung-laptop.c miss in drivers/platform/x86/
Comment 11 zhenyuw 2009-12-29 05:09:49 UTC
It's under drivers/staging/samsung-laptop/
Comment 12 a3990208 2009-12-29 07:52:17 UTC
ok, i compiled kernel 2.6.33-rc2 with samsung laptop driver (on 2.6.32 this driver not exist), but backlight still not works
Comment 13 Greg Kroah-Hartman 2010-01-02 05:57:08 UTC
The samsung-laptop driver does not support this device, sorry.

It will not work with the dri driver, a special bios-mode call needs
to be made.

Patches are gladly accepted to add support for this device to the samsung-laptop driver, but I can not create them, myself.
Comment 14 Jesse Barnes 2010-02-26 22:40:25 UTC
Does http://patchwork.kernel.org/patch/81187/ help?
Comment 15 Jesse Barnes 2010-07-23 19:34:33 UTC
Another backlight dupe: https://bugs.freedesktop.org/show_bug.cgi?id=26664

Note You need to log in before you can comment on or make changes to this bug.