Bug 14852 - Sleep/resume cycle causes video display to freeze after some time
Sleep/resume cycle causes video display to freeze after some time
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: ykzhao
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-12-21 00:52 UTC by Jean-Pierre Demailly
Modified: 2013-04-09 06:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32.x
Tree: Mainline
Regression: Yes


Attachments
lspci + dmesg output (43.40 KB, text/plain)
2009-12-21 00:53 UTC, Jean-Pierre Demailly
Details

Description Jean-Pierre Demailly 2009-12-21 00:52:16 UTC
I own a MSI Wind U100 netbook (specs below) and I have a reproducible
problem with kernels 2.6.32.x which did not occur with 2.6.31.x, related
possibly to a regression in the ACPI layer. (I have checked that this affects the mainline kernel already.) The system otherwise runs the most recent Debian sid distribution (Sidux) with Xorg-server 1.6.5 on an Intel video chip 945GME; same
problem occurs with the sidux kernel 2.6.32.2.

It happens randomly (one time out of 3 or 4) that suspend fails, leaving the
machine in active state but with video freezed. In other circumstances, the suspend/resume cycle works but after some time (a few minutes at most), the video display starts to blink briefly - this affects both the X session and the console sessions; then blinking becomes more and more frequent and after some time the video display freezes completely; the system then still reacts to keyboard input, however, and can be for instance rebooted by using Ctrl-Alt-F1 Ctrl-Alt-Del from the freezed X session.

There may be a connection with the Atheros wireless driver (r8169), since 
a prior "rmmod r8169" seems to help avoiding immediate freezes. This does not
solve the problem either.

Jean-Pierre Demailly
Comment 1 Jean-Pierre Demailly 2009-12-21 00:53:55 UTC
Created attachment 24239 [details]
lspci + dmesg output
Comment 2 Zhang Rui 2009-12-22 01:33:57 UTC
this seems like a graphics problem to me.
RE-assign to Yakui.
Comment 3 ykzhao 2009-12-22 01:38:42 UTC
Hi,
    Will you please try the following patch and see whether the issue still exists?
    >http://lists.freedesktop.org/archives/intel-gfx/2009-December/005143.html

Thanks.
Comment 4 Jean-Pierre Demailly 2009-12-23 16:21:23 UTC
Unfortunately, the above patch from comment #3 does not solve the issue. The incorrect behavior of video display after sleep/resume cycle is unchanged.
Comment 5 Jean-Pierre Demailly 2010-01-23 11:12:34 UTC
Issue seems to be cleared with kernel 2.6.32.5 and Xorg 1.7.4. Maybe version 1.6.5 of Xorg and corresponding drm didn't have good enough hooks with changes introduced in 2.6.32. In any case issue appears much less of a problem now,
as few users will probably have bad combination of kernel/Xorg/hardware ...
Comment 6 Jesse Barnes 2010-07-23 19:32:24 UTC
Ok, thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.