Bug 14833 - Duplicated directories
Duplicated directories
Status: CLOSED OBSOLETE
Product: File System
Classification: Unclassified
Component: CIFS
All Linux
: P1 normal
Assigned To: Jeff Layton
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-18 16:09 UTC by Vladimir Stavrinov
Modified: 2012-06-18 13:20 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments

Description Vladimir Stavrinov 2009-12-18 16:09:54 UTC
I didn't notice this new bug at the first time 
testing, but now it is look like if it is originating from the patch for this bug: http://bugzilla.kernel.org/show_bug.cgi?id=14641. In any
way the fact is that after successful booting I see some duplicated
directories: /etc, /usr and /var at the root level. But there are some others
in the depth. This have some side effects. For example, the gdm chooser can not
find any hosts on the net. This bug appear in the my patched 2.6.31 kernel and
new one recently came the 2.6.32. If You think it is aufs related bug, than You
should take in account that there are no such problem with the same kernels and
live cd, because there are no cifs.
Comment 1 Jeff Layton 2009-12-18 20:28:09 UTC
If you mount up this directory using CIFS without AUFS in the picture, does the problem still occur?
Comment 2 Vladimir Stavrinov 2009-12-21 13:47:09 UTC
(In reply to comment #1)
> If you mount up this directory using CIFS without AUFS in the picture, does the
> problem still occur?

There are no such effect after mount neither cifs nor aufs. Duplicated directories does not appear within initrd stage at all, but there are other error like "usermod: command not found" that point out that there are something wrong with file system. It need more deep investigation.
Comment 3 Jeff Layton 2009-12-21 13:52:30 UTC
I'm so(In reply to comment #2)
> (In reply to comment #1)
> > If you mount up this directory using CIFS without AUFS in the picture, does the
> > problem still occur?
> 
> There are no such effect after mount neither cifs nor aufs.

I'm sorry, I'm having a hard time understanding exactly what you tested here. Are you saying that you don't see this problem when you just mount a plain CIFS share? Or does the problem only occur at particular times?

I'm a little confused as to what sort of filesystem layout you're using here as well (i.e. what sort of filesystems are mounted in what locations).
Comment 4 Vladimir Stavrinov 2009-12-21 14:19:33 UTC
(In reply to comment #3)
> I'm sorry, I'm having a hard time understanding exactly what you tested here.

Testing environment described in previous bug "cifs crash":

http://bugzilla.kernel.org/show_bug.cgi?id=14641

You have take part in that discussion: it is debian live project in netboot variant. That is cifs is used as root fs to boot system.
Comment 5 Jeff Layton 2009-12-21 14:22:58 UTC
Right...and if I understand correctly, in that setup you're using CIFS as one of the AUFS layers.

The question I had was, if you mount up this share as a plain CIFS share (i.e. without AUFS) do you also see these duplicated directories. It wasn't clear to me whether you had done this and if so, what the result was.
Comment 6 Vladimir Stavrinov 2009-12-21 14:35:11 UTC
I don't do nothing. All work is done by initrd and init scripts at boot time. What I am doing is debugging. In this case I have turned on debug mode (that is set -x -v shell option) and insert ls / command after two mount commannds (cifs and aufs). In both cases I don't see duplicated directories.
Comment 7 Vladimir Stavrinov 2009-12-22 13:10:14 UTC
I have add "ls /" command after every script in /etc/rcS.d directory and turned on bootlogd. I see duplicated directories in console, but not in log file. It is very strange. That is why I don't see them at initrd stage: the output was done into log.
Comment 8 Jeff Layton 2010-01-31 12:00:58 UTC
I suspect that this problem is actually the same as the one in bug 15088. Could you try adding "noserverino" to the mount options and see if this is still reproducible?
Comment 9 Vladimir Stavrinov 2010-01-31 14:26:14 UTC
On Sun, Jan 31, 2010 at 12:00:59PM +0000, bugzilla-daemon@bugzilla.kernel.org wrote:

> --- Comment #8 from Jeff Layton <jlayton@redhat.com>  2010-01-31 12:00:58 ---
> I suspect that this problem is actually the same as the one in bug 15088. Could
> you try adding "noserverino" to the mount options and see if this is still
> reproducible?

I will do this tomorrow. Wait.
 
**********************************
****   Vladimir Stavrinov   ******
*******   vs@inist.ru   **********
*****   http://inist.ru/   *******
**********************************
Comment 10 Vladimir Stavrinov 2010-02-01 16:40:11 UTC
On Sun, Jan 31, 2010 at 12:00:59PM +0000, bugzilla-daemon@bugzilla.kernel.org wrote:

> --- Comment #8 from Jeff Layton <jlayton@redhat.com>  2010-01-31 12:00:58 ---
> I suspect that this problem is actually the same as the one in bug 15088. Could
> you try adding "noserverino" to the mount options and see if this is still
> reproducible?

Done. It has no effect. No ideas.

I have placed break points after cifs and aufs mounts (inserting
"/bin/sh -i" line) - there are no duplicated directories. The problem
arise somewhere later in the initrd, but not in the init scripts,
because it exists even with init=/bin/bash kernel command line
parameter.

Something mysterious. I think, we need help from debian-live developers,
but they don't replay
Comment 11 Vladimir Stavrinov 2010-02-01 16:47:14 UTC
On Mon, Feb 01, 2010 at 07:39:24PM +0300, Vladimir Stavrinov wrote:

 
> Something mysterious. I think, we need help from debian-live developers,
> but they don't replay
                 ^^^^^^

Sorry, I mean "they don't reply".

Note You need to log in before you can comment on or make changes to this bug.