Bug 14745 - usb-storage oops with Alcor USB flash card reader
usb-storage oops with Alcor USB flash card reader
Status: RESOLVED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-06 03:34 UTC by Alex Wauck
Modified: 2012-02-22 21:47 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments
The backtrace from dmesg (4.37 KB, text/plain)
2009-12-06 03:34 UTC, Alex Wauck
Details
Output of linux_ver (1.43 KB, text/plain)
2009-12-06 03:35 UTC, Alex Wauck
Details

Description Alex Wauck 2009-12-06 03:34:48 UTC
Created attachment 24044 [details]
The backtrace from dmesg

Bus 002 Device 002: ID 058f:6364 Alcor Micro Corp.

The oops frequently occurs immediately after inserting a SD card, although the most recent oops occurred when unmounting the card after successfully mounting it and copying data from it.

I am running a 2.6.32 kernel from the Ubuntu mainline kernels repository.  This problem occurred with the Ubuntu 2.6.31 kernel as well.
Comment 1 Alex Wauck 2009-12-06 03:35:20 UTC
Created attachment 24045 [details]
Output of linux_ver
Comment 2 Andrew Morton 2009-12-07 21:43:40 UTC
(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Sun, 6 Dec 2009 03:34:49 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=14745
> 
>            Summary: usb-storage oops with Alcor USB flash card reader
>            Product: Drivers
>            Version: 2.5
>     Kernel Version: 2.6.32
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: USB
>         AssignedTo: greg@kroah.com
>         ReportedBy: alex.wauck@gmail.com
>         Regression: No
> 
> 
> Created an attachment (id=24044)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=24044)
> The backtrace from dmesg
> 
> Bus 002 Device 002: ID 058f:6364 Alcor Micro Corp.
> 
> The oops frequently occurs immediately after inserting a SD card, although the
> most recent oops occurred when unmounting the card after successfully mounting
> it and copying data from it.
> 
> I am running a 2.6.32 kernel from the Ubuntu mainline kernels repository.  This
> problem occurred with the Ubuntu 2.6.31 kernel as well.
> 
> -- 
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.

> [  294.074711] sd 8:0:0:0: [sdc] 15523840 512-byte logical blocks: (7.94 GB/7.40 GiB)
> [  294.075693] sd 8:0:0:0: [sdc] Assuming drive cache: write through
> [  294.077066] sd 8:0:0:0: [sdc] Assuming drive cache: write through
> [  294.077073]  sdc: sdc1
> [  482.131317] usb 2-3: reset high speed USB device using ehci_hcd and address 2
> [  482.283140] BUG: unable to handle kernel NULL pointer dereference at 0000000000000038
> [  482.283156] IP: [<ffffffff81334ca0>] dev_get_drvdata+0x10/0x30
> [  482.283175] PGD 37884067 PUD 7ac01067 PMD 0
> [  482.283184] Oops: 0000 [#1] SMP
> [  482.283191] last sysfs file: /sys/devices/pci0000:00/0000:00:13.2/usb2/2-3/2-3:1.0/bInterfaceSubClass
> [  482.283198] CPU 1
> [  482.283202] Modules linked in: nls_iso8859_1 nls_cp437 vfat fat binfmt_misc ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ipt_REJECT xt_tcpudp bridge stp ppdev kvm_amd kvm radeon ttm drm_kms_helper drm i2c_algo_bit snd_emu10k1_synth snd_emux_synth snd_hda_codec_atihdmi snd_seq_virmidi snd_seq_midi_emul snd_hda_codec_realtek snd_emu10k1 snd_ac97_codec snd_hda_intel ac97_bus snd_hda_codec snd_util_mem snd_pcm_oss snd_mixer_oss snd_seq_dummy snd_pcm snd_hwdep snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device snd emu10k1_gp iptable_filter lp ip_tables k8temp asus_atk0110 parport x_tables soundcore snd_page_alloc amd64_edac_mod edac_core psmouse serio_raw gameport i2c_piix4 ohci1394 ieee1394 usb_storage usbhid atl1 mii
> [  482.283312] Pid: 425, comm: usb-storage Not tainted 2.6.32-020632-generic #020632 System Product Name
> [  482.283318] RIP: 0010:[<ffffffff81334ca0>]  [<ffffffff81334ca0>] dev_get_drvdata+0x10/0x30
> [  482.283329] RSP: 0018:ffff88007ababcd0  EFLAGS: 00010206
> [  482.283333] RAX: 0000000000000000 RBX: ffff88007a004000 RCX: ffffffff813b38f9
> [  482.283338] RDX: 0000000000000000 RSI: 0000000000000292 RDI: 0000000000000030
> [  482.283344] RBP: ffff88007ababcd0 R08: ffff88007abaa000 R09: ffffffff817cad10
> [  482.283349] R10: 0000000000000000 R11: 0000000000000000 R12: ffff88007b3b9600
> [  482.283354] R13: ffff88007d19c000 R14: ffff88007a004000 R15: ffff88007b33e000
> [  482.283360] FS:  00007fa5fd9c4770(0000) GS:ffff880001c80000(0000) knlGS:00000000f6a1d750
> [  482.283366] CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
> [  482.283370] CR2: 0000000000000038 CR3: 000000003794b000 CR4: 00000000000006e0
> [  482.283376] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
> [  482.283381] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
> [  482.283387] Process usb-storage (pid: 425, threadinfo ffff88007abaa000, task ffff88007a020000)
> [  482.283391] Stack:
> [  482.283394]  ffff88007ababcf0 ffffffffa0017771 ffff88007a004000 ffff88007b3b9600
> [  482.283403] <0> ffff88007ababd10 ffffffffa0017813 ffff88007d19c000 ffff88007a006880
> [  482.283412] <0> ffff88007ababd50 ffffffffa00178af ffff88007ababd30 ffff88007b3b9600
> [  482.283422] Call Trace:
> [  482.283438]  [<ffffffffa0017771>] usbhid_restart_ctrl_queue+0x21/0xa0 [usbhid]
> [  482.283451]  [<ffffffffa0017813>] usbhid_restart_queues+0x23/0x30 [usbhid]
> [  482.283462]  [<ffffffffa00178af>] hid_post_reset+0x8f/0xc0 [usbhid]
> [  482.283472]  [<ffffffff813addf5>] usb_reset_device+0xe5/0x180
> [  482.283487]  [<ffffffffa0029e1c>] usb_stor_port_reset+0x5c/0x60 [usb_storage]
> [  482.283500]  [<ffffffffa002aece>] usb_stor_invoke_transport+0x1be/0x3b0 [usb_storage]
> [  482.283512]  [<ffffffff81531f79>] ? wait_for_common+0x119/0x160
> [  482.283525]  [<ffffffff810543f0>] ? default_wake_function+0x0/0x10
> [  482.283537]  [<ffffffffa0029c99>] usb_stor_transparent_scsi_command+0x9/0x10 [usb_storage]
> [  482.283551]  [<ffffffffa002bf12>] usb_stor_control_thread+0x162/0x240 [usb_storage]
> [  482.283563]  [<ffffffffa002bdb0>] ? usb_stor_control_thread+0x0/0x240 [usb_storage]
> [  482.283572]  [<ffffffff8107f36e>] kthread+0x8e/0xa0
> [  482.283581]  [<ffffffff8101302a>] child_rip+0xa/0x20
> [  482.283588]  [<ffffffff8107f2e0>] ? kthread+0x0/0xa0
> [  482.283595]  [<ffffffff81013020>] ? child_rip+0x0/0x20
> [  482.283598] Code: 4c 89 ee 48 c7 c7 ba 4a 33 81 ff d0 49 8b 07 48 85 c0 75 da e9 55 fe ff ff 90 90 55 48 85 ff 48 89 e5 75 07 c9 31 c0 c3 0f 1f 00 <48> 8b 47 08 48 85 c0 74 f0 48 8b 80 88 00 00 00 c9 c3 66 66 66
> [  482.283667] RIP  [<ffffffff81334ca0>] dev_get_drvdata+0x10/0x30
> [  482.283676]  RSP <ffff88007ababcd0>
> [  482.283679] CR2: 0000000000000038
> [  482.283685] ---[ end trace d2a71b6ffc804db9 ]---
> 
>
Comment 3 Matthew Dharm 2009-12-08 05:24:06 UTC
On Mon, Dec 07, 2009 at 01:43:37PM -0800, Andrew Morton wrote:
> 
> > [  482.283438]  [<ffffffffa0017771>] usbhid_restart_ctrl_queue+0x21/0xa0 [usbhid]
> > [  482.283451]  [<ffffffffa0017813>] usbhid_restart_queues+0x23/0x30 [usbhid]
> > [  482.283462]  [<ffffffffa00178af>] hid_post_reset+0x8f/0xc0 [usbhid]
> > [  482.283472]  [<ffffffff813addf5>] usb_reset_device+0xe5/0x180
> > [  482.283487]  [<ffffffffa0029e1c>] usb_stor_port_reset+0x5c/0x60 [usb_storage]
> > [  482.283500]  [<ffffffffa002aece>] usb_stor_invoke_transport+0x1be/0x3b0 [usb_storage]
> > [  482.283512]  [<ffffffff81531f79>] ? wait_for_common+0x119/0x160

Does this device have some HID component also?  It looks like something
went pear-shaped, usb-storage tried a port-reset, and then hid OOPSed...

Matt

-- 
Matthew Dharm                              Home: mdharm-usb@one-eyed-alien.net 
Maintainer, Linux USB Mass Storage Driver

What, are you one of those Microsoft-bashing Linux freaks?
					-- Customer to Greg
User Friendly, 2/10/1999
Comment 4 Anonymous Emailer 2009-12-08 09:40:53 UTC
Reply-To: jkosina@suse.cz

On Mon, 7 Dec 2009, Andrew Morton wrote:

> > Bus 002 Device 002: ID 058f:6364 Alcor Micro Corp.
> > 
> > The oops frequently occurs immediately after inserting a SD card, although the
> > most recent oops occurred when unmounting the card after successfully mounting
> > it and copying data from it.
[ ... ]
> > [  482.283140] BUG: unable to handle kernel NULL pointer dereference at 0000000000000038
> > [  482.283156] IP: [<ffffffff81334ca0>] dev_get_drvdata+0x10/0x30
[ ... ]
> > [  482.283438]  [<ffffffffa0017771>] usbhid_restart_ctrl_queue+0x21/0xa0 [usbhid]
> > [  482.283451]  [<ffffffffa0017813>] usbhid_restart_queues+0x23/0x30 [usbhid]
> > [  482.283462]  [<ffffffffa00178af>] hid_post_reset+0x8f/0xc0 [usbhid]
> > [  482.283472]  [<ffffffff813addf5>] usb_reset_device+0xe5/0x180
> > [  482.283487]  [<ffffffffa0029e1c>] usb_stor_port_reset+0x5c/0x60 [usb_storage]
> > [  482.283500]  [<ffffffffa002aece>] usb_stor_invoke_transport+0x1be/0x3b0 [usb_storage]
> > [  482.283512]  [<ffffffff81531f79>] ? wait_for_common+0x119/0x160
> > [  482.283525]  [<ffffffff810543f0>] ? default_wake_function+0x0/0x10
> > [  482.283537]  [<ffffffffa0029c99>] usb_stor_transparent_scsi_command+0x9/0x10 [usb_storage]
> > [  482.283551]  [<ffffffffa002bf12>] usb_stor_control_thread+0x162/0x240 [usb_storage]
> > [  482.283563]  [<ffffffffa002bdb0>] ? usb_stor_control_thread+0x0/0x240 [usb_storage]
> > [  482.283572]  [<ffffffff8107f36e>] kthread+0x8e/0xa0
> > [  482.283581]  [<ffffffff8101302a>] child_rip+0xa/0x20
> > [  482.283588]  [<ffffffff8107f2e0>] ? kthread+0x0/0xa0
> > [  482.283595]  [<ffffffff81013020>] ? child_rip+0x0/0x20

What kind of device is this? Does it have both mass-storage and HID 
interfaces?

Thanks,
Comment 5 Alex Wauck 2009-12-08 13:59:01 UTC
>
> What kind of device is this? Does it have both mass-storage and HID
> interfaces?
>

This is the device in question:
http://www.newegg.com/Product/Product.aspx?Item=N82E16820300608

Since the device reset seems to be what triggers the oops, is there a way to
trigger a USB device reset manually?  I would like to see if I can get the
oops to happen without the card reader attached.

Also, all USB HID devices work fine after the oops, but the card reader no
longer works.

Alex
Comment 6 Alex Wauck 2009-12-08 14:02:06 UTC
(I'm resending this because Gmail sent a HTML mail the first time, and
it was rejected by linux-usb.)

> What kind of device is this? Does it have both mass-storage and HID
> interfaces?


This is the device in question:
http://www.newegg.com/Product/Product.aspx?Item=N82E16820300608

Since the device reset seems to be what triggers the oops, is there a
way to trigger a USB device reset manually?  I would like to see if I
can get the oops to happen without the card reader attached.

Also, all USB HID devices work fine after the oops, but the card
reader no longer works.

Alex
Comment 7 Anonymous Emailer 2009-12-08 14:06:12 UTC
Reply-To: oliver@neukum.org

Am Dienstag, 8. Dezember 2009 15:02:03 schrieb Alex Wauck:
> This is the device in question:
> http://www.newegg.com/Product/Product.aspx?Item=N82E16820300608
> 
> Since the device reset seems to be what triggers the oops, is there a
> way to trigger a USB device reset manually?  I would like to see if I
> can get the oops to happen without the card reader attached.

You can reset a device via libusb.

	Regards
		Oliver
Comment 8 Alex Wauck 2009-12-08 14:45:09 UTC
I tried manually resetting the USB HID devices on my system without
the card reader attached, and I did not get any oopses.  I will try
resetting USB devices again next time I have the card reader attached.

Alex
Comment 9 Alan Stern 2009-12-08 15:32:23 UTC
On Tue, 8 Dec 2009, Oliver Neukum wrote:

> You can reset a device via libusb.

Attached is a program to do it for you.  You run it like this:

	./usbreset /dev/bus/usb/001/002

where, of course, you must give it the correct device file in 
/dev/bus/usb.

Alan Stern
Comment 10 Alex Wauck 2009-12-12 17:43:30 UTC
I have repeated the experiment with the card reader attached.
Resetting the USB HID devices did not have any effect.  When resetting
the card reader, my USB reset program hung (not killable even with
kill -9) in the call to usb_reset and the same oops appeared in dmesg.
 Subsequently running lsusb resulted in a similar hang in lsusb.
Attempting to run my USB reset program again resulted in a hang in
usb_find_devices.

Alex
Comment 11 Marko Kohtala 2010-01-15 07:36:55 UTC
I have an A-Link UCH 3-PORT USB 2.0 HUB with memory card reader. I keep getting an oops that may be related to this bug. I have no cards inserted. The A-Link is quite crappy and the reader does not work, but if it finds a bug in kernel then it is ok... ha.

I have tried the same device in a PC, and the PC hanged completely (not even numlock worked). I did not have any opportunity to see any dmesg yet.

Here is the console output up to the oops.

Linux version 2.6.32 (steve@www.sakoman.com) (gcc version 4.3.3 (GCC) ) #1 Sun Jan 10 21:07:48 PST 2010
CPU: ARMv7 Processor [411fc083] revision 3 (ARMv7), cr=10c53c7f
CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
Machine: Gumstix Overo
Memory policy: ECC disabled, Data cache writeback
OMAP3430/3530 ES3.1 (l2cache iva sgx neon isp )
SRAM: Mapped pa 0x40200000 to va 0xfe400000 size: 0x100000
Reserving 12582912 bytes SDRAM for VRAM
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 65024
Kernel command line: console=ttyS2,115200n8 vram=12M omapfb.mode=dvi:1024x768MR-16@60 omapfb.debug=y omapdss.def_disp=lcd43 root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait
PID hash table entries: 1024 (order: 0, 4096 bytes)
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 128MB 128MB = 256MB total
Memory: 240512KB available (5220K code, 596K data, 932K init, 0K highmem)
Hierarchical RCU implementation.
NR_IRQS:402
Clocking rate (Crystal/Core/MPU): 26.0/331/500 MHz
Reprogramming SDRC clock to 331882352 Hz
GPMC revision 5.0
IRQ: Found an INTC at 0xfa200000 (revision 4.0) with 96 interrupts
Total of 96 interrupts on 1 active controller
OMAP GPIO hardware version 2.5
OMAP clockevent source: GPTIMER1 at 32768 Hz
Console: colour dummy device 80x30
Calibrating delay loop... 499.92 BogoMIPS (lpj=1949696)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
regulator: core version 0.5
NET: Registered protocol family 16
Found NAND on CS0
Registering NAND on CS0
OMAP DMA hardware revision 4.0
bio: create slab <bio-0> at 0
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
i2c_omap i2c_omap.1: bus 1 rev3.12 at 2600 kHz
twl4030: PIH (irq 7) chaining IRQs 368..375
twl4030: power (irq 373) chaining IRQs 376..383
twl4030: gpio (irq 368) chaining IRQs 384..401
regulator: VUSB1V5: 1500 mV normal standby
regulator: VUSB1V8: 1800 mV normal standby
regulator: VUSB3V1: 3100 mV normal standby
twl4030_usb twl4030_usb: Initialized TWL4030 USB module
regulator: VMMC1: 1850 <--> 3150 mV normal standby
regulator: VDAC: 1800 mV normal standby
regulator: VPLL2: 1800 mV normal standby
i2c_omap i2c_omap.3: bus 3 rev3.12 at 400 kHz
Bluetooth: Core ver 2.15
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
cfg80211: Using static regulatory domain info
cfg80211: Regulatory domain: US
        (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
        (2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2700 mBm)
        (5170000 KHz - 5190000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5190000 KHz - 5210000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5210000 KHz - 5230000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5230000 KHz - 5330000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
        (5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 3000 mBm)
cfg80211: Calling CRDA for country: US
Switching to clocksource 32k_counter
musb_hdrc: version 6.0, musb-dma, host, debug=0
musb_hdrc: USB Host mode controller at fa0ab000 using DMA, IRQ 92
musb_hdrc musb_hdrc: MUSB HDRC host driver
musb_hdrc musb_hdrc: new USB bus registered, assigned bus number 1
usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: MUSB HDRC host driver
usb usb1: Manufacturer: Linux 2.6.32 musb-hcd
usb usb1: SerialNumber: musb_hdrc
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
NET: Registered protocol family 2
IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
TCP established hash table entries: 8192 (order: 4, 65536 bytes)
TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 8192 bind 8192)
TCP reno registered
NET: Registered protocol family 1
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
VFS: Disk quotas dquot_6.5.2
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
msgmni has been set to 470
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
OMAP DSS rev 2.0
OMAP DISPC rev 3.0
OMAP VENC rev 2
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
serial8250.0: ttyS0 at MMIO 0x4806a000 (irq = 72) is a ST16654
serial8250.1: ttyS1 at MMIO 0x4806c000 (irq = 73) is a ST16654
serial8250.2: ttyS2 at MMIO 0x49020000 (irq = 74) is a ST16654
console [ttyS2] enabled
brd: module loaded
loop: module loaded
omap2-nand driver initializing
NAND device: Manufacturer ID: 0x2c, Chip ID: 0xba (Micron NAND 256MiB 1,8V 16-bit)
cmdlinepart partition parsing not available
Creating 5 MTD partitions on "omap2-nand":
0x000000000000-0x000000080000 : "xloader"
0x000000080000-0x000000240000 : "uboot"
0x000000240000-0x000000280000 : "uboot environment"
0x000000280000-0x000000680000 : "linux"
0x000000680000-0x000010000000 : "rootfs"
smsc911x: Driver version 2008-10-21.
smsc911x-mdio: probed
eth0: attached PHY driver [Generic PHY] (mii_bus:phy_addr=0:01, irq=-1)
net eth0: MAC Address: 00:15:c9:28:c9:1d
smsc911x: Driver version 2008-10-21.
usbcore: registered new interface driver asix
usbcore: registered new interface driver cdc_ether
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci-omap ehci-omap.0: OMAP-EHCI Host Controller
ehci-omap ehci-omap.0: new USB bus registered, assigned bus number 2
ehci-omap ehci-omap.0: irq 77, io mem 0x48064800
ehci-omap ehci-omap.0: USB 2.0 started, EHCI 1.00
usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: OMAP-EHCI Host Controller
usb usb2: Manufacturer: Linux 2.6.32 ehci_hcd
usb usb2: SerialNumber: ehci-omap.0
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
udc: OMAP UDC driver, version: 4 October 2004 (iso) (dma)
mice: PS/2 mouse device common for all mice
twl4030_rtc twl4030_rtc: rtc core: registered twl4030_rtc as rtc0
i2c /dev entries driver
OMAP Watchdog Timer Rev 0x31: initial timeout 60 sec
Bluetooth: HCI UART driver ver 2.2
Bluetooth: HCI H4 protocol initialized
Bluetooth: HCI BCSP protocol initialized
Bluetooth: HCILL protocol initialized
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
Advanced Linux Sound Architecture Driver Version 1.0.21.
usbcore: registered new interface driver snd-usb-audio
No device for DAI twl4030
No device for DAI twl4030 Voice
No device for DAI omap-mcbsp-dai-0
No device for DAI omap-mcbsp-dai-1
No device for DAI omap-mcbsp-dai-2
No device for DAI omap-mcbsp-dai-3
No device for DAI omap-mcbsp-dai-4
overo SoC init
TWL4030 Audio Codec init
asoc: twl4030 <-> omap-mcbsp-dai-0 mapping ok
ALSA device list:
  #0: overo (twl4030)
oprofile: using arm/armv7
TCP cubic registered
NET: Registered protocol family 17
NET: Registered protocol family 15
Bluetooth: L2CAP ver 2.14
Bluetooth: L2CAP socket layer initialized
Bluetooth: SCO (Voice Link) ver 0.6
Bluetooth: SCO socket layer initialized
usb 2-2: new high speed USB device using ehci-omap and address 2
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM ver 1.11
Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Bluetooth: BNEP filters: protocol multicast
Bluetooth: HIDP (Human Interface Emulation) ver 1.2
ThumbEE CPU extension supported.
Power Management for TI OMAP3.
VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 1
fbcvt: 1024x768@60: CVT Name - .786M3-R
Console: switching to colour frame buffer device 60x34
omapdss DPI: Could not find exact pixel clock. Requested 9200 kHz, got 9094 kHz
regulator_init_complete: incomplete constraints, leaving VDVI on
regulator_init_complete: incomplete constraints, leaving VDAC on
twl4030_rtc twl4030_rtc: setting system clock to 2010-01-09 18:07:49 UTC (1263060469)
Waiting for root device /dev/mmcblk0p2...
usb 2-2: New USB device found, idVendor=058f, idProduct=6254
usb 2-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
usb 2-2: configuration #1 chosen from 1 choice
hub 2-2:1.0: USB hub found
hub 2-2:1.0: 4 ports detected
mmc0: host does not support reading read-only switch. assuming write-enable.
mmc0: new high speed SDHC card at address 8fe4
mmcblk0: mmc0:8fe4 SU08G 7.40 GiB
 mmcblk0: p1 p2
mmc1: new SDIO card at address 0001
usb 2-2.3: new high speed USB device using ehci-omap and address 3
usb 2-2.3: New USB device found, idVendor=058f, idProduct=6364
usb 2-2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-2.3: Product: Mass Storage Device
usb 2-2.3: Manufacturer: Generic
usb 2-2.3: SerialNumber: 058F63646476
usb 2-2.3: configuration #1 chosen from 1 choice
scsi0 : SCSI emulation for USB Mass Storage devices
generic-usb: probe of 0003:058F:6364.0001 failed with error -22
usb 2-2.4: new low speed USB device using ehci-omap and address 4
usb 2-2.4: New USB device found, idVendor=046d, idProduct=c312
usb 2-2.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-2.4: Product: USB Multimedia Keyboard
usb 2-2.4: Manufacturer: LITEON Technology
usb 2-2.4: configuration #1 chosen from 1 choice
input: LITEON Technology USB Multimedia Keyboard as /devices/platform/ehci-omap.0/usb2/2-2/2-2.4/2-2.4:1.0/input/input0
generic-usb 0003:046D:C312.0002: input: USB HID v1.10 Keyboard [LITEON Technology USB Multimedia Keyboard] on usb-ehci-omap.0-2.4/input0
scsi 0:0:0:0: Direct-Access     Generic- SD/MMC           1.00 PQ: 0 ANSI: 0
scsi 0:0:0:1: Direct-Access     Generic- Compact Flash    1.01 PQ: 0 ANSI: 0
scsi 0:0:0:2: Direct-Access     Generic- SM/xD-Picture    1.02 PQ: 0 ANSI: 0
sd 0:0:0:0: [sda] Attached SCSI removable disk
usb 2-2.3: reset high speed USB device using ehci-omap and address 3
Unable to handle kernel NULL pointer dereference at virtual address 00000024
pgd = c0004000
[00000024] *pgd=00000000
Internal error: Oops: 5 [#1]
last sysfs file:
Modules linked in:
CPU: 0    Not tainted  (2.6.32 #1)
PC is at dev_get_drvdata+0x8/0x20
LR is at usbhid_restart_queues+0x90/0x104
pc : [<c0302104>]    lr : [<c03996b8>]    psr: 20000013
sp : cfb09ea0  ip : cfaf8000  fp : cfade274
r10: 00000002  r9 : 00000000  r8 : 00000000
r7 : cfaf8000  r6 : cfae1000  r5 : cfae5a80  r4 : cfaf8000
r3 : 00000000  r2 : 00000010  r1 : cf8000c0  r0 : 00000020
Flags: nzCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment kernel
Control: 10c5387d  Table: 80004019  DAC: 00000017
Process usb-storage (pid: 571, stack limit = 0xcfb082f0)
Stack: (0xcfb09ea0 to 0xcfb0a000)
9ea0: 00000001 c03997cc 00000000 00000001 00000000 00000000 00001388 cfade400
9ec0: cfa22608 cfae5a80 cfa22658 cfade400 00000001 c03419f0 00000000 cfade24c
9ee0: cfaff980 00000003 00040000 c035e90c cfade24c cfade24c cfade24c c035ef6c
9f00: cfb09f44 cfb09f38 cf8404c0 cfade2fc 7fffffff cfb08000 00000001 c04a6e80
9f20: 00000000 00000001 00000000 00000001 cf8404c0 cfb08000 cfb08000 c04a7ee0
9f40: 22222222 22222222 22222222 22222222 cfade2fc cfade24c cfade274 cfade24c
9f60: cfade274 cfade308 cfade2fc 00040000 00000000 00000002 cfb09f84 c036085c
9f80: cfb08000 00000013 00000000 00000000 c0131ff0 cfb08000 a610014d 000040b0
9fa0: cfb09fcc cfb09fd4 cf91bcbc cfb09fd4 cf91bcbc cfade24c c0360720 00000000
9fc0: 00000000 00000000 00000000 c0132008 00000000 00000000 cfb09fd8 cfb09fd8
9fe0: 00000000 00000000 00000000 00000000 00000000 c00f2900 20782d72 6f722031
[<c0302104>] (dev_get_drvdata+0x8/0x20) from [<c03996b8>] (usbhid_restart_queues+0x90/0x104)
[<c03996b8>] (usbhid_restart_queues+0x90/0x104) from [<c03997cc>] (hid_post_reset+0xa0/0xac)
[<c03997cc>] (hid_post_reset+0xa0/0xac) from [<c03419f0>] (usb_reset_device+0x120/0x17c)
[<c03419f0>] (usb_reset_device+0x120/0x17c) from [<c035e90c>] (usb_stor_port_reset+0x38/0x54)
[<c035e90c>] (usb_stor_port_reset+0x38/0x54) from [<c035ef6c>] (usb_stor_invoke_transport+0x2a4/0x300)
[<c035ef6c>] (usb_stor_invoke_transport+0x2a4/0x300) from [<c036085c>] (usb_stor_control_thread+0x13c/0x1f0)
[<c036085c>] (usb_stor_control_thread+0x13c/0x1f0) from [<c0132008>] (kthread+0x78/0x80)
[<c0132008>] (kthread+0x78/0x80) from [<c00f2900>] (kernel_thread_exit+0x0/0x8)
Code: e12fff1e c06b9a68 e3500000 0a000003 (e5900004)
---[ end trace 8b4a36706ddb365b ]---
Comment 12 Greg Kroah-Hartman 2012-02-22 21:47:28 UTC
All USB bugs should be sent to the linux-usb@vger.kernel.org mailing 
list, and not entered into bugzilla.  Please bring this issue up there,
if it is still a problem in the latest kernel release.

Note You need to log in before you can comment on or make changes to this bug.