Bug 14740 - battery status info dissapears in 2.6.32 - MSI PR200
battery status info dissapears in 2.6.32 - MSI PR200
Status: CLOSED DUPLICATE of bug 14446
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 normal
Assigned To: Alexey Starikovskiy
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-12-05 14:16 UTC by Leonid Podolny
Modified: 2009-12-30 21:04 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: Yes


Attachments
dmsg (34.75 KB, text/plain)
2009-12-05 14:17 UTC, Leonid Podolny
Details
.config for my kernel (57.73 KB, text/plain)
2009-12-05 14:18 UTC, Leonid Podolny
Details

Description Leonid Podolny 2009-12-05 14:16:32 UTC
+++ This bug was initially created as a clone of Bug #12187 +++

Latest working kernel version:2.6.31
Earliest failing kernel version:2.6.32
Distribution: Gentoo
Hardware Environment: MSI PR200
Software Environment:
Problem Description:

Some time after booting the laptop the system stops seeing the battery charge state.
The problem also appeared in kernels prior to 2.6.31, but it appeared so rarely (days after booting) that I can't really say what was the last kernel when it worked OK. In 2.6.32 it is wrong right after boot.

For example, with fully charged battery and power cable connected:

leonid@looptop ~ % cat /proc/acpi/battery/BAT1/state
present:                 yes
capacity state:          ok
charging state:          charged
present rate:            unknown
remaining capacity:      unknown
present voltage:         10000 mV
leonid@looptop ~ % cat /sys/class/power_supply/BAT1/charge_now
-1000
Comment 1 Leonid Podolny 2009-12-05 14:17:47 UTC
Created attachment 24033 [details]
dmsg
Comment 2 Leonid Podolny 2009-12-05 14:18:40 UTC
Created attachment 24035 [details]
.config for my kernel
Comment 3 Zhang Rui 2009-12-30 08:20:01 UTC
please attach the acpidump output.
Comment 4 Leonid Podolny 2009-12-30 11:35:45 UTC
This bug is actually a duplicate of B14446 -- it started working after I applied a patch from there.

*** This bug has been marked as a duplicate of bug 14446 ***

Note You need to log in before you can comment on or make changes to this bug.