Bug 14724 - ath5k fails to connect some times mlme.c:97 cfg80211_send_rx_assoc+0x19f/0x1a4()
ath5k fails to connect some times mlme.c:97 cfg80211_send_rx_assoc+0x19f/0x1a4()
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-12-03 12:33 UTC by Hernan G Solari
Modified: 2010-08-13 16:12 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32-rc7 rc8
Tree: Mainline
Regression: Yes


Attachments
iwlist iwconfig and dmsg output when connected (1.04 KB, application/x-gtar)
2010-03-05 17:42 UTC, Hernan G Solari
Details

Description Hernan G Solari 2009-12-03 12:33:36 UTC
I believe this BUG me be the same or related to bug 13943. At least has several
features in common.

The wifi is working fine with madwifi-hal-0.10.5.6-current. And works with ath5k
but I hit this warning some times (see below) and have to retry the connection  in such cases.

02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
        Subsystem: AMBIT Microsystem Corp. AR5BXB63 802.11bg NIC
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d0200000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [60] Express Legacy Endpoint, MSI 00
        Capabilities: [90] MSI-X: Enable- Count=1 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel <?>

However, madwifi ath_pci driver says:
 wifi0: Atheros AR2425 chip found (MAC 14.2, PHY SChip 7.0, Radio 10.2)

and Vista used to say it was an AR5007. This last too are in agreement as we
know.

Bug reported. Regresion. Not present in kernel 2.6.30-2 (Debian/squeeze)
present in 2.6.32-rc7 and rc8


Dec  2 13:53:04 dinnu kernel: [   66.636846] WARNING: at net/wireless/mlme.c:97 cfg80211_send_rx_assoc+0x19f/0x1a4()
Dec  2 13:53:04 dinnu kernel: [   66.636850] Hardware name: Aspire 5050     
Dec  2 13:53:04 dinnu kernel: [   66.636852] Modules linked in: radeon ttm drm_kms_helper drm i2c_algo_bit sco bnep rfcomm l2cap crc16 bluetooth powernow_k8 cpufreq_performance cpufreq_powersave cpufreq_ondemand cpufreq_stats freq_table cpufreq_conservative loop snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss uvcvideo videodev snd_mixer_oss v4l1_compat v4l2_compat_ioctl32 serio_raw acer_wmi ac battery pcspkr shpchp wmi snd_pcm ath5k joydev ath evdev k8temp snd_page_alloc ata_generic 8139too pata_acpi sdhci_pci ohci_hcd sdhci 8139cp mmc_core pata_atiixp ehci_hcd usbcore sata_sil thermal fan [last unloaded: scsi_wait_scan]
Dec  2 13:53:04 dinnu kernel: [   66.636907] Pid: 1237, comm: phy0 Tainted: G       A   2.6.32-rc8 #2
Dec  2 13:53:04 dinnu kernel: [   66.636910] Call Trace:
Dec  2 13:53:04 dinnu kernel: [   66.636917]  [<ffffffff813fc575>] ? cfg80211_send_rx_assoc+0x19f/0x1a4
Dec  2 13:53:04 dinnu kernel: [   66.636923]  [<ffffffff81044628>] warn_slowpath_common+0x77/0xa4
Dec  2 13:53:04 dinnu kernel: [   66.636927]  [<ffffffff81044664>] warn_slowpath_null+0xf/0x11
Dec  2 13:53:04 dinnu kernel: [   66.636932]  [<ffffffff813fc575>] cfg80211_send_rx_assoc+0x19f/0x1a4
Dec  2 13:53:04 dinnu kernel: [   66.636938]  [<ffffffff8140a30b>] ieee80211_sta_work+0x4e5/0xe86
Dec  2 13:53:04 dinnu kernel: [   66.636945]  [<ffffffff8103e7fb>] ? finish_task_switch+0x3a/0x78
Dec  2 13:53:04 dinnu kernel: [   66.636952]  [<ffffffff81434420>] ? thread_return+0x61/0xc6
Dec  2 13:53:04 dinnu kernel: [   66.636959]  [<ffffffff81058734>] worker_thread+0x18d/0x222
Dec  2 13:53:04 dinnu kernel: [   66.636963]  [<ffffffff81409e26>] ? ieee80211_sta_work+0x0/0xe86
Dec  2 13:53:04 dinnu kernel: [   66.636968]  [<ffffffff8105c0a8>] ? autoremove_wake_function+0x0/0x38
Dec  2 13:53:04 dinnu kernel: [   66.636973]  [<ffffffff810585a7>] ? worker_thread+0x0/0x222
Dec  2 13:53:04 dinnu kernel: [   66.636977]  [<ffffffff8105bd96>] kthread+0x7d/0x85
Dec  2 13:53:04 dinnu kernel: [   66.636982]  [<ffffffff8100ca9a>] child_rip+0xa/0x20
Dec  2 13:53:04 dinnu kernel: [   66.636986]  [<ffffffff8105bd19>] ? kthread+0x0/0x85
Dec  2 13:53:04 dinnu kernel: [   66.636989]  [<ffffffff8100ca90>] ? child_rip+0x0/0x20
Dec  2 13:53:04 dinnu kernel: [   66.636992] ---[ end trace 3a917509636f79c9 ]---
Dec  2 13:53:04 dinnu kernel: [   66.637527] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Dec  2 13:53:04 dinnu kernel: [   66.641490] wlan0: deauthenticated from 00:22:6b:5f:12:fd (Reason: 7)
Dec  2 13:53:04 dinnu dhclient: Internet Systems Consortium DHCP Client V3.1.3

-----------------------------------

How to produce it:

It happens with SOME networks and not always. The network is open (insecure). Happens only at the first attempt to connect. The second attempt is succesful.
Using as network manager wicd.
Connections made directly with iwconfig and dhclient3 do not trigger the bug.
Comment 1 John W. Linville 2010-03-01 18:58:07 UTC
Are you still seeing this with 2.6.33?
Comment 2 Hernan G Solari 2010-03-05 17:39:20 UTC
The problem is still there in 2.6.33. There is no much information in dmesg output now.
But the behaviour is the same.

I am attaching dmesg output (relevant part), iwlist scanning of node and iwconfig
Comment 3 Hernan G Solari 2010-03-05 17:42:23 UTC
Created attachment 25369 [details]
iwlist iwconfig and dmsg output when connected
Comment 4 John W. Linville 2010-08-13 16:12:26 UTC
The warning has been removed, so I'm going to optimistically close this one. :-)

Note You need to log in before you can comment on or make changes to this bug.