Bug 14716 - HP Compaq 615 laptop doesn't boot starting with kernel 2.6.3x, ssb and 43 fail unless "acpi=off"?
HP Compaq 615 laptop doesn't boot starting with kernel 2.6.3x, ssb and 43 fai...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 high
Assigned To: Michael Buesch
:
: 15975 (view as bug list)
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-12-02 14:27 UTC by RJ
Modified: 2013-04-09 06:23 UTC (History)
12 users (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments
bootdmesg (43.39 KB, text/plain)
2009-12-02 14:27 UTC, RJ
Details
lspci (13.77 KB, text/plain)
2009-12-02 14:27 UTC, RJ
Details
acpidump from 2.6.28 (Ubuntu 9.04) (446.53 KB, text/plain)
2009-12-03 17:12 UTC, RJ
Details
/etc/modprobe.d/blacklist.conf (1.95 KB, text/plain)
2010-01-06 18:10 UTC, iX
Details
/boot/config-2.6.33-rc3-compaq-athlon64-smp-4gb (91.55 KB, text/x-mpsub)
2010-01-06 18:14 UTC, iX
Details
kernel config file (94.40 KB, application/octet-stream)
2010-01-06 20:23 UTC, 8disk
Details

Description RJ 2009-12-02 14:27:21 UTC
Created attachment 23996 [details]
bootdmesg

I'm not sure at selecting component but HP Compaq 615 laptop doesn't work with kernel 2.6.30+ and work fine with <2.6.29.

I have tested Fedora 12, Ubuntu 9.10, Mandriva 2010 on it and all of them didn't work. Someone suggested that the problem is in loading pcmcia and pcmcia_core acpi modules because in this laptop we have only Express.

Here is the link: http://bbs.archlinux.org/viewtopic.php?id=82052 at #9

#rh https://bugzilla.redhat.com/show_bug.cgi?id=530942
:LP  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/454268
Comment 1 RJ 2009-12-02 14:27:48 UTC
Created attachment 23997 [details]
lspci
Comment 2 ykzhao 2009-12-03 13:00:05 UTC
Hi, Rj
   Will you please attach the output of acpidump on your box? 
   will you please try the following boot option and see whether the box can be booted?
   a. idle=poll
   b. processor.max_cstate=1

Thanks.
Comment 3 RJ 2009-12-03 17:12:14 UTC
Created attachment 24003 [details]
acpidump from 2.6.28 (Ubuntu 9.04)
Comment 4 RJ 2009-12-03 17:56:24 UTC
I've tested on Fedora 12 LiveCD:

a. idle=poll Result: doesn't boot

b. processor.max_cstate=1 Result: doesn't boot

c. nolapic Result: doesn't boot

d. acpi=off Result: works fine!

doesn't boot means that it tries to start udev but it failed (not OK nor FAILED printed) and screen become black and cdrom stops.

I got lines were udev stops (using additional params "debug udevdebug nomodeset")

...
...
udevd-work[474]: M ATTRS match 'idVendor' '056a'(plain)
udevd-work[469]: forward to rule:8172
udevd-work[474]:got 'idVendor' ((null)) from cache 
... 
(after some seconds screen turns black)

p.s also I've tested mainline kernel from Ubuntu PPA (2.6.32-rc8) - doesn't work
Comment 5 Tom 2009-12-07 21:23:44 UTC
I'm another owner of a compaq 615 laptop and I'm experiencing the same trouble.
After some searches I found this thread

https://lists.berlios.de/pipermail/bcm43xx-dev/2009-November/006312.html

were a weakness on the ssb module is found.

The problem is created by the same wifi module we have on the compaq 615,
(BCM4312 14e4:4315) so I think the defect we are talking here could be 
the same problem that has been identified in the link.

Regards
Tom
Comment 6 RJ 2009-12-13 19:06:48 UTC
Any help with this bug?
Comment 7 Len Brown 2009-12-22 02:51:21 UTC
so if the b43 driver is excluded from the kernel, it boots?
Comment 8 Tom 2009-12-22 10:20:29 UTC
I was able to boot excluding the module ssb, and I had acpi working;
probably you can have the same effect removing the module b43.

Unlikely the laptop was very noisy so I gave it back,
I can't tell you more about this fault.

Regards
Tom
Comment 9 iX 2010-01-05 03:10:47 UTC
I have the same trouble with the HP Compaq 615 using 2.6.33-rc2-git5 even when excluding the ssb and b43 module from the initrd. And "acpi=off" is for me a no-go kernel option since it fixes the problem by adding other problems, e.g. no SMP, no fan control etc.

Using the 2.6.32.2 and excluding the ssb and b43 module from the initrd I succeeded in particular with the kernel options "acpi=strict pci=nobios".

Best,

iX
Comment 10 8disk 2010-01-06 17:19:23 UTC
@ iX 
I also own a compaq 615,and i recompiled the lastest kernel without the pcmcia modules,but no way,we have to prevent the initrd to load ssb and b43 on boot,maybe they could be loaded later in a higher runlevel,can you tell me how to exclude these mudules from the initrd??thanks..
Comment 11 iX 2010-01-06 17:56:40 UTC
@8disk, all those people which have trouble with the HP Compaq 615 and the developers of hp_wmi, the HP laptop WMI hotkeys driver.

Excluding ssb from the initrd seems to be a neccessary prerequisite to let the HP Compaq 615 boot with the linux kernel 2.6.3[23]. But one should not forget to exclude hp_wmi (the HP laptop WMI hotkeys driver), too. The latter one puts the HP Compaq 615 into big trouble with all recent 2.6.33 kernels, Everybody can easily reproduce this by modprobing the hp_wmi driver after a (hopefully) successfull boot. One can exclude all baleful modules e.g. ssb, hp_wmi, wmi by blacklisting those modules e.g. in /etc/modprobe.d/blacklist.conf on a Debian system. Of course one has to update an existing initrd after the mentioned modification of your blacklist.conf. But even when doing so, boot satisfaction isn't guaranteed at any boot. Thus, there seems to be a different initialisation at different boot times. But why?

Since the hp_wmi is a driver which was born for HP Compaq laptops, all kernel developers should notice that this driver dosn't work at all with recent 2.6.33 kernels, e.g. the 2.6.33-rc3. 

Best,

iX

PS: One can find my .config and blacklist.conf above.
Comment 12 iX 2010-01-06 18:10:09 UTC
Created attachment 24471 [details]
/etc/modprobe.d/blacklist.conf

Additions to /etc/modprobe.d/blacklist.conf to let the HP Compaq 615 boot with ACPI enabled on recent 2.6.33 kernels.
Comment 13 iX 2010-01-06 18:14:44 UTC
Created attachment 24472 [details]
/boot/config-2.6.33-rc3-compaq-athlon64-smp-4gb

.config for recent 2.6.33 kernels modified for the HP Compaq 615
Comment 14 8disk 2010-01-06 20:23:12 UTC
Created attachment 24473 [details]
kernel config file

great,now i'm able to boot,i just blacklisted ssb only,not b43 and/or wmi as you have said above,to prevent it from be loaded by the initramfs,in fact now i have to modprobe it manually when starting a session,however i don't use the 2.6.33 kernel but 2.6.32,i'm attaching the congif file,it's for 32bit,and i havn't had any problem with wmi or hp_wmi..all fine

cheers
Comment 15 iX 2010-01-06 20:43:42 UTC
I think it would be very helpful (for the kernel and driver developers) if you would be so kind to check the configuration(s) with the most recent kernel, too.

Moreover, I'm wondering why you need to modprobe ssb manually. If you tag your wlan interface to be a hotplug interface in /etc/network/interfaces your system should automatically load the b43 and ssb module.

What happens when you load hp_wmi. Are e.g. the keys "dim up" and "dim down" working properly?

Best

iX
Comment 16 8disk 2010-01-07 12:15:49 UTC
The wlan interface is not "tagged" in my /etc/network/interfaces i'm going to do that,for the wmi,i usually got no hp_wmi in the modules,but only wmi,and no problem in that side,i tried to load hp_wmi and:

andrea@ott0disk:~/qt-everywhere-opensource-src-4.6.0$ dmesg |grep WMI
[    5.045483] ACPI: WMI: Mapper loaded
[ 3385.143538] input: HP WMI hotkeys as /devices/virtual/input/input9
[ 3385.268838] HP WMI: Unknown key pressed - 0
------------------------------------------------------------------
the firt line is of course at boot time and th "Unknown key pressed" is quite strange,i pressed no key,just the caps lock switched on(BY ITSELF!)and this is the result in the dmesg.

cheers
Comment 17 8disk 2010-01-22 17:40:31 UTC
Hi there,i've just read a news about keeping 2.6.32 releas as a long term release,good news,but what about this bug?because my pc still freezes sometimes while loading the b43 module,no way here is needed a patch.

cheers
Comment 18 Zhang Rui 2010-01-26 07:24:27 UTC
this seems a ssb issue to me.
cc Michael Buesch.
Comment 19 RJ 2010-02-12 07:44:48 UTC
What additional information do you need?
Comment 20 RJ 2010-02-18 20:05:58 UTC
someone said that he _solved_ this problem with installation Ubuntu 9.10 __amd64__, but Ubuntu 9.10 i386 have installation problem.

http://ubuntuforums.org/showpost.php?p=8504786&postcount=20
Comment 21 Matthias Tingelhoff 2010-03-21 15:28:29 UTC
I can confirm this bug, still present in 2.6.34-rc2 (amd64).
Sometimes it is booting fine, sometimes (in most cases ~70%) it doesnt.
Comment 22 Jaromír Cápík 2010-03-23 19:18:04 UTC
I have the same problem here on HP Mini 5102 ... tested on several kernels (from 2.6.31.5 to 2.6.34.rc2)

if I blacklist the ssb module and use broadcom-wl module instead, wifi works ... when I call modprobe ssb, the system gets frozen.


lspci -v
---------
01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
	Subsystem: Hewlett-Packard Company Device 1508
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at 94200000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: wl
	Kernel modules: wl, ssb



lspcidrake -v
--------------
wl              : Broadcom Corporation|BCM4312 802.11b/g [NETWORK_OTHER]
(vendor:14e4 device:4315 subv:103c subd:1508) (rev: 01)
Comment 23 Jaromír Cápík 2010-03-23 19:22:06 UTC
https://qa.mandriva.com/show_bug.cgi?id=57059
Comment 24 Len Brown 2010-04-06 02:21:47 UTC
The mystery is why for Rj "acpi=off" makes the system work.
(for iX, "acpi=off" is not an option).

 Matthias,
 Jaromír,
 8disk,
what do you see with "acpi=off"?

Everybody,
Is it true that 2.6.29 worked and 2.6.30 was the first to fail?
Can anybody try a bisect?
Comment 25 8disk 2010-04-06 08:12:02 UTC
I confirm,with kernels < 2.6.30 it boots up but i don't know if the wireless card works,right now i'm using a vanilla kernel compiled by me in the version 2.6.32-2 and i have to modprobe b43 at the finish of the boot process,its the only way(by the way the pc freezes sometimes),with acpi=off set in the kernel command line,of course it boots well but you will be without acpi,so no battery found ecc. the bug is still present as i see also in newer kernel release...

cheers
Comment 26 Matthias Tingelhoff 2010-04-11 19:06:58 UTC
Same here, "acpi=off" works well, but is a unacceptable workaround IMHO.
Another working workaround is the "nolapic" parameter.
Comment 27 Matthias Tingelhoff 2010-04-11 19:09:06 UTC
sorry for doublepost, but I think its good to mention: It worked < 2.6.30 because the wireless adapter was not supported in the b43 driver back then.
Comment 28 8disk 2010-04-12 21:08:57 UTC
so we are sure that is a b43-ssb issue...(i'm keeping an eye on "linuxwireless.com")
Comment 29 Angelo 2010-05-19 12:02:31 UTC
*** Bug 15975 has been marked as a duplicate of this bug. ***
Comment 30 Philippe De Muyter 2010-07-02 13:01:37 UTC
I have had the same problem on a laptop hp pavilion dv6-1300sb (Intel Pentium Dual-Core T4300 2.1 GHz 4Gb ram).  See bug 15665

I now have tested v2.6.35-rc3 on that machine, and at least it does not block
anymore so far at startup, but it still always does block on restart after the ssb messages.
Comment 31 Angelo 2010-07-02 13:10:06 UTC
I have an HP pavillion dv6-2044el.

cat /proc/version
Linux version 2.6.33-i7 (2.6.33) (root@angel7) (gcc version 4.3.5 (Debian 4.3.5-1) ) #1 SMP Mon Jun 7 11:57:14 CEST 2010


I confirm that removing ssb and b43, for 99% of the cases allow the kernel to boot correctly, even if in some rare cases i still get pc paralized at boot.

Re-adding these 2 modules and adding "nolapic", in my case don't solve the issue, still 50% cases the boot hang/paralize. I will attach some more details asap.

Regards
Comment 32 Angelo 2010-07-03 13:14:50 UTC
about my post below, 
i can give boot visual trace logs, copyed by hand since the boot state is paralized:

[   1.115736] pci 0000:01:00.0: no compatible bridge window for [mem 0xfff80000-0xffffffff pref]
[   1.115745] pci 0000:03:00.0: no compatible bridge window for [mem 0xffff0000-0xffffffff pref]
Loading, please wait...
kinit: No resume image, doing normal boot...
INIT: version 2.88 booting
Using makefile-style concurrent boot in runlevel S.
Starting the hotplug events dispatcher: udevd.
Synthesizing the initial hotplug events...done.
Waiting for /dev to be fully populated...[   9.508937] ACPI: I/O resource 0000:00:1f.3 [0x7000-0x701f] conflicts with ACPI region SMBI [0x7000-0x700f]

hope it helps
regards,
angelo
Comment 33 Peter Dahlberg 2010-09-13 12:32:28 UTC
Good news.
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.35.y.git;a=commit;h=9d1ac34ec3a67713308ae0883c3359c557f14d17 seems to fix this.

After applying this patch, loading ssb does not freeze the system anymore and b43 works here. It is also included in >=2.6.35.1
Comment 34 Matthias Tingelhoff 2010-09-13 19:00:36 UTC
That also fixed the problem for me !

Note You need to log in before you can comment on or make changes to this bug.