Bug 14625 - Commit d451564 breaks ARM
Commit d451564 breaks ARM
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-11-16 22:03 UTC by Rafael J. Wysocki
Modified: 2010-01-24 23:39 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-11-16 22:03:24 UTC
Subject    : d451564 breakage
Submitter  : Russell King <rmk+lkml@arm.linux.org.uk>
Date       : 2009-11-13 15:11
References : http://marc.info/?l=linux-kernel&m=125812520315835&w=4
Notify-Also : Ingo Molnar <mingo@elte.hu>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit d4515646699b6ad7b1a98ceb871296b957f3ef47
Author: Soeren Sandmann <sandmann@daimi.au.dk>
Date:   Wed Oct 28 18:56:35 2009 +0100

    highmem: Fix debug_kmap_atomic() to also handle KM_IRQ_PTE, KM_NMI, and KM_NMI_PTE

First-Bad-Commit : d4515646699b6ad7b1a98ceb871296b957f3ef47
Comment 1 Rafael J. Wysocki 2010-01-24 23:39:08 UTC
On Monday 25 January 2010, Russell King wrote:
> On Sun, Jan 24, 2010 at 11:22:52PM +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.31 and 2.6.32.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.31 and 2.6.32.  Please verify if it still should
> > be listed and let me know (either way).
> 
> Fixed by 4ff1fa2.

Note You need to log in before you can comment on or make changes to this bug.