Bug 14623 - Mount -o sync regression in 2.6.31
Mount -o sync regression in 2.6.31
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: fs_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 21:53 UTC by Rafael J. Wysocki
Modified: 2010-12-18 00:58 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-11-16 21:53:15 UTC
Subject    : Mount -o sync regression in 2.6.31
Submitter  : Stephen Hemminger <shemminger@vyatta.com>
Date       : 2009-11-11 20:33
References : http://marc.info/?l=linux-kernel&m=125797165709131&w=4
Notify-Also : Frans Pop <elendil@planet.nl>
Notify-Also : Andrew Morton <akpm@linux-foundation.org>
Notify-Also : Frederic Weisbecker <fweisbec@gmail.com>

This entry is being used for tracking a regression from 2.6.30.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2010-12-18 00:56:42 UTC
not a regression, but fixed by: 

commit 772be899bc022ef2b911c3611b487d417e3269c3
Author: Feng Tang <feng.tang@intel.com>
Date:   Tue Oct 20 12:54:02 2009 +0800

    x86: Make EFI RTC function depend on 32bit again
Comment 2 Florian Mickler 2010-12-18 00:58:02 UTC
well, no. Scrap that above commit... my cut'n'paste buffer was stale.

Fixed-By: commit 2074abfeb8ea2904aeeaecc45e0dfea3f83a22b2
Author: Stephen Hemminger <shemminger@vyatta.com>
Date:   Mon Nov 16 16:04:49 2009 -0800

    ext2: clear uptodate flag on super block I/O error

Note You need to log in before you can comment on or make changes to this bug.