Bug 14621 - specjbb2005 and aim7 regression with 2.6.32-rc kernels
specjbb2005 and aim7 regression with 2.6.32-rc kernels
Status: CLOSED OBSOLETE
Product: Process Management
Classification: Unclassified
Component: Scheduler
All Linux
: P1 normal
Assigned To: Ingo Molnar
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-11-16 21:39 UTC by Rafael J. Wysocki
Modified: 2012-06-18 12:35 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-11-16 21:39:41 UTC
Subject    : specjbb2005 and aim7 regression with 2.6.32-rc kernels
Submitter  : "Zhang, Yanmin" <yanmin_zhang@linux.intel.com>
Date       : 2009-11-06 7:38
References : http://marc.info/?l=linux-kernel&m=125749310413174&w=4
Notify-Also : Mike Galbraith <efault@gmx.de>
Notify-Also : Ingo Molnar <mingo@elte.hu>
Notify-Also : Peter Zijlstra <peterz@infradead.org>
Notify-Also : Gautham R Shenoy <ego@in.ibm.com>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Yanmin Zhang 2009-11-23 00:59:07 UTC
It's not resolved on core2 machines yet. The key is it will hurt Nehalem performance if we revert to old values on these schedule parameters.
Comment 2 Rafael J. Wysocki 2010-01-11 19:42:40 UTC
On Monday 11 January 2010, Mike Galbraith wrote:
> On Sun, 2010-01-10 at 23:56 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.31 and 2.6.32.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.31 and 2.6.32.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14621
> > Subject		: specjbb2005 and aim7 regression with 2.6.32-rc kernels
> > Submitter	: Zhang, Yanmin <yanmin_zhang@linux.intel.com>
> > Date		: 2009-11-06 7:38 (66 days old)
> > References	: http://marc.info/?l=linux-kernel&m=125749310413174&w=4
> 
> FWIW, I couldn't reproduce the aim7 regression with my one little disk,
> the opposite in fact, attributable to cfq low_latency switch.
> 
> (don't have specjbb2005, can't try to reproduce that one)
Comment 3 Rafael J. Wysocki 2010-02-02 20:56:36 UTC
On Monday 01 February 2010, Mike Galbraith wrote:
> On Mon, 2010-02-01 at 01:43 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.31 and 2.6.32.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.31 and 2.6.32.  Please verify if it still should
> > be listed and let me know (either way).
> 
> Yes, it should remain open.  Aim7 regression isn't reproducible here,
> specjbb2005 unknown, not available to the general public.

Note You need to log in before you can comment on or make changes to this bug.