Bug 14620 - WARNING: at mm/page_alloc.c:1805 __alloc_pages_nodemask
WARNING: at mm/page_alloc.c:1805 __alloc_pages_nodemask
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: ext4
All Linux
: P1 normal
Assigned To: fs_ext4@kernel-bugs.osdl.org
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-11-16 21:30 UTC by Rafael J. Wysocki
Modified: 2009-11-17 22:52 UTC (History)
0 users

See Also:
Kernel Version: 2.6.31-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-11-16 21:30:28 UTC
Subject    : 2.6.31-rc6: WARNING: at mm/page_alloc.c:1805 __alloc_pages_nodemas
Submitter  : Rogério Brito <rbrito@ime.usp.br>
Date       : 2009-11-06 23:10
References : http://marc.info/?l=linux-kernel&m=125754907413892&w=4

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-11-17 22:51:54 UTC
On Tuesday 17 November 2009, Theodore Tso wrote:
> On Mon, Nov 16, 2009 at 11:37:47PM +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.31.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=14620
> > Subject		: WARNING: at mm/page_alloc.c:1805 __alloc_pages_nodemask
> > Submitter	: Rogério Brito <rbrito@ime.usp.br>
> > Date		: 2009-11-06 23:10 (11 days old)
> > References	: http://marc.info/?l=linux-kernel&m=125754907413892&w=4
> 
> This isn't technically a regression, since the warning is simply
> complaining about something that apparently ext4 has been doing for a
> long time, which is that it allocates some very large order data
> buffers.  So the change referenced simply printed a warning message
> that complained about the fact.
> 
> The actual problem will be fixed in 2.6.32, as we no longer allocate
> the big data buffers at mount time.

Note You need to log in before you can comment on or make changes to this bug.