Bug 14619 - ext3/jbd oops in journal_start
Summary: ext3/jbd oops in journal_start
Status: CLOSED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: ext3 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Chris Mason
URL:
Keywords:
Depends on:
Blocks: 14230
  Show dependency tree
 
Reported: 2009-11-16 21:22 UTC by Rafael J. Wysocki
Modified: 2009-11-20 20:26 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-11-16 21:22:39 UTC
Subject    : ext3/jbd oops in journal_start
Submitter  : Sage Weil <sage@newdream.net>
Date       : 2009-10-31 6:14
References : http://marc.info/?l=linux-kernel&m=125696970418300&w=4
Notify-Also : Dmitry Monakhov <rjevskiy@gmail.com>
Notify-Also : Chris Mason <chris.mason@oracle.com>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Theodore Tso 2009-11-20 15:09:11 UTC
Note that Sage reported in http://marc.info/?l=linux-kernel&m=125696970418300&w=4
that he saw this with 2.6.31.   So at minimum it's not a regression from 2.6.31; possibly 2.6.30 --- we need more data, though.
Comment 2 Chris Mason 2009-11-20 15:19:15 UTC
This is a btrfs bug, and was specific to ceph's use of btrfs userland transactions.  We were leaving current->journal_info set after returning from the kernel which ext3 (rightly) faulted on.

It is fixed in 2.6.32-rc7 and higher.
Comment 3 Chris Mason 2009-11-20 15:20:09 UTC
->FIXED

Note You need to log in before you can comment on or make changes to this bug.