Bug 14615 - 2.6.31.6 - Keyboard nearly everytime dead after acpi s3 resume
2.6.31.6 - Keyboard nearly everytime dead after acpi s3 resume
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-11-16 19:45 UTC by Thomas Meyer
Modified: 2011-07-30 06:43 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31.6
Tree: Mainline
Regression: No


Attachments
config (73.31 KB, text/plain)
2009-11-16 19:46 UTC, Thomas Meyer
Details
dmesg - Fresh boot - No s2r cycle (54.58 KB, text/plain)
2009-11-16 19:47 UTC, Thomas Meyer
Details
One s2r cycle - system and keyboard seems to be okay (65.61 KB, text/plain)
2009-11-16 19:49 UTC, Thomas Meyer
Details
dmesg after one s2r cycle (106.28 KB, text/plain)
2009-11-19 19:07 UTC, Thomas Meyer
Details

Description Thomas Meyer 2009-11-16 19:45:47 UTC
Suspend and resume from ram seems to work mostly on my new computer. But after resume from acpi S3 mode the keyboard is dead. I still can press the "reboot" button in gnome, but the system doesn't reboot than. The last line I see in the reboot process is "Sending all processes the TERM signal" - On this point the system waits forever.

Will attach the config and a dmesg.
Comment 1 Thomas Meyer 2009-11-16 19:46:24 UTC
Created attachment 23802 [details]
config
Comment 2 Thomas Meyer 2009-11-16 19:47:21 UTC
Created attachment 23803 [details]
dmesg - Fresh boot - No s2r cycle
Comment 3 Thomas Meyer 2009-11-16 19:49:37 UTC
Created attachment 23805 [details]
One s2r cycle - system and keyboard seems to be okay
Comment 4 Thomas Meyer 2009-11-16 20:10:55 UTC
Okay, it doesn't seem to be a keyboard problem at all!

After the second s2r cycle the system behaves strangley:

- gnome screensaver password logon: I can enter my password
- Firefox: I can enter this bug report
- gnome-terminal doesn't seems to react to the keyboard anymore! Also killing the gnome-terminal and restarting it again doesn't seem to help
- The nm-applet doesn't seem to reconnect after the second s3r cycle. 
- I cannot switch away from X server to virtual console 2, etc. E.g. pressing Ctrl+Alt+F2 doesn't seem to do anything!
- Trying to execute a command from gnome with Alt+F2 opens the command line window, but it doesn't seem to matter what I enter, all commands seems to do nothing
- gnome process monitor shows that the process "bash" is in zombie state and the processes "nm-applet and "gnome-terminal" are state "not interruptbile".

Any help appreciated!
Comment 5 Thomas Meyer 2009-11-16 22:46:02 UTC
maybe related to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/468772
Comment 6 Thomas Meyer 2009-11-19 19:07:44 UTC
Created attachment 23833 [details]
dmesg after one s2r cycle

One S2R cycle with PM debug. Everything seemed to work after this cycle. The second s2r cycle left the machine in the strange state. I'll try to get the dmesg from the second cycle.
Comment 7 Thomas Meyer 2009-12-22 08:34:00 UTC
I switched to 2.6.32.2. Here I need to boot with the "nomodeset" option as something in the intel driver broke. But suspend and resume from ram started to work properly with this kernel version.
I tested 2.6.31.9 with the "nomodeset" option, but still got the strange system behaviour/error after resume from ram.

So good news 2.6.32.2 seems to suspend and resume correctly!
Shall I provide dmesg and config of this kernel?
Comment 8 Zhang Rui 2009-12-28 01:59:39 UTC
No.
Close this bug report as the bug has been fixed in the upstream kernel.

Note You need to log in before you can comment on or make changes to this bug.