Bug 14593 - Second CPU core not enabled on Turion64x2 TL-52
Second CPU core not enabled on Turion64x2 TL-52
Status: CLOSED OBSOLETE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 high
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-13 13:52 UTC by Dietrich T. Schmitz
Modified: 2012-06-18 12:28 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31-14 Ubuntu
Tree: Mainline
Regression: No


Attachments
dmesg output for second cpu not brought up (42.96 KB, text/plain)
2009-11-13 13:52 UTC, Dietrich T. Schmitz
Details

Description Dietrich T. Schmitz 2009-11-13 13:52:28 UTC
Created attachment 23764 [details]
dmesg output for second cpu not brought up

Hello,

The Laptop I am using was installed to Ubuntu 9.10 recently.  I have discovered that the second core is not being recognized/enabled.

I have attached a copy of dmesg.

uname -a:

Linux dietrich-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux

cat /proc/cmdline:

BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=85116730-ae4e-43a0-a7f0-ef97c6952857 ro maxcpus=1 ipv6.disable=1

dmesg | grep CPU:

[    0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs
[    0.000000] NR_CPUS:64 nr_cpumask_bits:64 nr_cpu_ids:2 nr_node_ids:1
[    0.000000] PERCPU: Embedded 30 pages at ffff8800019f4000, static data 90720 bytes
[    0.000000] Initializing CPU#0
[    0.000000] SLUB: Genslabs=14, HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[    0.010000] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[    0.010000] CPU: L2 Cache: 512K (64 bytes/line)
[    0.010000] CPU 0/0x0 -> Node 0
[    0.010000] CPU: Physical Processor ID: 0
[    0.010000] CPU: Processor Core ID: 0
[    0.010000] mce: CPU supports 5 MCE banks
[    0.135827] CPU0: AMD Turion(tm) 64 X2  stepping 02
[    0.140000] Brought up 1 CPUs
[    0.140000] CPU0 attaching NULL sched-domain.
[    0.140000] Switch to broadcast mode on CPU0
[    0.350019] Switched to high resolution mode on CPU 0
[    0.855992] processor LNXCPU:00: registered as cooling_device0
[    0.856049] ACPI: Processor [CPU0] (supports 8 throttling states)
[    0.856215] processor LNXCPU:01: registered as cooling_device1
[    0.856270] ACPI: Processor [CPU1] (supports 8 throttling states)
[   23.277533] CPU0 attaching NULL sched-domain.
[   23.277596] CPU0 attaching NULL sched-domain.
[   26.225264] CPU0 attaching NULL sched-domain.
[   26.225327] CPU0 attaching NULL sched-domain.

cat /proc/cpuinfo:

dietrich@dietrich-laptop:~$ cat /proc/cpuinfo
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 72
model name	: AMD Turion(tm) 64 X2 
stepping	: 2
cpu MHz		: 800.000
cache size	: 512 KB
physical id	: 0
siblings	: 1
core id		: 0
cpu cores	: 1
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow up rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy
bogomips	: 1607.22
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc


I am referencing bug# 14525 as a possible duplicate but since this is for AMD (the other is Intel) I am opening a bug report.
In reading bug 14525, I can tell you I have experienced the same issues he had at boot, wherein I set nolapic to get the machine to boot.  Subsequently, I determined that based on his call ticket replacing nolapic with maxcpus=1 allows the machine to boot.

Attached please find a copy of dmesg output in its entirety.

Any questions, please let me know.
Thank You.

Dietrich T. Schmitz
Comment 1 hj.12876 2009-11-13 14:31:56 UTC
I have the same problem on an Acer Aspire with an AMD Turion (MK-36) only one core is recognized but that's about it, no boot issues that I'm aware of. System is Ubuntu 9.10 64 bit.

dmesg | grep CPU:

[    0.000000] SMP: Allowing 1 CPUs, 0 hotplug CPUs
[    0.000000] NR_CPUS:64 nr_cpumask_bits:64 nr_cpu_ids:1 nr_node_ids:1
[    0.000000] PERCPU: Embedded 30 pages at ffff8800019ee000, static data 90720 bytes
[    0.000000] Initializing CPU#0
[    0.000000] SLUB: Genslabs=14, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.011333] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[    0.011335] CPU: L2 Cache: 512K (64 bytes/line)
[    0.011339] CPU 0/0x0 -> Node 0
[    0.011345] mce: CPU supports 5 MCE banks
[    0.141744] CPU0: AMD Turion(tm) 64 Mobile Technology MK-36 stepping 02
[    0.150000] Brought up 1 CPUs
[    0.150000] CPU0 attaching NULL sched-domain.
[    0.515425] Switched to high resolution mode on CPU 0
[    0.515457] ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
[    0.515482] processor LNXCPU:00: registered as cooling_device0


cat /proc/cpuinfo:

processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 76
model name	: AMD Turion(tm) 64 Mobile Technology MK-36
stepping	: 2
cpu MHz		: 800.000
cache size	: 512 KB
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow up rep_good extd_apicid pni cx16 lahf_lm svm extapic cr8_legacy
bogomips	: 1596.21
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc
Comment 2 Andrew Morton 2009-11-13 20:13:07 UTC
You say it's a regression, but from which kernel version?  Which kernel version worked OK?

Thanks.
Comment 3 Dietrich T. Schmitz 2009-11-13 20:21:26 UTC
Perhaps that flag should be turned off until you have made your own determination.

I drew a parallel to the user's experience with bug#14525, but did not personally try an older version of the kernel.

The issue, as reported, stands.
Please let me know what I can do to be of further assistance in troubleshooting.

I have toggled 'Regression' off.

Note You need to log in before you can comment on or make changes to this bug.