Bug 14590 - Request to add force key release for Samsung N310 netbook
Request to add force key release for Samsung N310 netbook
Status: RESOLVED DUPLICATE of bug 14052
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 enhancement
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-12 11:45 UTC by vandenzel
Modified: 2009-11-14 08:05 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: No


Attachments

Description vandenzel 2009-11-12 11:45:26 UTC
I'd like to see some Fn- keys working for the Samsung N310 netbook. 

The NC10 and NC20 netbooks are implemented in the atkbd.c file in source tree 2.6.31, but the N310 is not. The keyboard issues are the same as the NC10 and NC20 netbooks, so the same force-release mapping can be used.

I've tested the following patch on a 2.6.30 kernel and it works (backlight control is one of the issues). The system was a Samsung N310 (obviously) on Ubuntu Netbook Remix 9.04 (with manually upgraded kernel and kernel source to 2.6.30).

Below is a diff -u of the same modification to the atkbd.c file in the 2.6.31 source tree:

alx@weber:~/work$ diff -u atkbd.c atkbd.c.orig 
--- atkbd.c	2009-11-12 12:36:45.000000000 +0100
+++ atkbd.c.orig	2009-11-12 12:35:36.000000000 +0100
@@ -1607,15 +1607,6 @@
 		.driver_data = atkbd_samsung_forced_release_keys,
 	},
 	{
-		.ident = "Samsung N310",
-		.matches = {
-			DMI_MATCH(DMI_SYS_VENDOR, "SAMSUNG ELECTRONICS CO., LTD."),
-			DMI_MATCH(DMI_PRODUCT_NAME, "N310"),
-		},
-		.callback = atkbd_setup_forced_release,
-		.driver_data = atkbd_samsung_forced_release_keys,
-	},
-	{
 		.ident = "Samsung SQ45S70S",
 		.matches = {
 			DMI_MATCH(DMI_SYS_VENDOR, "SAMSUNG ELECTRONICS CO., LTD."),
Comment 1 Dmitry Torokhov 2009-11-14 08:05:16 UTC

*** This bug has been marked as a duplicate of bug 14052 ***

Note You need to log in before you can comment on or make changes to this bug.