Bug 14588 - Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: ccccb5b0
Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: cc...
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
http://bugs.debian.org/cgi-bin/bugrep...
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-11-12 02:25 UTC by Hideki Yamane
Modified: 2010-10-01 08:16 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.31.5, 2.6.31.6 (Debian kernel)
Tree: Mainline
Regression: Yes


Attachments
/var/log/kern.log file (41.69 KB, text/plain)
2009-11-12 02:25 UTC, Hideki Yamane
Details

Description Hideki Yamane 2009-11-12 02:25:44 UTC
Created attachment 23753 [details]
/var/log/kern.log file

I'm using Thinkpad i1157 (mostly same as Thinkpad 570), and it hanged up with 
2.6.31.5 based Debian kernel. The error message is

> (snip)
> INIT: version 2.86 booting
> Starting the hotplug events dispatcher: udevd.
> Synthesizing the initial hotplug events ... done.
> Waiting for /dev to be fully poplulated...[    11.526424] Kernel panic - not 
> syncing: stack-protector: Kernel stack is corrupted in: ccccb5b0
> [    11.526538]


And, previous 2.6.30.8 based one works fine.
Comment 1 Andrew Morton 2009-11-12 05:46:31 UTC
(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Thu, 12 Nov 2009 02:25:47 GMT bugzilla-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=14588
> 
>                URL: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=55582
>                     6
>            Summary: Kernel panic - not syncing: stack-protector: Kernel
>                     stack is corrupted in: ccccb5b0
>            Product: Other
>            Version: 2.5
>     Kernel Version: 2.6.31.5 (Debian kernel)
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Other
>         AssignedTo: other_other@kernel-bugs.osdl.org
>         ReportedBy: henrich@debian.or.jp
>         Regression: No

yes, this is a 2.6.30.x -> 2.6.31.x regression.

> 
> Created an attachment (id=23753)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=23753)
> /var/log/kern.log file
> 
> I'm using Thinkpad i1157 (mostly same as Thinkpad 570), and it hanged up with 
> 2.6.31.5 based Debian kernel. The error message is
> 
> > (snip)
> > INIT: version 2.86 booting
> > Starting the hotplug events dispatcher: udevd.
> > Synthesizing the initial hotplug events ... done.
> > Waiting for /dev to be fully poplulated...[    11.526424] Kernel panic - not 
> > syncing: stack-protector: Kernel stack is corrupted in: ccccb5b0
> > [    11.526538]
> 
> 
> And, previous 2.6.30.8 based one works fine.

And that's all the output we got.

Perhaps the stack protector code is playing up.  Please set
CONFIG_CC_STACKPROTECTOR=n and retest.
Comment 2 Arjan van de Ven 2009-11-12 05:51:20 UTC
On Wed, 11 Nov 2009 21:46:27 -0800
Andrew Morton <akpm@linux-foundation.org> wrote:

<addressing "you" here, but it's for the bug reporter>

> Perhaps the stack protector code is playing up.  Please set
> CONFIG_CC_STACKPROTECTOR=n and retest.

also can we get exact information of the GCC being used?

Also can you confirm that no kernel modules are being used that are not
part of the normal kernel ?
Comment 3 Hideki Yamane 2009-11-12 15:06:53 UTC
Hi,

On Wed, 11 Nov 2009 21:46:27 -0800
Andrew Morton <akpm@linux-foundation.org> wrote:
> Perhaps the stack protector code is playing up.  Please set
> CONFIG_CC_STACKPROTECTOR=n and retest.

 Now I set as "CONFIG_CC_STACKPROTECTOR=n" and running build.
 So, please wait for a while to retest it.



On Wed, 11 Nov 2009 21:52:38 -0800
Arjan van de Ven <arjan@infradead.org> wrote:
> also can we get exact information of the GCC being used?

 It's gcc 4.3.4-5 (-5 is Debian revision) for this.
 Kernel build log is here, https://buildd.debian.org/fetch.cgi?pkg=linux-2.6;ver=2.6.31-1;arch=i386;stamp=1256512487
 and gcc Debian package information is here: http://packages.debian.org/changelogs/pool/main/g/gcc-4.3/current/changelog


> Also can you confirm that no kernel modules are being used that are not
> part of the normal kernel ?

 I use Debian kernel package, it's not vanilla kernel but some patched one.
 But I don't set anything special because I use normal x86 old thinkpad.
 Debian kernel includes extra feature patches like below

 debian/patches/features/all/aufs2/aufs2-add.patch                                          |24968 ++++++++++
 debian/patches/features/all/aufs2/aufs2-base.patch                                         |   81 
 debian/patches/features/all/aufs2/aufs2-kbuild.patch                                       |   35 
 debian/patches/features/all/aufs2/aufs2-standalone.patch                                   |  182 
 debian/patches/features/all/aufs2/mark-as-staging.patch                                    |   15 
 debian/patches/features/all/drivers-gpu-drm-mga-request_firmware.patch                     |  277 
 debian/patches/features/all/drivers-gpu-drm-r128-request_firmware.patch                    |  139 
 debian/patches/features/all/drivers-gpu-drm-radeon-request_firmware.patch                  |  562 
 debian/patches/features/all/drivers-infiniband-hw-ipath-iba7220-use-request_firmware.patch |  230 
 debian/patches/features/all/drivers-media-dvb-usb-af9005-request_firmware.patch            |  152 
 debian/patches/features/all/drivers-net-cxgb3-request_firmware.patch                       |  213 
 debian/patches/features/all/drivers-staging-rt28x0sta-request_firmware.patch               |  278 
 debian/patches/features/all/export-unionfs-symbols.patch                                   |   11 
 debian/patches/features/all/sound-pci-cs46xx-request_firmware.patch                        |  172 
 debian/patches/features/all/speakup/speakup-add.patch                                      |10231 ++++
 debian/patches/features/all/speakup/speakup-kbuild.patch                                   |   28 
 debian/patches/features/all/vserver/bindmount-dev.patch                                    |   41 
 debian/patches/features/all/vserver/gen-patch                                              |   14 
 debian/patches/features/arm/mv_cesa.patch                                                  |  789 
 debian/patches/features/arm/openrd-machtype.patch                                          |    7 
 debian/patches/features/arm/openrd-sata.patch                                              |   43 
 debian/patches/features/arm/openrd.patch                                                   |  138 
 debian/patches/features/sparc/video-sunxvr500-intergraph.patch                             |   23 

 None of them seems to be used in my environment.
Comment 4 Hideki Yamane 2009-11-12 22:39:34 UTC
Hi,

>  Now I set as "CONFIG_CC_STACKPROTECTOR=n" and running build.
>  So, please wait for a while to retest it.

henrich@hatchpotch:~$ grep STACKPROTECTOR /boot/config-2.6.31-1-686 
# CONFIG_CC_STACKPROTECTOR is not set

 and now it works.

henrich@hatchpotch:~$ uname -a
Linux hatchpotch 2.6.31-1-686 #1 SMP Fri Nov 13 02:32:13 JST 2009 i686 GNU/Linux

 and /var/log/dmesg attached.
 gcc package version is little bit different, but it is not so big, I think.
 

[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 2.6.31-1-686 (Debian 2.6.31-1.1) (henrich@debian.or.jp) (gcc version 4.3.4 (Debian 4.3.4-6) ) #1 SMP Fri Nov 13 02:32:13 JST 2009
[    0.000000] KERNEL supported cpus:
[    0.000000]   Intel GenuineIntel
[    0.000000]   AMD AuthenticAMD
[    0.000000]   NSC Geode by NSC
[    0.000000]   Cyrix CyrixInstead
[    0.000000]   Centaur CentaurHauls
[    0.000000]   Transmeta GenuineTMx86
[    0.000000]   Transmeta TransmetaCPU
[    0.000000]   UMC UMC UMC UMC
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[    0.000000]  BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000e8000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000000bff0000 (usable)
[    0.000000]  BIOS-e820: 000000000bff0000 - 000000000bfffc00 (ACPI data)
[    0.000000]  BIOS-e820: 000000000bfffc00 - 000000000c000000 (ACPI NVS)
[    0.000000]  BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
[    0.000000] DMI 2.3 present.
[    0.000000] last_pfn = 0xbff0 max_arch_pfn = 0x100000
[    0.000000] MTRR default type: uncachable
[    0.000000] MTRR fixed ranges enabled:
[    0.000000]   00000-9FFFF write-back
[    0.000000]   A0000-BFFFF uncachable
[    0.000000]   C0000-CBFFF write-protect
[    0.000000]   CC000-E7FFF uncachable
[    0.000000]   E8000-FFFFF write-protect
[    0.000000] MTRR variable ranges enabled:
[    0.000000]   0 base 000000000 mask FF8000000 write-back
[    0.000000]   1 base 008000000 mask FFC000000 write-back
[    0.000000]   2 disabled
[    0.000000]   3 disabled
[    0.000000]   4 disabled
[    0.000000]   5 disabled
[    0.000000]   6 disabled
[    0.000000]   7 disabled
[    0.000000] PAT not supported by CPU.
[    0.000000] initial memory mapped : 0 - 01800000
[    0.000000] init_memory_mapping: 0000000000000000-000000000bff0000
[    0.000000]  0000000000 - 0000400000 page 4k
[    0.000000]  0000400000 - 000bc00000 page 2M
[    0.000000]  000bc00000 - 000bff0000 page 4k
[    0.000000] kernel direct mapping tables up to bff0000 @ 7000-d000
[    0.000000] RAMDISK: 08911000 - 09033052
[    0.000000] ACPI: RSDP 000f6cf0 00014 (v00 PTLTD )
[    0.000000] ACPI: RSDT 0bffa9c6 0002C (v01 PTLTD    RSDT   06040000  LTP 00000000)
[    0.000000] ACPI: FACP 0bfffb65 00074 (v01 IBM    VIPER    06040000 PTL  000F4240)
[    0.000000] ACPI Warning: Optional field Gpe1Block has zero address or length: 0000000000000000/4 20090521 tbfadt-558
[    0.000000] ACPI: DSDT 0bffa9f2 05173 (v01 IBM    VIPER    06040000 MSFT 01000004)
[    0.000000] ACPI: FACS 0bffffc0 00040
[    0.000000] ACPI: BOOT 0bfffbd9 00027 (v01 PTLTD  $SBFTBL$ 06040000  LTP 00000001)
[    0.000000] 0MB HIGHMEM available.
[    0.000000] 191MB LOWMEM available.
[    0.000000]   mapped low ram: 0 - 0bff0000
[    0.000000]   low ram: 0 - 0bff0000
[    0.000000]   node 0 low ram: 00000000 - 0bff0000
[    0.000000]   node 0 bootmap 00002000 - 00003800
[    0.000000] (9 early reservations) ==> bootmem [0000000000 - 000bff0000]
[    0.000000]   #0 [0000000000 - 0000001000]   BIOS data page ==> [0000000000 - 0000001000]
[    0.000000]   #1 [0000001000 - 0000002000]    EX TRAMPOLINE ==> [0000001000 - 0000002000]
[    0.000000]   #2 [0000006000 - 0000007000]       TRAMPOLINE ==> [0000006000 - 0000007000]
[    0.000000]   #3 [0001000000 - 0001471d58]    TEXT DATA BSS ==> [0001000000 - 0001471d58]
[    0.000000]   #4 [0008911000 - 0009033052]          RAMDISK ==> [0008911000 - 0009033052]
[    0.000000]   #5 [000009fc00 - 0000100000]    BIOS reserved ==> [000009fc00 - 0000100000]
[    0.000000]   #6 [0001472000 - 00014780ca]              BRK ==> [0001472000 - 00014780ca]
[    0.000000]   #7 [0000007000 - 0000009000]          PGTABLE ==> [0000007000 - 0000009000]
[    0.000000]   #8 [0000002000 - 0000004000]          BOOTMAP ==> [0000002000 - 0000004000]
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA      0x00000000 -> 0x00001000
[    0.000000]   Normal   0x00001000 -> 0x0000bff0
[    0.000000]   HighMem  0x0000bff0 -> 0x0000bff0
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[2] active PFN ranges
[    0.000000]     0: 0x00000000 -> 0x0000009f
[    0.000000]     0: 0x00000100 -> 0x0000bff0
[    0.000000] On node 0 totalpages: 49039
[    0.000000] free_area_init_node: node 0, pgdat c1367fa0, node_mem_map c1479000
[    0.000000]   DMA zone: 32 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 3967 pages, LIFO batch:0
[    0.000000]   Normal zone: 352 pages used for memmap
[    0.000000]   Normal zone: 44688 pages, LIFO batch:7
[    0.000000] Using APIC driver default
[    0.000000] ACPI: PM-Timer IO Port: 0x1008
[    0.000000] SMP: Allowing 1 CPUs, 0 hotplug CPUs
[    0.000000] Local APIC disabled by BIOS -- you can enable it with "lapic"
[    0.000000] APIC: disable apic facility
[    0.000000] nr_irqs_gsi: 16
[    0.000000] PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
[    0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000e8000
[    0.000000] PM: Registered nosave memory: 00000000000e8000 - 0000000000100000
[    0.000000] Allocating PCI resources starting at c000000 (gap: c000000:f3ff0000)
[    0.000000] NR_CPUS:32 nr_cpumask_bits:32 nr_cpu_ids:1 nr_node_ids:1
[    0.000000] PERCPU: Embedded 13 pages at c15fb000, static data 31804 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 48655
[    0.000000] Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.31-1-686 root=UUID=f3dfaab3-b2dd-44cd-b4aa-ac3d29dcd6a3 ro quiet
[    0.000000] PID hash table entries: 1024 (order: 10, 4096 bytes)
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Enabling fast FPU save and restore... done.
[    0.000000] Enabling unmasked SIMD FPU exception support... done.
[    0.000000] Initializing CPU#0
[    0.000000] Initializing HighMem for node 0 (00000000:00000000)
[    0.000000] Memory: 182284k/196544k available (2310k kernel code, 13720k reserved, 1210k data, 340k init, 0k highmem)
[    0.000000] virtual kernel memory layout:
[    0.000000]     fixmap  : 0xffd56000 - 0xfffff000   (2724 kB)
[    0.000000]     pkmap   : 0xff400000 - 0xff800000   (4096 kB)
[    0.000000]     vmalloc : 0xcc7f0000 - 0xff3fe000   ( 812 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xcbff0000   ( 191 MB)
[    0.000000]       .init : 0xc1371000 - 0xc13c6000   ( 340 kB)
[    0.000000]       .data : 0xc12419bd - 0xc1370458   (1210 kB)
[    0.000000]       .text : 0xc1000000 - 0xc12419bd   (2310 kB)
[    0.000000] Checking if this processor honours the WP bit even in supervisor mode...Ok.
[    0.000000] NR_IRQS:1280
[    0.000000] Fast TSC calibration using PIT
[    0.000000] Detected 497.939 MHz processor.
[    0.001689] Console: colour VGA+ 80x25
[    0.001704] console [tty0] enabled
[    0.004032] Calibrating delay loop (skipped), value calculated using timer frequency.. 995.87 BogoMIPS (lpj=1991756)
[    0.004234] Security Framework initialized
[    0.004259] SELinux:  Disabled at boot.
[    0.004332] Mount-cache hash table entries: 512
[    0.004851] Initializing cgroup subsys ns
[    0.004871] Initializing cgroup subsys cpuacct
[    0.004890] Initializing cgroup subsys devices
[    0.004903] Initializing cgroup subsys freezer
[    0.004913] Initializing cgroup subsys net_cls
[    0.005002] CPU: L1 I cache: 16K, L1 D cache: 16K
[    0.005015] CPU: L2 cache: 128K
[    0.005032] mce: CPU supports 5 MCE banks
[    0.005086] Performance Counters: 
[    0.005097] no APIC, boot with the "lapic" boot parameter to force-enable it.
[    0.005107] no hardware sampling interrupt available.
[    0.005117] p6 PMU driver.
[    0.005176] ... version:                 0
[    0.005185] ... bit width:               32
[    0.005194] ... generic counters:        2
[    0.005203] ... value mask:              00000000ffffffff
[    0.005213] ... max period:              000000007fffffff
[    0.005223] ... fixed-purpose counters:  0
[    0.005232] ... counter mask:            0000000000000003
[    0.005253] Checking 'hlt' instruction... OK.
[    0.020861] SMP alternatives: switching to UP code
[    0.032076] Freeing SMP alternatives: 13k freed
[    0.032140] ACPI: Core revision 20090521
[    0.048536] ACPI: setting ELCR to 0200 (from 0800)
[    0.052210] weird, boot CPU (#0) not listed by the BIOS.
[    0.052222] SMP motherboard not detected.
[    0.052233] Local APIC not detected. Using dummy APIC emulation.
[    0.052242] SMP disabled
[    0.052929] Brought up 1 CPUs
[    0.052946] Total of 1 processors activated (995.87 BogoMIPS).
[    0.053006] CPU0 attaching NULL sched-domain.
[    0.054335] Booting paravirtualized kernel on bare hardware
[    0.056436] regulator: core version 0.5
[    0.056769] NET: Registered protocol family 16
[    0.057222] ACPI: bus type pci registered
[    0.059890] PCI: PCI BIOS revision 2.10 entry at 0xfd96f, last bus=7
[    0.059904] PCI: Using configuration type 1 for base access
[    0.061680] bio: create slab <bio-0> at 0
[    0.063885] ACPI: EC: Look up EC in DSDT
[    0.104664] ACPI: Interpreter enabled
[    0.104689] ACPI: (supports S0 S1 S3 S4 S5)
[    0.104794] ACPI: Using PIC for interrupt routing
[    0.159586] ACPI: Power Resource [FANP] (off)
[    0.168838] ACPI: ACPI Dock Station Driver: 1 docks/bays found
[    0.172892] ACPI: PCI Root Bridge [PCI] (0000:00)
[    0.173093] pci 0000:00:00.0: reg 10 32bit mmio: [0xf8000000-0xfbffffff]
[    0.173257] pci 0000:00:02.0: reg 10 32bit mmio: [0x50000000-0x50000fff]
[    0.173294] pci 0000:00:02.0: supports D1 D2
[    0.173306] pci 0000:00:02.0: PME# supported from D0 D1 D2 D3hot D3cold
[    0.173322] pci 0000:00:02.0: PME# disabled
[    0.173385] pci 0000:00:02.1: reg 10 32bit mmio: [0x50100000-0x50100fff]
[    0.173420] pci 0000:00:02.1: supports D1 D2
[    0.173432] pci 0000:00:02.1: PME# supported from D0 D1 D2 D3hot D3cold
[    0.173447] pci 0000:00:02.1: PME# disabled
[    0.173523] pci 0000:00:05.0: reg 10 32bit mmio: [0xf4100000-0xf4100fff]
[    0.173544] pci 0000:00:05.0: reg 14 32bit mmio: [0xf4000000-0xf40fffff]
[    0.173605] pci 0000:00:05.0: supports D1 D2
[    0.173767] pci 0000:00:06.1: reg 20 io port: [0x1800-0x180f]
[    0.173861] pci 0000:00:06.2: reg 20 io port: [0x1820-0x183f]
[    0.173978] pci 0000:00:06.3: quirk: region 1000-103f claimed by PIIX4 ACPI
[    0.173994] pci 0000:00:06.3: quirk: region 1040-104f claimed by PIIX4 SMB
[    0.174013] pci 0000:00:06.3: PIIX4 devres C PIO at 15e8-15ef
[    0.174028] pci 0000:00:06.3: PIIX4 devres I PIO at 03f0-03f7
[    0.174043] pci 0000:00:06.3: PIIX4 devres J PIO at 002e-002f
[    0.174114] pci 0000:00:07.0: reg 10 32bit mmio: [0xf4101000-0xf41010ff]
[    0.174135] pci 0000:00:07.0: reg 14 io port: [0x1810-0x1817]
[    0.174154] pci 0000:00:07.0: reg 18 io port: [0x2000-0x20ff]
[    0.174209] pci 0000:00:07.0: supports D2
[    0.174222] pci 0000:00:07.0: PME# supported from D2 D3hot D3cold
[    0.174236] pci 0000:00:07.0: PME# disabled
[    0.174355] pci 0000:01:00.0: reg 10 32bit mmio: [0xf5000000-0xf5ffffff]
[    0.174376] pci 0000:01:00.0: reg 14 32bit mmio: [0xf4400000-0xf47fffff]
[    0.174396] pci 0000:01:00.0: reg 18 32bit mmio: [0xf4200000-0xf42fffff]
[    0.174449] pci 0000:01:00.0: supports D1 D2
[    0.174517] pci 0000:00:01.0: bridge 32bit mmio: [0xf4200000-0xf47fffff]
[    0.174534] pci 0000:00:01.0: bridge 32bit mmio pref: [0xf5000000-0xf5ffffff]
[    0.174606] pci_bus 0000:00: on NUMA node 0
[    0.174629] ACPI: PCI Interrupt Routing Table [\_SB_.PCI_._PRT]
[    0.215109] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 9 10 *11 15)
[    0.215492] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 9 10 *11 15)
[    0.215863] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 9 10 *11 15)
[    0.216293] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 9 10 *11 15)
[    0.216936] PCI: Using ACPI for IRQ routing
[    0.222841] pnp: PnP ACPI init
[    0.222923] ACPI: bus type pnp registered
[    0.277470] pnp: PnP ACPI: found 16 devices
[    0.277485] ACPI: ACPI bus type pnp unregistered
[    0.277500] PnPBIOS: Disabled by ACPI PNP
[    0.277563] system 00:06: iomem range 0x0-0x9ffff could not be reserved
[    0.277581] system 00:06: iomem range 0xe0000-0xfffff could not be reserved
[    0.277600] system 00:06: iomem range 0xfff80000-0xffffffff could not be reserved
[    0.277647] system 00:0e: ioport range 0x1000-0x103f has been reserved
[    0.277666] system 00:0e: ioport range 0x1040-0x104f has been reserved
[    0.277682] system 00:0e: ioport range 0x15ea-0x15ef has been reserved
[    0.277699] system 00:0e: ioport range 0xfe00-0xfe0f has been reserved
[    0.313057] pci 0000:00:01.0: PCI bridge, secondary bus 0000:01
[    0.313072] pci 0000:00:01.0:   IO window: disabled
[    0.313089] pci 0000:00:01.0:   MEM window: 0xf4200000-0xf47fffff
[    0.313105] pci 0000:00:01.0:   PREFETCH window: 0xf5000000-0xf5ffffff
[    0.313122] pci 0000:00:02.0: CardBus bridge, secondary bus 0000:02
[    0.313135] pci 0000:00:02.0:   IO window: 0x001400-0x0014ff
[    0.313149] pci 0000:00:02.0:   IO window: 0x001c00-0x001cff
[    0.313164] pci 0000:00:02.0:   PREFETCH window: 0xc000000-0xfffffff
[    0.313179] pci 0000:00:02.0:   MEM window: 0x10000000-0x13ffffff
[    0.313195] pci 0000:00:02.1: CardBus bridge, secondary bus 0000:06
[    0.313207] pci 0000:00:02.1:   IO window: 0x002400-0x0024ff
[    0.313221] pci 0000:00:02.1:   IO window: 0x002800-0x0028ff
[    0.313236] pci 0000:00:02.1:   PREFETCH window: 0x14000000-0x17ffffff
[    0.313251] pci 0000:00:02.1:   MEM window: 0x18000000-0x1bffffff
[    0.313523] pci 0000:00:02.0: power state changed by ACPI to D0
[    0.314130] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
[    0.314145] PCI: setting IRQ 11 as level-triggered
[    0.314164] pci 0000:00:02.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
[    0.314333] pci 0000:00:02.1: power state changed by ACPI to D0
[    0.314867] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 11
[    0.314887] pci 0000:00:02.1: PCI INT B -> Link[LNKB] -> GSI 11 (level, low) -> IRQ 11
[    0.314912] pci_bus 0000:00: resource 0 io:  [0x00-0xffff]
[    0.314926] pci_bus 0000:00: resource 1 mem: [0x000000-0xffffffff]
[    0.314942] pci_bus 0000:01: resource 1 mem: [0xf4200000-0xf47fffff]
[    0.314956] pci_bus 0000:01: resource 2 pref mem [0xf5000000-0xf5ffffff]
[    0.314971] pci_bus 0000:02: resource 0 io:  [0x1400-0x14ff]
[    0.314985] pci_bus 0000:02: resource 1 io:  [0x1c00-0x1cff]
[    0.314998] pci_bus 0000:02: resource 2 pref mem [0xc000000-0xfffffff]
[    0.315013] pci_bus 0000:02: resource 3 mem: [0x10000000-0x13ffffff]
[    0.315027] pci_bus 0000:06: resource 0 io:  [0x2400-0x24ff]
[    0.315041] pci_bus 0000:06: resource 1 io:  [0x2800-0x28ff]
[    0.315055] pci_bus 0000:06: resource 2 pref mem [0x14000000-0x17ffffff]
[    0.315069] pci_bus 0000:06: resource 3 mem: [0x18000000-0x1bffffff]
[    0.315300] NET: Registered protocol family 2
[    0.315771] IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.317268] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[    0.317487] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[    0.317715] TCP: Hash tables configured (established 8192 bind 8192)
[    0.317728] TCP reno registered
[    0.318272] NET: Registered protocol family 1
[    0.318534] Unpacking initramfs...
[    0.815985] Switched to high resolution mode on CPU 0
[    1.375921] Freeing initrd memory: 7304k freed
[    1.417404] Simple Boot Flag at 0x37 set to 0x1
[    1.418303] audit: initializing netlink socket (disabled)
[    1.418367] type=2000 audit(1258064810.416:1): initialized
[    1.419156] HugeTLB registered 4 MB page size, pre-allocated 0 pages
[    1.419567] VFS: Disk quotas dquot_6.5.2
[    1.419738] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    1.419998] msgmni has been set to 370
[    1.420917] alg: No test for stdrng (krng)
[    1.421111] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    1.421126] io scheduler noop registered
[    1.421136] io scheduler anticipatory registered
[    1.421146] io scheduler deadline registered
[    1.421198] io scheduler cfq registered (default)
[    1.421243] pci 0000:00:00.0: Limiting direct PCI/PCI transfers
[    1.421332] pci 0000:01:00.0: Boot video device
[    1.421914] isapnp: Scanning for PnP cards...
[    1.775101] isapnp: No Plug & Play device found
[    1.780894] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[    1.800890] serial 00:09: activated
[    1.801202] 00:09: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.802061] PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:MOUS] at 0x60,0x64 irq 1,12
[    1.817253] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.817281] serio: i8042 AUX port at 0x60,0x64 irq 12
[    1.817693] mice: PS/2 mouse device common for all mice
[    1.817869] rtc_cmos 00:03: RTC can wake from S4
[    1.818040] rtc_cmos 00:03: rtc core: registered rtc_cmos as rtc0
[    1.818084] rtc0: alarms up to one month, y3k, 114 bytes nvram
[    1.818152] cpuidle: using governor ladder
[    1.818162] cpuidle: using governor menu
[    1.818182] No iBFT detected.
[    1.820283] TCP cubic registered
[    1.820450] NET: Registered protocol family 10
[    1.822765] lo: Disabled Privacy Extensions
[    1.824524] Mobile IPv6
[    1.824541] NET: Registered protocol family 17
[    1.824605] Using IPI No-Shortcut mode
[    1.825064] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0
[    1.825653] registered taskstats version 1
[    1.826071] rtc_cmos 00:03: setting system clock to 2009-11-12 22:26:51 UTC (1258064811)
[    1.826261] Freeing unused kernel memory: 340k freed
[    1.828194] Write protecting the kernel text: 2312k
[    1.828290] Write protecting the kernel read-only data: 824k
[    2.390503] fan PNP0C0B:00: registered as cooling_device0
[    2.390537] ACPI: Fan [FAN] (off)
[    2.488188] thermal LNXTHERM:01: registered as thermal_zone0
[    2.488231] ACPI: Thermal Zone [THM0] (64 C)
[    2.877172] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/device:01/device:02/input/input1
[    2.877206] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[    2.971519] Floppy drive(s): fd0 is 1.44M
[    2.991438] FDC 0 is a National Semiconductor PC87306
[    3.258162] Linux agpgart interface v0.103
[    3.305879] Uniform Multi-Platform E-IDE driver
[    3.400178] piix 0000:00:06.1: IDE controller (0x8086:0x7111 rev 0x01)
[    3.400248] PIIX_IDE 0000:00:06.1: power state changed by ACPI to D0
[    3.400320] piix 0000:00:06.1: not 100% native mode: will probe irqs later
[    3.400341]     ide0: BM-DMA at 0x1800-0x1807
[    3.400386]     ide1: BM-DMA at 0x1808-0x180f
[    3.400417] Probing IDE interface ide0...
[    3.410544] usbcore: registered new interface driver usbfs
[    3.411335] usbcore: registered new interface driver hub
[    3.412256] usbcore: registered new device driver usb
[    3.439473] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.459905] uhci_hcd: USB Universal Host Controller Interface driver
[    3.688285] hda: FUJITSU MHV2040AH, ATA DISK drive
[    4.360249] hda: host max PIO4 wanted PIO255(auto-tune) selected PIO4
[    4.364065] hda: UDMA/33 mode selected
[    4.367561] Probing IDE interface ide1...
[    5.104284] hdc: CRN-8241B, ATAPI CD/DVD-ROM drive
[    5.776479] hdc: host max PIO4 wanted PIO255(auto-tune) selected PIO4
[    5.776606] hdc: MWDMA2 mode selected
[    5.778977] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[    5.861074] ide1 at 0x170-0x177,0x376 on irq 15
[    5.867396] agpgart-intel 0000:00:00.0: Intel 440BX Chipset
[    5.874499] agpgart-intel 0000:00:00.0: AGP aperture is 64M @ 0xf8000000
[    5.876681] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
[    5.876706] uhci_hcd 0000:00:06.2: PCI INT D -> Link[LNKD] -> GSI 11 (level, low) -> IRQ 11
[    5.876740] uhci_hcd 0000:00:06.2: UHCI Host Controller
[    5.876877] uhci_hcd 0000:00:06.2: new USB bus registered, assigned bus number 1
[    5.876944] uhci_hcd 0000:00:06.2: irq 11, io base 0x00001820
[    5.877138] usb usb1: New USB device found, idVendor=1d6b, idProduct=0001
[    5.877154] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.877167] usb usb1: Product: UHCI Host Controller
[    5.877179] usb usb1: Manufacturer: Linux 2.6.31-1-686 uhci_hcd
[    5.877190] usb usb1: SerialNumber: 0000:00:06.2
[    5.877843] usb usb1: configuration #1 chosen from 1 choice
[    5.878265] hub 1-0:1.0: USB hub found
[    5.878324] hub 1-0:1.0: 2 ports detected
[    6.027121] SCSI subsystem initialized
[    6.182048] libata version 3.00 loaded.
[    6.286824] ide-gd driver 1.18
[    6.286987] hda: max request size: 128KiB
[    6.287226] hda: 78140160 sectors (40007 MB) w/8192KiB Cache, CHS=65535/16/63
[    6.288274] ide-cd driver 5.00
[    6.290807] hda: cache flushes supported
[    6.290977]  hda: hda1 hda2 hda3 hda4
[    6.351498] ide-cd: hdc: ATAPI 24X CD-ROM drive, 128kB Cache
[    6.351524] Uniform CD-ROM driver Revision: 3.20
[    6.815145] PM: Starting manual resume from disk
[    6.958026] kjournald starting.  Commit interval 5 seconds
[    6.958078] EXT3-fs: mounted filesystem with ordered data mode.
[    8.903474] udev: starting version 147
[    9.330590] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
[    9.330620] ACPI: Power Button [PWRF]
[    9.330933] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input3
[    9.332916] ACPI: Lid Switch [LID]
[    9.333302] input: Sleep Button as /devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input4
[    9.333333] ACPI: Sleep Button [SLPB]
[    9.595053] ACPI: AC Adapter [AC] (on-line)
[    9.604579] Non-volatile memory driver v1.3
[    9.898593] Marking TSC unstable due to TSC halts in idle
[    9.898847] ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
[    9.898987] processor LNXCPU:00: registered as cooling_device1
[    9.899011] ACPI: Processor [CPU0] (supports 8 throttling states)
[    9.930536] ACPI: Battery Slot [BAT1] (battery present)
[    9.930734] ACPI: Battery Slot [BAT2] (battery absent)
[   10.335966] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[   10.577045] parport_pc 00:0b: activated
[   10.577064] parport_pc 00:0b: reported by Plug and Play ACPI
[   10.577129] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
[   10.620207] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   10.631361] yenta_cardbus 0000:00:02.0: CardBus bridge found [1014:0130]
[   10.631400] yenta_cardbus 0000:00:02.0: Using INTVAL to route CSC interrupts to PCI
[   10.631413] yenta_cardbus 0000:00:02.0: Routing CardBus interrupts to PCI
[   10.631430] yenta_cardbus 0000:00:02.0: TI: mfunc 0x00001000, devctl 0x66
[   10.869757] yenta_cardbus 0000:00:02.0: ISA IRQ mask 0x0438, PCI irq 11
[   10.869774] yenta_cardbus 0000:00:02.0: Socket status: 30000020
[   10.870321] yenta_cardbus 0000:00:02.1: CardBus bridge found [1014:0130]
[   10.870360] yenta_cardbus 0000:00:02.1: Using INTVAL to route CSC interrupts to PCI
[   10.870373] yenta_cardbus 0000:00:02.1: Routing CardBus interrupts to PCI
[   10.870390] yenta_cardbus 0000:00:02.1: TI: mfunc 0x00001000, devctl 0x66
[   10.931203] NET: Registered protocol family 23
[   11.101456] yenta_cardbus 0000:00:02.1: ISA IRQ mask 0x0438, PCI irq 11
[   11.101474] yenta_cardbus 0000:00:02.1: Socket status: 30000006
[   11.494865] thinkpad_acpi: ThinkPad ACPI Extras v0.23
[   11.494881] thinkpad_acpi: http://ibm-acpi.sf.net/
[   11.494894] thinkpad_acpi: ThinkPad BIOS IUET25WW , EC unknown
[   11.496739] nsc-ircc 00:0a: activated
[   11.496866] nsc-ircc, chip->init
[   11.496879] nsc-ircc, Found chip at base=0x02e
[   11.496916] nsc-ircc, driver loaded (Dag Brattli)
[   11.502395] Registered led device: tpacpi::power
[   11.504640] Registered led device: tpacpi::standby
[   11.508130] pcmcia_socket pcmcia_socket0: pccard: CardBus card inserted into slot 0
[   11.508230] pci 0000:02:00.0: reg 10 io port: [0x00-0xff]
[   11.508252] pci 0000:02:00.0: reg 14 32bit mmio: [0x000000-0x0001ff]
[   11.508337] pci 0000:02:00.0: supports D1 D2
[   11.508349] pci 0000:02:00.0: PME# supported from D1 D2 D3hot
[   11.508365] pci 0000:02:00.0: PME# disabled
[   11.541477] IrDA: Registered device irda0
[   11.541496] nsc-ircc, Using dongle: IBM31T1100 or Temic TFDS6000/TFDS6500
[   11.547800] input: ThinkPad Extra Buttons as /devices/virtual/input/input5
[   11.569303] piix4_smbus 0000:00:06.3: IBM system detected; this module may corrupt your serial eeprom! Refusing to load module!
[   11.569408] piix4_smbus: probe of 0000:00:06.3 failed with error -1
[   11.590806] input: PC Speaker as /devices/platform/pcspkr/input/input6
[   11.672889] IBM TrackPoint firmware: 0x0b, buttons: 3/3
[   11.705244] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/input/input7
[   11.767773] Error: Driver 'pcspkr' is already registered, aborting...
[   11.835690] pcmcia_socket pcmcia_socket1: cs: IO port probe 0x100-0x3af: clean.
[   11.836877] pcmcia_socket pcmcia_socket1: cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
[   11.837448] pcmcia_socket pcmcia_socket1: cs: IO port probe 0x820-0x8ff: clean.
[   11.837950] pcmcia_socket pcmcia_socket1: cs: IO port probe 0xc00-0xcf7: clean.
[   11.839002] pcmcia_socket pcmcia_socket1: cs: IO port probe 0xa00-0xaff: clean.
[   11.869847] 8139too Fast Ethernet driver 0.9.28
[   11.869969] 8139too 0000:02:00.0: enabling device (0000 -> 0003)
[   11.870004] 8139too 0000:02:00.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
[   11.870038] 8139too 0000:02:00.0: setting latency timer to 64
[   11.874373] eth0: RealTek RTL8139 at 0x1400, 00:09:41:26:66:bd, IRQ 11
[   12.124410] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x100-0x3af: clean.
[   12.125488] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
[   12.126068] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x820-0x8ff: clean.
[   12.126580] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xc00-0xcf7: clean.
[   12.127684] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xa00-0xaff: clean.
[   12.200993] Sound Fusion CS46xx 0000:00:05.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
[   12.403352] Sound Fusion CS46xx 0000:00:05.0: firmware: requesting cs46xx/cs46xx-old.fw
[   12.477862] cs46xx: no firmware
[   12.477922] image download error
[   12.478387] Sound Fusion CS46xx 0000:00:05.0: PCI INT A disabled
[   12.478422] Sound Fusion CS46xx: probe of 0000:00:05.0 failed with error -5
[   12.812083] Clocksource tsc unstable (delta = -117535168 ns)
[   13.784928] Adding 488440k swap on /dev/hda3.  Priority:-1 extents:1 across:488440k 
[   14.112747] EXT3 FS on hda4, internal journal
[   14.481146] loop: module loaded
[   15.707572] kjournald starting.  Commit interval 5 seconds
[   15.707941] EXT3 FS on hda1, internal journal
[   15.707962] EXT3-fs: mounted filesystem with ordered data mode.
[   15.717149] kjournald starting.  Commit interval 5 seconds
[   15.717641] EXT3 FS on hda2, internal journal
[   15.717663] EXT3-fs: mounted filesystem with ordered data mode.
[   16.750959] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   19.093958] device-mapper: uevent: version 1.0.3
[   19.095825] device-mapper: ioctl: 4.15.0-ioctl (2009-04-01) initialised: dm-devel@redhat.com
[   27.264096] eth0: no IPv6 routers present
Comment 5 Hideki Yamane 2009-11-22 15:53:51 UTC
On Thu, 12 Nov 2009 05:46:34 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:
> Perhaps the stack protector code is playing up.  Please set
> CONFIG_CC_STACKPROTECTOR=n and retest.

 And, 2.6.32-rc8 works for me.

henrich@hatchpotch:~$ uname -a
Linux hatchpotch 2.6.32-rc8 #5 SMP Sun Nov 22 22:32:12 JST 2009 i686 GNU/Linux

henrich@hatchpotch:~$ grep STACKPROTECT /boot/config-2.6.32-rc8 
CONFIG_CC_STACKPROTECTOR=y
Comment 6 Florian Mickler 2010-10-01 08:16:25 UTC
I'm closing this then as fixed. Thank you.

Note You need to log in before you can comment on or make changes to this bug.