Bug 1456 - Poweroff fails on HP OmniBook 500 and other laptops in 2.4.22 and 2.4.23
Summary: Poweroff fails on HP OmniBook 500 and other laptops in 2.4.22 and 2.4.23
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Off (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-29 21:26 UTC by Adam Kessel
Modified: 2004-03-04 12:35 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.4.22, 2.4.23rc*
Tree: Mainline
Regression: ---


Attachments
acpi_power_off() 2.4 patch from Ducrot Bruno (704 bytes, patch)
2003-11-13 22:22 UTC, Len Brown
Details | Diff

Description Adam Kessel 2003-10-29 21:26:22 UTC
Distribution: Debian Unstable
Hardware Environment: HP OmniBook 500
Software Environment: Shutting down
Problem Description:

I posted this recently to lkml, but got no response, so I thought I would
report it here as well.[1] I also posted to acpi-devel.[2]

In 2.4.22-rc2, ACPI poweroff worked fine on the HP OmniBook.

Since 2.4.22, all the way up to 2.4.23-pre8, the system fails to
shutdown--the process gets to "power off" and hangs there. It is
necessary to do a hard shut down to turn the system off.

There is no problem with rebooting.

Apparently this effects a number of HP laptops, although I have only
verified it on the OmniBook 500.[3]

This problem is not present in any of the 2.6.0 kernels, up to -test9.

I am using force=acpi as required since I have an older BIOS.  Apparently
the problem occurs in OmniBook laptops they have newer BIOSes as well.

I expect this is related to the Sony VAIO problem discussed this month on
the acpi-devel list as well.[4]

[1] http://www.ussg.iu.edu/hypermail/linux/kernel/0310.1/1625.html
[2] http://sourceforge.net/mailarchive/forum.php?thread_id=3368475&forum_id=6102
[3] http://zurich.ai.mit.edu/pipermail/omnibook/2003-September/002805.html
[4] http://article.gmane.org/gmane.linux.acpi.devel/4770

Steps to reproduce: Shut down system
Comment 1 Len Brown 2003-11-13 22:22:18 UTC
Created attachment 1441 [details]
acpi_power_off() 2.4 patch from Ducrot Bruno

Please test this 2.4.(22, 23) patch from Ducrot Bruno.

thanks,
-Len
Comment 2 Adam Kessel 2003-11-14 00:21:59 UTC
That patch fixes the problem on the HP OB500. I have word from another user that
the problem persists on the HP nx7000.
Comment 3 Len Brown 2003-11-17 19:12:58 UTC
Thanks for verifying that the patch fixes the powerdown issue on the HP Omnibook. 
Marking this entry RESOLVED .  For failures on other systems please open a new bug. 
It seems that we have multiple ways of making poweroff not work, and they're not 
duplicates of this one. 
 
thanks, 
-Len 
 
Comment 4 Len Brown 2003-11-30 23:19:01 UTC
in 2.4.23 
 

Note You need to log in before you can comment on or make changes to this bug.