Bug 14556 - hang when looking at /proc/acpi/video/VGA/CRT/state with no display attached and kernel modesetting
Summary: hang when looking at /proc/acpi/video/VGA/CRT/state with no display attached ...
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jesse Barnes
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-08 08:40 UTC by Christian Lupien
Modified: 2010-07-23 19:50 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-rc6
Tree: Mainline
Regression: No


Attachments

Description Christian Lupien 2009-11-08 08:40:50 UTC
My laptop hangs if no external display is connected and I run:
 cat /proc/acpi/video/VGA/CRT/state
    or equivalently
 cat /sys/class/video_output/acpi_video0/state

This happens even when I boot in single mode.

If an external display is connected, or when running with the nomodeset kernel parameters then my laptop does not hang (in this case the i915 module is still loaded).

When a hang happens it occurs after a screen blank. As specified in the redhat bug (see below), I can fix the bug by commenting one instruction in the acpi code for my laptop.
The same bug is triggered by using the screen switch hotkey.

My setup is:
Machine: Fujitsu LifeBook S6231
lspci -nn -v:
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM
Integrated Graphics Device [8086:3582] (rev 02) (prog-if 00 [VGA controller])
 Subsystem: Fujitsu Limited. Device [10cf:126b]
 Flags: bus master, fast devsel, latency 0, IRQ 11
 Memory at d8000000 (32-bit, prefetchable) [size=128M]
 Memory at d0000000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at 2450 [size=8]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: [d0] Power Management version 1
 Kernel driver in use: i915
 Kernel modules: i915


This has been happening for a while. I have seen this in Fedora 11 and Fedora 12 beta. But I just tested it with mainline 2.6.32-rc6.

See redhat bug: 518251 (specially comment 1 and 4
 https://bugzilla.redhat.com/show_bug.cgi?id=518251
Comment 1 Jesse Barnes 2009-11-17 22:58:17 UTC
Hm sounds potentially opregion related.  Maybe we're not initializing some structures that ACPI needs to run those methods.  Matthew, I think you looked at those bits most recently, any ideas?
Comment 2 Jesse Barnes 2010-07-23 19:50:32 UTC
Ah this could be another dupe of https://bugs.freedesktop.org/show_bug.cgi?id=22126.  Can you try the patch in that bug and see if it fixes your case?

Note You need to log in before you can comment on or make changes to this bug.