Bug 14526 - no battery information after suspend
no battery information after suspend
Status: CLOSED DUPLICATE of bug 13745
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: acpi_power-battery
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-01 21:16 UTC by alebetco
Modified: 2009-11-17 01:42 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.31.5
Tree: Mainline
Regression: No


Attachments

Description alebetco 2009-11-01 21:16:01 UTC
after suspend or hibernate Compaq Presario CQ40-505la Notebook, the system indicates that there is no battery connected.

patch "drivers/acpi/sleep.c" solves the problem.

+	.callback = init_set_sci_en_on_resume,
+	.ident = "Hewlett-Packard Compaq Presario CQ40 Notebook PC",
+	.matches = {
+		DMI_MATCH(DMI_SYS_VENDOR, "Hewlett-Packard"),
+		DMI_MATCH(DMI_PRODUCT_NAME, "Compaq Presario CQ40 Notebook PC"),
+		},
+	},
Comment 1 Zhang Rui 2009-11-17 01:42:16 UTC
fixed by commit 2839d396e3ae0891c1fdd87aa1cea218e6f5c4df.
And this is also a duplicate of bug 13745

*** This bug has been marked as a duplicate of bug 13745 ***

Note You need to log in before you can comment on or make changes to this bug.