Bug 14525 - Second CPU core (Intel) not found, Thinks it is a Transmeta
Second CPU core (Intel) not found, Thinks it is a Transmeta
Status: RESOLVED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-11-01 15:01 UTC by Henk van Velden
Modified: 2009-12-31 10:57 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: Yes


Attachments
dmesg of openSUSE 10.3 (25.89 KB, text/plain)
2009-11-02 09:30 UTC, Henk van Velden
Details
dmesg of openSUSE 11.2 (45.62 KB, text/plain)
2009-11-02 09:31 UTC, Henk van Velden
Details
dmesg when booted with maxcpu=1 (24 bytes, text/plain)
2009-11-03 15:50 UTC, Henk van Velden
Details
dmesg when booted with maxcpu=1 (forget the one above please) (46.56 KB, text/plain)
2009-11-03 16:00 UTC, Henk van Velden
Details
dmesg on 11.2 using only one of 8 cores (52.69 KB, text/plain)
2009-12-02 04:49 UTC, John Emmer
Details

Description Henk van Velden 2009-11-01 15:01:10 UTC
On openSUSE 11.2 uname -a:
Linux boven 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux
and dmesg | grep CPU:
[    0.000000]   Transmeta TransmetaCPU
[    0.000000] Processor #0 (Bootup-CPU)
[    0.000000] SMP: Allowing 2 CPUs, 0 hotplug CPUs
[    0.000000] NR_CPUS:128 nr_cpumask_bits:128 nr_cpu_ids:2 nr_node_ids:8
[    0.000000] PERCPU: Embedded 14 pages at c1a25000, static data 34204 bytes
[    0.000000] Initializing CPU#0
[    0.032061] CPU: L1 I cache: 32K, L1 D cache: 32K
[    0.032065] CPU: L2 cache: 1024K
[    0.032069] CPU: Physical Processor ID: 0
[    0.032071] CPU: Processor Core ID: 0
[    0.032076] mce: CPU supports 6 MCE banks
[    0.032087] CPU0: Thermal monitoring enabled (TM2)
[    0.052039] Brought up 1 CPUs
[    0.052089] CPU0 attaching NULL sched-domain.
[    0.500998] Switched to high resolution mode on CPU 0
[    1.455278] processor LNXCPU:00: registered as cooling_device0
[   19.243956] powernow: This module only works with AMD K7 CPUs
[   55.014525] CPU0 attaching NULL sched-domain.
[   55.014601] CPU0 attaching NULL sched-domain.
---------------
On openSUSE 10.3 (same system of course) uname -a:
Linux boven 2.6.22.19-0.4-default #1 SMP 2009-08-14 02:09:16 +0200 i686 i686 i386 GNU/Linux
and dmesg | grep CPU:
Initializing CPU#0
CPU: After generic identify, caps: bfebfbff 20100000 00000000 00000000 0000e39d 00000000 00000001
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
CPU: After all inits, caps: bfebfbff 20100000 00000000 00003940 0000e39d 00000000 00000001
Intel machine check reporting enabled on CPU#0.
CPU0: Intel Genuine Intel(R) CPU            2140  @ 1.60GHz stepping 02
Initializing CPU#1
CPU: After generic identify, caps: bfebfbff 20100000 00000000 00000000 0000e39d 00000000 00000001
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 1
CPU: After all inits, caps: bfebfbff 20100000 00000000 00003940 0000e39d 00000000 00000001
Intel machine check reporting enabled on CPU#1.
CPU1: Intel Genuine Intel(R) CPU            2140  @ 1.60GHz stepping 02
checking TSC synchronization [CPU#0 -> CPU#1]: passed.
Brought up 2 CPUs
Switched to NOHz mode on CPU #0
Switched to NOHz mode on CPU #1
powernow: This module only works with AMD K7 CPUs
--------
Something seems to be wrong when initiating the CPU and one core is missing afterwards.
Comment 1 Henk van Velden 2009-11-01 15:04:59 UTC
I tried booting in secure mode, without apci and with nolapi, also tried kernel-default and kernel-pae. All give thesame result.
Comment 2 Henk van Velden 2009-11-01 15:47:26 UTC
I must correct that last Comment (sorry got a bit tired).

There is 'nolapi' in GRUBs menu.lst and I tried without, this will boot in a loop.

I tried also with 'acpi=off' and with 'noapic', same problem.

And, as said, kernel-default and kernel-pae do also have the problem.
Comment 3 Henk van Velden 2009-11-02 09:30:06 UTC
Created attachment 23620 [details]
dmesg of openSUSE 10.3

Someome told me I should have added the complete dmesg and not the part I did in the main post.
Comment 4 Henk van Velden 2009-11-02 09:31:36 UTC
Created attachment 23621 [details]
dmesg of openSUSE 11.2

And this is the one with the wrong CPU detection in openSUSE 11.2
Comment 5 Henk van Velden 2009-11-02 10:35:51 UTC
Hm, Reading through the complete 11.2 dmesg it seems that the Transmeta line is there only because it is a supported CPU type, NOT the CPU detected on this system.
 It seees two CPUs (od the correct tpe), but it initializes only one in the end.
Comment 6 Thomas Gleixner 2009-11-03 11:43:19 UTC
Comparing the dmesg of 10.3 and 11.2:

-Kernel command line: root=/dev/disk/by-id/scsi-SATA_Hitachi_HDT7250_VFJ201R23XUEXW-part2 vga=0x31a resume=/dev/sda1 splash=silent
+Kernel command line: root=/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part5 nolapic resume=/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part1 splash=silent quiet vga=0x31a

The 11.2 boot has "nolapic" on the kernel command line. SMP requires
the local apic to be enabled.

Can you please remove "nolapic" from the kernel command line ?

Thanks,

	tglx
Comment 7 Henk van Velden 2009-11-03 12:41:26 UTC
I tried that allready as can be seen from my Comment #2 (I admit Comment #1 was lousy). I tried again to be 100% sure.
Removing 'nolapic' from menu.lst: after hitting the Return key in the GRUB menu the screen goes dark for about 20 secs. Then the BIOS splash comes up. This cycles.
Comment 8 Thomas Gleixner 2009-11-03 12:57:09 UTC
> Removing 'nolapic' from menu.lst: after hitting the Return key in the GRUB menu
> the screen goes dark for about 20 secs. Then the BIOS splash comes up. This
> cycles.

Can you please remove the "splash=silent" option as well so you can
see what's happening ? Btw, does the box have a serial port ?

Thanks,

	tglx
Comment 9 Henk van Velden 2009-11-03 13:20:12 UTC
Removed "splash=silent". Stil seeing only a black screen for about 20 secs. It never comes to even loading the GRUB splash, let alone that Esc could be hit.

There is no serial port in the system.
Comment 10 Thomas Gleixner 2009-11-03 15:23:58 UTC
> Removed "splash=silent". Stil seeing only a black screen for about 20 secs. It
> never comes to even loading the GRUB splash, let alone that Esc could be hit.

Can you add "maxcpus=1" to the command line instead of "nolapic" ?

Thanks,

	tglx
Comment 11 Henk van Velden 2009-11-03 15:48:24 UTC
This one boots. I do not know what you want to see from it, but I gathered some data.

/proc/cmdline:
root=/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part5 maxcpus=1 resume=/dev/disk/by-id/ata-Hitachi_HDT725032VLA380_VFJ201R23XUEXW-part1 splash=silent quiet vga=0x31a

/proc/cpuinfo:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Genuine Intel(R) CPU            2140  @ 1.60GHz
stepping        : 2
cpu MHz         : 1200.000
cache size      : 1024 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc up arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips        : 3200.84
clflush size    : 64
power management:

uname -a:
Linux boven 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

And the complete dmesg as a an attachment follows.

Thanks for helping me.

Henk
Comment 12 Henk van Velden 2009-11-03 15:50:49 UTC
Created attachment 23636 [details]
dmesg when booted with maxcpu=1
Comment 13 Thomas Gleixner 2009-11-03 15:59:18 UTC
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=23636)
> dmesg when booted with maxcpu=1

The file contains only: "dmes: command not found"

which is telling me that youy fatfingered dmesg :)

   tglx
Comment 14 Henk van Velden 2009-11-03 16:00:24 UTC
Created attachment 23637 [details]
dmesg when booted with maxcpu=1 (forget the one above please)
Comment 15 John Emmer 2009-12-02 04:45:46 UTC
I am having a similar problem.  I upgraded from openSUSE 11.0 to 11.2 on my dual quad-core AMD system, and now only see one core instead of 8.  I tried switching to the 'default' kernel, thinking maybe 'desktop' didn't have the proper support for this system.  And I removed all the kernel options from the grub menu to make sure none were causing the issue.  I will provide information similar to what Henk has provided, and will provide more if needed.

uname -a
Linux server 2.6.31.5-0.1-default #1 SMP 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /proc/cmdline
root=/dev/md1 vga=0x31a

cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 16
model           : 2
model name      : Quad-Core AMD Opteron(tm) Processor 2344 HE
stepping        : 10
cpu MHz         : 1708.861
cache size      : 512 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc up rep_good nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs
bogomips        : 3417.71
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate
Comment 16 John Emmer 2009-12-02 04:49:05 UTC
Created attachment 23992 [details]
dmesg on 11.2 using only one of 8 cores
Comment 17 Jeff Mahoney 2009-12-02 21:48:18 UTC
Following along from Novell Bugzilla #551641

John, your issue looks like it may be different. Henk's dmesg reports "SMP: Allowing 4 CPUs, 2 hotplug CPUs", but yours only says, "SMP: Allowing 1 CPUs, 0 hotplug CPUs"

Henk, can you boot without maxcpus=1, without nolacpi, and without quiet and capture the results? I wonder if some useful messages are getting hidden because of 'quiet'. So far the things that we've observed that result in you having one usable CPU are because you've directed the kernel to do so (nolacpi and maxcpus=1). There's another bug in there that needs to be ferreted out.
Comment 18 John Emmer 2009-12-03 01:59:20 UTC
Jeff, should I file a separate ticket here and/or on the Novell Bugzilla?
Comment 19 Henk van Velden 2009-12-03 10:40:19 UTC
Booted without 'maxcpus=1' or 'nolapic'. Result is the same using 'quiet' or not and the same as booting from the openSUSE install DVD: after leaving the GRUB menu (either by time out or by return) the screen turns black for about 15 secs and then the hardware restarts. No information whatsoever on the screen.

(Using the install DVD does show a "loading the kernel" graphics before going to black).
Comment 20 Henk van Velden 2009-12-31 09:47:58 UTC
I got a lot of suggestions and help from Larry and Rafael and did the following:

1) installed kernel-desktop-2.6.32-3.5 from openSUSE repro. This was worse. Without maxcpus=1 (or nolapic) there was not even a boot loop, but darkness and silence after leaving the GRUB menue. I had to stop it using the power button. With maxcpus=1 also the same darkness, contrary to the earlier kernel that did run with one cpu.

2) Downloaded the source of 2.6.33-rc2 kernel. Generated and booted (without maxcpus=1 or nolapic). This time the system booted and according to dmesg two (2) CPUs were started.

Conclusion: regression worsened in 2.6.32-3.5, but fixed in 2.6.33-rc2.

Thanks for all the help.
Comment 21 Rafael J. Wysocki 2009-12-31 10:57:37 UTC
Closing, because it's been fixed in the mainline kernel.

Note You need to log in before you can comment on or make changes to this bug.