Bug 14481 - umount blocked for more than 120 seconds after USB drive removal
umount blocked for more than 120 seconds after USB drive removal
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
: 14463 (view as bug list)
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2009-10-26 17:48 UTC by Rafael J. Wysocki
Modified: 2009-11-21 15:28 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-26 17:48:42 UTC
Subject    : 2.6.32-rc4ish: task umount blocked for more than 120 seconds after USB drive removal
Submitter  : Robert Hancock <hancockrwd@gmail.com>
Date       : 2009-10-21 5:26
References : http://marc.info/?l=linux-kernel&m=125610280532245&w=4

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-10-27 08:27:33 UTC
On Tuesday 27 October 2009, Robert Hancock wrote:
> Haven't seen the problem again, but I haven't really tried to
> reproduce it, and haven't gotten any responses about it, so yes, it
> should still be listed.
Comment 2 Rafael J. Wysocki 2009-10-27 08:28:38 UTC
On Tuesday 27 October 2009, Yong Zhang wrote:
> On Tue, Oct 27, 2009 at 2:56 AM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.31.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=14481
> > Subject         : umount blocked for more than 120 seconds after USB drive removal
> > Submitter       : Robert Hancock <hancockrwd@gmail.com>
> > Date            : 2009-10-21 5:26 (6 days old)
> > References      : http://marc.info/?l=linux-kernel&m=125610280532245&w=4
> >
> >
> 
> I met the same problem on 2.6.32-rc5
Comment 3 Rafael J. Wysocki 2009-10-27 08:29:07 UTC
Notify-Also : Yong Zhang <yong.zhang0@gmail.com>
Comment 4 Pavel Machek 2009-10-28 08:08:10 UTC
...happened to me on -rc5...
Comment 5 Alan Stern 2009-11-17 15:51:40 UTC
This is supposedly fixed in -rc7.  Any results from testers?
Comment 6 Yanko Kaneti 2009-11-17 15:57:08 UTC
Fixed for me.
Comment 7 Peter Teoh 2009-11-21 15:28:38 UTC
*** Bug 14463 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.