Bug 14461 - msi-laptop kernel module corrupts battery status - MSI S271
msi-laptop kernel module corrupts battery status - MSI S271
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Platform_x86
i386 Linux
: P1 low
Assigned To: drivers_platform_x86@kernel-bugs.osdl.org
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2009-10-24 22:44 UTC by Filipp Andjelo
Modified: 2013-04-09 06:23 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.27 - 2.6.31
Tree: Mainline
Regression: No


Attachments
acpidump (85.61 KB, text/plain)
2009-10-26 18:44 UTC, Filipp Andjelo
Details
dmesg output (27.13 KB, text/plain)
2009-10-26 18:51 UTC, Filipp Andjelo
Details
The battery info before module load. (2.15 KB, text/plain)
2010-11-09 00:47 UTC, Mihail Kasadjikov
Details
The battery info after module load. (2.24 KB, text/plain)
2010-11-09 00:48 UTC, Mihail Kasadjikov
Details
MSI S271 dmidecode output (13.38 KB, text/plain)
2010-11-09 00:50 UTC, Mihail Kasadjikov
Details
Medion Akoya MD 96360 dmidecode (13.39 KB, application/octet-stream)
2010-11-09 09:05 UTC, Petr Cerny
Details

Description Filipp Andjelo 2009-10-24 22:44:01 UTC
Description:
Battery status (and maybe other ACPI info) on the MSI S271 is going mad once the module 'msi-laptop' is loaded. It is jumping up and down all the time, then the system think, that the power supply was plugged in for a second, the next one it is unplugged and so on.

Workaround:
Blacklist 'msi-laptop' and reboot. It's not enough just to unload the module. Some things, f.e. brightness control is not working then (although I've never seen it working, even with msi-laptop, but it should, may be it's the same problem), but you have at least a valid battery status.
Comment 1 Jean Delvare 2009-10-25 08:03:27 UTC
The msi-laptop driver is not a hardware monitoring driver. Moving to the right component.
Comment 2 Thomas Renninger 2009-10-26 12:53:27 UTC
Please attach acpidump.
Hmm, this is related to the EC, hopefully Alexey can help a bit.
But I could imagine an answer like: "Not these broken MSI ECs again"...
Comment 3 Alexey Starikovskiy 2009-10-26 13:05:20 UTC
Filipp,

Please start from attaching some info... dmesg, kernel version, etc.
Comment 4 Filipp Andjelo 2009-10-26 18:44:42 UTC
Created attachment 23537 [details]
acpidump
Comment 5 Filipp Andjelo 2009-10-26 18:51:40 UTC
Created attachment 23538 [details]
dmesg output

Here you have acpidump and dmesg output. My kernel version is 2.6.30.6, but it didn't work since at least 2.6.24. I hope you can find the problem and thank you for the effort. Write, if you need more information.
Comment 6 Alexey Starikovskiy 2009-12-24 11:32:18 UTC
Please check with latest 2.6.32 kernel
Comment 7 Mihail Kasadjikov 2010-03-05 14:03:37 UTC
The problem still exists in 2.6.32 and 2.6.33 kernels on MSI S271 laptop.
My comments in bug 14446.
Comment 8 Zhang Rui 2010-10-22 03:09:15 UTC
does the problem still exist in the latest upstream kernel? say 2.6.35 or 2.6.36-rc?
Comment 9 Petr Cerny 2010-11-07 23:44:20 UTC
I have been experiencing the same (or very similar) problem on my MSI laptop. After reading this bugreport I tried to actually *load* the msi_laptop module on 2.6.36 and the problem was gone.
Comment 10 Zhang Rui 2010-11-08 00:17:32 UTC
great. It seems that the problem is fixed in 2.6.36. Bug closed.
Mihail,
please feel free to re-open it if you can reproduce the problem in the latest upstream kernel, with msi_laptop driver loaded.
Comment 11 Petr Cerny 2010-11-08 13:54:08 UTC
Just for the record: after hibernation (using tuxonice), the problem appears again, until load *or* unload of msi-laptop happens. It seems as if module's init/cleanup does something essential.
Comment 12 Zhang Rui 2010-11-09 00:40:58 UTC
hah, it seems that the msi-laptop driver needs a .resume() callback.
Comment 13 Mihail Kasadjikov 2010-11-09 00:45:06 UTC
On my MSI S271 the problem still exists... :-(

hamer@hamer13:~$ sudo dmidecode -t 0x0002
# dmidecode 2.9
SMBIOS 2.5 present.

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
        Manufacturer: MSI
        Product Name: MS-1058
        Version: Ver 1.000
        Serial Number: BSS-0123456789
        Asset Tag: To Be Filled By O.E.M.
        Features:
                Board is a hosting board
                Board is replaceable
        Location In Chassis: To Be Filled By O.E.M.
        Chassis Handle: 0x0003
        Type: Motherboard
        Contained Object Handles: 0
Comment 14 Mihail Kasadjikov 2010-11-09 00:47:03 UTC
Created attachment 36852 [details]
The battery info before module load.

The battery info before module load.
Comment 15 Mihail Kasadjikov 2010-11-09 00:48:00 UTC
Created attachment 36862 [details]
The battery info after module load.
Comment 16 Mihail Kasadjikov 2010-11-09 00:50:21 UTC
Created attachment 36872 [details]
MSI S271 dmidecode output
Comment 17 Zhang Rui 2010-11-09 01:28:38 UTC
Petr,
please attach the dmidecode of your laptops.
Comment 18 Petr Cerny 2010-11-09 09:05:28 UTC
Created attachment 36882 [details]
Medion Akoya MD 96360 dmidecode

It's actually a rebranded MSI - sold as Medion Akoya
Comment 19 Lee, Chun-Yi 2010-12-09 04:50:44 UTC
(In reply to comment #12)
> hah, it seems that the msi-laptop driver needs a .resume() callback.

The newest msi-laptop driver already introduce the .resume callback but didn't do any thing for this issue.
The S271 is support by old EC command's path, and the msi-laptop driver only detect the acpi backlight support when driver init.

I am trying to borrow this old machine for debug.
Comment 20 Lee, Chun-Yi 2010-12-09 07:09:29 UTC
Before I got the machine...

Found there have 2 different BIOS for S271 on MSI web site, one for Vista, another one is for XP:
http://www.msi.com/index.php?func=downloaddetail&type=bios&maincat_no=135&prod_no=662

We need someone help to ask MSI why there have Vista BIOS (support ACPI?) and one is for XP.
Comment 21 Lee, Chun-Yi 2010-12-09 07:12:11 UTC
Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
	Vendor: American Megatrends Inc.
	Version: A1058AMS V3.38

This BIOS version is for XP.
Comment 22 Mihail Kasadjikov 2010-12-09 12:06:55 UTC
I have a XP BIOS v3.38

# dmidecode 2.9
SMBIOS 2.5 present.
47 structures occupying 1737 bytes.
Table at 0x000FACD0.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: American Megatrends Inc.
        Version: A1058AMS V3.38
        Release Date: 03/13/2008
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 512 kB
        Characteristics:
                ISA is supported
                PCI is supported
                PNP is supported
                APM is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                ESCD support is available
                Boot from CD is supported
                Selectable boot is supported
                BIOS ROM is socketed
                EDD is supported
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 KB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                CGA/mono video services are supported (int 10h)
                ACPI is supported
                USB legacy is supported
                AGP is supported
                Smart battery is supported
                BIOS boot specification is supported
        BIOS Revision: 8.12
Comment 23 Filipp Andjelo 2010-12-09 16:31:33 UTC
I don't have that notebook anymore, because running Linux on that machine was very painful experience. My request by MSI was answered with: "It doesn't work with Linux and never will be, just forget it". It was the stupidest answer I've ever expected to get from MSI, so I forgot it and decided to buy me a new one (never MSI again!). But as I had nothing more to lose, I flashed the Vista BIOS on the machine, with no result. I mean, I didn't noticed any changes, same problems with ACPI running Linux, it was just another BIOS version number, not more.
I've also installed Windows XP, since I've expected kinda problems running Vista BIOS. But my expectation was not confirmed. I still do not know, why MSI did that thing, but I don't have the hardware anymore to help in this case.
Comment 24 Mihail Kasadjikov 2010-12-09 22:05:39 UTC
I have a MSI S271 laptop for four years and found only two problems:
1. ugly ACPI (problem on modern kernels)
2. glossy screen (very bad idea)
Everything else - isn't worse than at competitors.
Comment 25 Lee, Chun-Yi 2010-12-10 02:07:39 UTC
hm....... sigh, too bad!

The old machine have bad Linux experience. As I know, before 2 years ago MSI start to _real_ bundle with Linux to ship their machine, hope their current BIOS already more Linux friendly compare with 4 years ago.

Thank's for Filipp and Mihail's kindly comments, hope I am lucky can borrow this old machine then take look what's happen.
Comment 26 Lee, Chun-Yi 2010-12-31 09:15:21 UTC
Unfortunately I cann't borrow this machine from my friend, it's too old and there have no sample machine keep on his hand.

Sorry about I cann't do more work because there nobody have the machine.

Note You need to log in before you can comment on or make changes to this bug.