Bug 14448 - PAT cpu feature is absent but detected by Xorg and others, cuses video driver problems
PAT cpu feature is absent but detected by Xorg and others, cuses video driver...
Status: CLOSED UNREPRODUCIBLE
Product: Memory Management
Classification: Unclassified
Component: MTTR
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2009-10-20 17:54 UTC by Aleksei Lukin
Modified: 2011-03-05 00:16 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.31-14-generic #48-Ubuntu SMP
Tree: Mainline
Regression: Yes


Attachments
output of cat /proc/cpuinfo and x86info (1.05 KB, text/plain)
2009-10-20 17:56 UTC, Aleksei Lukin
Details

Description Aleksei Lukin 2009-10-20 17:54:18 UTC
On Intel-M (Dothan) [B-1] PAT feature is absent and kernel says so in /proc/cpuinfo and in kernel messages in boot time. But certain programs like Xorg, x86info "see" PAT support and take wrong behavior path.

For instance, nouveau driver just hangs on latest Ubuntu 9.10, nvidia drivers can not load GL support and so on. 

Problem can be solved by passing "nopat" argument in kernel command line and then everithing works, but x86info still reports "pat" in CPU flags.

The same situation in latest Fedora 11 kernels. 

output of cat /proc/cpuinfo and x86info are attached.
Related Ubuntu bug discussion is here: 
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/391461
Comment 1 Aleksei Lukin 2009-10-20 17:56:52 UTC
Created attachment 23479 [details]
output of cat /proc/cpuinfo and x86info

output of cat /proc/cpuinfo and x86info
Comment 2 Florian Mickler 2011-02-06 15:04:12 UTC
Hi Aleksei!
Did this get resolved somehow, or is this still an issue?
Comment 3 Aleksei Lukin 2011-02-07 09:40:21 UTC
Yes, it resolved since Fedora 12, can not remember which kernel version.
Comment 4 Florian Mickler 2011-03-05 00:16:08 UTC
Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.