Bug 14398 - Blank display on resume from Suspend-to-RAM (HP ZV5400t CTO laptop)
Blank display on resume from Suspend-to-RAM (HP ZV5400t CTO laptop)
Status: CLOSED DUPLICATE of bug 11255
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
All Linux
: P1 normal
Assigned To: ykzhao
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 01:58 UTC by Random Guy
Modified: 2009-11-25 05:31 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.31.1
Tree: Mainline
Regression: No


Attachments
Output of lspci -vv (13.02 KB, text/plain)
2009-10-13 01:58 UTC, Random Guy
Details
acpidump (72.55 KB, application/octet-stream)
2009-10-13 02:01 UTC, Random Guy
Details
Output of dmesg post wakeup (73.72 KB, text/plain)
2009-10-13 02:11 UTC, Random Guy
Details

Description Random Guy 2009-10-13 01:58:50 UTC
Created attachment 23372 [details]
Output of lspci -vv

I've been trying for sometime to get suspend-to-ram to work but have had no success over a range of kernels going all the way back to the 2.4.x series. FWIW, suspend-to-ram works on windows xp.

I'm attatching the following that may help shed some light on this.
1) dmesg  *after* Test#2 
2) Output of lspci -vv
3) Output of acpidump 

Current kernel: 2.6.31.1
Last working kernel: none
Distro: slackware 13.0

Laptop: HP ZV5400T CTO       (HP Pavilion laptop)

Suspend-to-ram Tests

Test #1
Suspend:
-- Exit X-windows
-- go to single user (telinit 1), verified no acpid running
-- echo mem > /sys/power/state

Result:
-- System goes into suspend state. 
    Indications: power button flashing, power LED flashing, similar to standby in windows

Wakeup:
-- Push flashing power button
-- Fan turns on
-- Hard drive spins up
-- LCD display is blank and remains blank
-- CAPS Lock light does not come on when pushed

Test #2
To suspend:
-- Exit X-windows
-- go to single user (telinit 1) verified no acpid running
-- echo core > /sys/power/pm_test
-- echo mem > /sys/power/state

Result:
	System goes into suspend state 

Wakeup:
	Returns after 5-10 secs
	Display works, everything appears to work normally.

Other observations: 
Per the hint in the logs, adding acpi.gts=1 makes no difference
Comment 1 Random Guy 2009-10-13 02:01:42 UTC
Created attachment 23373 [details]
acpidump
Comment 2 Random Guy 2009-10-13 02:11:00 UTC
Created attachment 23374 [details]
Output of dmesg post wakeup
Comment 3 ykzhao 2009-10-13 07:29:43 UTC
Hi
   Will you please confirm whether this is a resume issue or blank display?
   Will you please do the following test and see whether the box can be resumed from sleeping state?
   1. echo mem > /sys/power/state; dmesg >dmesg_after; sync; reboot
   2. press the power button
   3. reboot the system and check whether the file of dmesg_after is created. If it is created, please attach the file of dmesg_after.
 
   If the file of dmesg_after is created, then it is related with Radeon graphics driver.
 
Thanks.
Comment 4 Random Guy 2009-10-15 01:51:38 UTC
(In reply to comment #3)
> Hi
>    Will you please confirm whether this is a resume issue or blank display?

I'm not sure how to answer this question, so I'll just describe what I see.

After putting the machine successfully into the suspend state, once the "flashing" power button is pushed to "resume", the following is observed:
1) the power button stops flashing and remains lit just like it does during normal operation
2) the fan comes back on
3) the display never comes back and *remains* blank
4) the cap lock LED does not light up when the caps lock button is pushed.

>    Will you please do the following test and see whether the box can be resumed
> from sleeping state?
>    1. echo mem > /sys/power/state; dmesg >dmesg_after; sync; reboot
>    2. press the power button
>    3. reboot the system and check whether the file of dmesg_after is created.
> If it is created, please attach the file of dmesg_after.
> 
>    If the file of dmesg_after is created, then it is related with Radeon
> graphics driver.
> 
> Thanks.

I ran the above commands and no file "dmesg_after" is created. 

NOTE:  As with past attempts, I have to power down the machine to get the display working again.

Thanks.
Comment 5 ykzhao 2009-11-06 06:41:16 UTC
Thanks for the confirmation.
From the test it seems that the box can't be resumed after pressing the power button. Maybe it is related with the BIOS.
In fact we see such issue on many boxes.

And this bug will be marked as the dup of bug 11255.

Thanks.
Comment 6 ykzhao 2009-11-06 06:42:58 UTC

*** This bug has been marked as a duplicate of bug 11255 ***

Note You need to log in before you can comment on or make changes to this bug.