Bug 14392 - Touchpad "paste" stops working after suspend to RAM
Touchpad "paste" stops working after suspend to RAM
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2009-10-11 21:54 UTC by Rafael J. Wysocki
Modified: 2009-10-26 16:41 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-rc
Tree: Mainline
Regression: Yes


Attachments
syslog with i8042.debug across a s2ram with Dmitry's patch (413.02 KB, text/plain)
2009-10-13 23:06 UTC, Carlos R. Mafra
Details
syslog with i8042.debug and atkbd.reset across a s2ram with Dmitry's patch (374.93 KB, text/plain)
2009-10-14 00:47 UTC, Carlos R. Mafra
Details
dmesg with i8042.nomux i8042.debug and atkbd.reset (90.82 KB, text/plain)
2009-10-14 10:57 UTC, Carlos R. Mafra
Details
dmidecode of my Vaio laptop (6.18 KB, text/plain)
2009-10-14 11:01 UTC, Carlos R. Mafra
Details

Description Rafael J. Wysocki 2009-10-11 21:54:18 UTC
Subject    : [bisected regression] Touchpad "paste" stops working after suspend to RAM
Submitter  : "Carlos R. Mafra" <crmafra2@gmail.com>
Date       : 2009-10-11 16:21
References : http://marc.info/?l=linux-kernel&m=125527987316493&w=4
Handled-By : Dmitry Torokhov <dmitry.torokhov@gmail.com>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Carlos R. Mafra 2009-10-13 23:06:25 UTC
Created attachment 23397 [details]
syslog with i8042.debug across a s2ram with Dmitry's patch
Comment 2 Carlos R. Mafra 2009-10-14 00:47:00 UTC
Created attachment 23399 [details]
syslog with i8042.debug and atkbd.reset across a s2ram with Dmitry's patch

The "paste" works after s2ram with Dmitry's patch applied. This syslog provides
more debugging information that Dmitry wants.
Comment 3 Carlos R. Mafra 2009-10-14 10:57:33 UTC
Created attachment 23402 [details]
dmesg with i8042.nomux i8042.debug and atkbd.reset
Comment 4 Carlos R. Mafra 2009-10-14 11:01:34 UTC
Created attachment 23403 [details]
dmidecode of my Vaio laptop
Comment 5 Marc Bejarano 2009-10-20 20:03:08 UTC
looks like the combination of patches from http://marc.info/?l=linux-kernel&m=125547616624781&w=4 and http://marc.info/?l=linux-kernel&m=125556759426974&w=4 fix this.
Comment 6 Dmitry Torokhov 2009-10-20 21:38:45 UTC
Yes, as soon as Linux pulls my changes into mainline this bug will be closed.
Comment 7 Dmitry Torokhov 2009-10-22 15:48:32 UTC
In mainline now.
Comment 8 Rafael J. Wysocki 2009-10-26 16:41:26 UTC
Fixed by commit b0225e8f1023ff1323e2de4caa148813eea71385 .

Note You need to log in before you can comment on or make changes to this bug.