Bug 14384 - tbench regression with 2.6.32-rc1
Summary: tbench regression with 2.6.32-rc1
Status: CLOSED CODE_FIX
Alias: None
Product: Process Management
Classification: Unclassified
Component: Scheduler (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Ingo Molnar
URL:
Keywords:
Depends on:
Blocks: 14230
  Show dependency tree
 
Reported: 2009-10-11 21:16 UTC by Rafael J. Wysocki
Modified: 2009-11-23 19:15 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-11 21:16:28 UTC
Subject    : tbench regression with 2.6.32-rc1
Submitter  : "Zhang, Yanmin" <yanmin_zhang@linux.intel.com>
Date       : 2009-10-09 9:51
References : http://marc.info/?l=linux-kernel&m=125508216713138&w=4
Handled-By : Peter Zijlstra <a.p.zijlstra@chello.nl>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 59abf02644c45f1591e1374ee7bb45dc757fcb88
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Wed Sep 16 08:28:30 2009 +0200

    sched: Add SD_PREFER_LOCAL

First-Bad-Commit : 59abf02644c45f1591e1374ee7bb45dc757fcb88
Comment 1 Yanmin Zhang 2009-11-23 00:57:45 UTC
With kernel 2.6.32-rc7:

On core2 arch machines, tbench regression becomes about 4%. Originally, the
regression is about 33%.

On Nehalem, tbench regression is about 4%. Original is 7%.

On Itanium, tbench regression is about 16%. Original is 26%

As for the surplus regression, I suspect it's related to commit de69a80be32445. Peter already has an improved patch against commit de69a80be32445.

As the regression becomes far smaller, we might close the bug report now.
Comment 2 Rafael J. Wysocki 2009-11-23 19:15:02 UTC
Closing.

Note You need to log in before you can comment on or make changes to this bug.