Bug 14383 - hackbench regression with kernel 2.6.32-rc1
Summary: hackbench regression with kernel 2.6.32-rc1
Status: CLOSED CODE_FIX
Alias: None
Product: Process Management
Classification: Unclassified
Component: Scheduler (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Ingo Molnar
URL:
Keywords:
Depends on:
Blocks: 14230
  Show dependency tree
 
Reported: 2009-10-11 21:13 UTC by Rafael J. Wysocki
Modified: 2009-11-23 19:15 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-11 21:13:13 UTC
Subject    : hackbench regression with kernel 2.6.32-rc1
Submitter  : "Zhang, Yanmin" <yanmin_zhang@linux.intel.com>
Date       : 2009-10-09 9:19
References : http://marc.info/?l=linux-kernel&m=125508007510274&w=4
Handled-By : Peter Zijlstra <a.p.zijlstra@chello.nl>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 29cd8bae396583a2ee9a3340db8c5102acf9f6fd
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Thu Sep 17 09:01:14 2009 +0200

    sched: Fix SD_POWERSAVING_BALANCE|SD_PREFER_LOCAL vs SD_WAKE_AFFINE

and 

commit de69a80be32445b0a71e8e3b757e584d7beb90f7
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Thu Sep 17 09:01:20 2009 +0200

    sched: Stop buddies from hogging the system
Comment 1 Rafael J. Wysocki 2009-10-11 21:13:46 UTC
First-Bad-Commit : 29cd8bae396583a2ee9a3340db8c5102acf9f6fd
Comment 2 Yanmin Zhang 2009-11-23 00:51:26 UTC
On core2 arch machines, hackbench regression disappears and there is much
improvement instead of regression. 
On Nehalem machine, no big change, comparing with 2.6.31.

On Itanium machines (2 sockets or 4 sockets), the regression become
about 20%. Originally it's 70%.

I think we could close the bug report now. I might continue to investigate the regression on Itanium machine.
Comment 3 Rafael J. Wysocki 2009-11-23 19:15:43 UTC
Closing.

Note You need to log in before you can comment on or make changes to this bug.