Bug 14381 - iwlagn lost connection after s2ram (with warnings)
Summary: iwlagn lost connection after s2ram (with warnings)
Status: CLOSED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 14230
  Show dependency tree
 
Reported: 2009-10-11 21:06 UTC by Rafael J. Wysocki
Modified: 2009-10-31 19:04 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-10-11 21:06:10 UTC
Subject    : [2.6.32-rc3] iwlagn lost connection after s2ram (with warnings)
Submitter  : "Carlos R. Mafra" <crmafra2@gmail.com>
Date       : 2009-10-07 14:20
References : http://marc.info/?l=linux-kernel&m=125492569119947&w=4
Notify-Also : reinette chatre <reinette.chatre@intel.com>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Reinette Chatre 2009-10-28 23:39:58 UTC
The following two patches address the warning, they are on their way to linux-2.6:

Johannes Berg (2):
      mac80211: keep auth state when assoc fails
      cfg80211: sme: deauthenticate on assoc failure
Comment 2 Carlos R. Mafra 2009-10-31 13:54:22 UTC
I can't reproduce it anymore, and the patches mentioned above are already
in mainline ( 2ef6e444 and 7d930bc3 )
As far as I am concerned, this bug can be closed. Thanks!

Note You need to log in before you can comment on or make changes to this bug.